Centos ignorming modprobe.d conf file

General support questions
Post Reply
kevins7189
Posts: 7
Joined: 2016/09/13 21:52:40

Centos ignorming modprobe.d conf file

Post by kevins7189 » 2018/07/10 16:30:58

Hi
I'm trying to set up a module config file, which according to the docs is supposed to be in /etc/modprobe.d/.

So I have a ixgbe 10g card dual port, and I have an ixgbe module version: 5.1.0-k-rh7.5
and I have a file /etc/modprobe.d/ixgbe.conf
with the following contents
options ixgbe AtrSampleRate=0,0 MQ=1,1 RSS=8,8

These are completely ignored at boot. How do I get them to take at boot time?

Also, completely ignored at boot, I compiled the latest ixgbe driver, which installed in /lib/modules/<kernel>/updates/drivers/net/ethernet/intel/ixgbe

Why does this get ignored also?

thanks!

User avatar
TrevorH
Forum Moderator
Posts: 23867
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Centos ignorming modprobe.d conf file

Post by TrevorH » 2018/07/10 17:02:16

First off, building from source is not recommended. Your new driver will break each and every time there is a new kernel comes out and you will lose network access and it'll need to be rebuilt each time.

Most likely you need to rebuild your initramfs for the current kernel as modules for important hardware are all loaded from there at boot time, before the root filesystem is even mounted and your updated driver and .conf file are in there.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kevins7189
Posts: 7
Joined: 2016/09/13 21:52:40

Re: Centos ignorming modprobe.d conf file

Post by kevins7189 » 2018/07/10 17:21:14

it "seems" that the Redhat version of the ixgbe driver doesn't accept module options. I was able to build the ixgbe driver from source and rebuild the initramfs with dracut --force.
The intel driver read the options I placed the modprobe.d/ixgbe.conf file.

Post Reply