Capslock light is blinking when installing to Dell XPS 15 9560

General support questions
bluepanic
Posts: 2
Joined: 2018/07/18 08:11:35

Capslock light is blinking when installing to Dell XPS 15 9560

Post by bluepanic » 2018/07/18 08:28:32

Hi, i have failed to to install centos 7 everything 1804 iso from usb stick to my Dell XPS 15 9560 UHD.

Actually the first 500-1000 package can be successfully installed but after 13xx. package(another time 8xx.) screen is freezing and after 1 second capslock on/off light is blinking until i do hard reset by holding the power button 3-4 second. Last package seen on the freezed screen was always different.

Iso file and after-write usb sha256 hash check is ok and tested media before installation via test media & instal option. Installed Windows 10 with the same usb stick and laptop succesfully after failed with centos.

I also had success on installing centos with minimal base environment with no add-ons. It successfully boots to the terminal and commands works ok.

Laptop is mid-2017 and the usb stick is Sandisk Ultra Flair 16gb Usb3.0

Usb stick was connected to the laptop directly without extender cable or usb hub.

User avatar
TrevorH
Forum Moderator
Posts: 23632
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by TrevorH » 2018/07/18 13:17:29

The keyboard LEDs flashing is a sign that the kernel paniced. I would start by downloading, booting and running memtest86+ for several hours - preferably overnight - and see if that finds any hardware problems.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

bluepanic
Posts: 2
Joined: 2018/07/18 08:11:35

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by bluepanic » 2018/07/23 23:15:56

TrevorH wrote:
2018/07/18 13:17:29
The keyboard LEDs flashing is a sign that the kernel paniced. I would start by downloading, booting and running memtest86+ for several hours - preferably overnight - and see if that finds any hardware problems.
Image

It seems ok.

beyondinsanity
Posts: 2
Joined: 2018/07/31 22:22:12

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by beyondinsanity » 2018/07/31 22:25:57

I made an account on this forum to reply regarding this issue; so far, I'm experiencing the same thing when I attempt to install CentOS 7 1804 and I select the option to install GNOME as well. I'll reply back after I continue to test.

beyondinsanity
Posts: 2
Joined: 2018/07/31 22:22:12

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by beyondinsanity » 2018/07/31 23:27:45

Confirmed kernel panic when installing with KDE Plasma Desktop selected as well. I then tried installing with minimal software (no selected packages) and the kernel panic when I clicked "Reboot" after a successful installation. For now, I'm going to try Fedora as I can't identify why this is happening.

romczak
Posts: 1
Joined: 2018/08/10 23:13:45

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by romczak » 2018/08/10 23:26:18

I had the same issue an it was happening at different stages of installation. Adding pcie_aspm=off kernel parameter helped in my case.

desertcat
Posts: 440
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by desertcat » 2018/08/12 02:03:47

beyondinsanity wrote:
2018/07/31 23:27:45
Confirmed kernel panic when installing with KDE Plasma Desktop selected as well. I then tried installing with minimal software (no selected packages) and the kernel panic when I clicked "Reboot" after a successful installation. For now, I'm going to try Fedora as I can't identify why this is happening.
There are a couple of things you might want to try as an experiment:

1) Burn a NEW DVD and check that the MD5sum or what ever CentOS7 uses, match. A corrupted DVD can cause a lot of problems.

2) Burn a NEW DVD of something like the latest version of Fedora, and confirm its MD5sum is correct.

Install CentOS 7.5 and see if you still have the problem. If the problem persists then do an install with Fedora, and see if you have the same problem.

Pure guesses as to what *may* be the problem:

1) That is a real nice laptop using an Intel i7 CPU plus DDR4 memory. It is possible that the hardware is beyond what the CentOS kernel can handle.

2) No doubt given that the laptop has Windows 10 pre-installed that it is using UEFI as the BIOS. It might be worthwhile to poke around in BIOS and see if you can set a Legacy BIOS and then try a re-install.

3) if you have one floating around, install am external HDD or SSD and try to install it on there (Better yet if it is not a GIANT PITA -- and with laptops unless they have changed that's a given -- install a new a NEW internal SSD or HDD. It is possible Windows 10 has hijacked the HDD (or SSD) and refuses to recognize the installation of any other OS, in other words trying to install CentOS on a UEFI BIOS where Windows 10 controls the keys to the kingdom is a no go. Remember UEFI is a "security" feature. A blank HDD or SSD with no OS on it can be written to, whereas a HDD or SSD with Windows 10 on it can not.

I wish I could give you better news, but experimentation is the best way to narrow down the problem. It may be hardware and kernel incompatability; it may be a BIOS problem; it may be some whacked out "security" feature that Windows 10 enforces that prevents any other OS from being installed; it might be something simple such as corrupted media used during the install process. If you can narrow down the problem to one thing, and reproduce the results over and over using a "control" ie it does not work here, but does here then you are one step closer to solving the problem.

Keep us posted as to your findings.

User avatar
warron.french
Posts: 283
Joined: 2014/03/27 20:21:58

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by warron.french » 2018/08/21 02:27:43

romczak wrote:
2018/08/10 23:26:18
I had the same issue an it was happening at different stages of installation. Adding pcie_aspm=off kernel parameter helped in my case.
How did you apply this kernel parameter during the installation phase?

Thank you.
\\War

User avatar
TrevorH
Forum Moderator
Posts: 23632
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by TrevorH » 2018/08/21 08:49:17

When you boot from DVD (or whatever), when you see the first menu which asks whether to install, verify media then install or Troubleshooting, highlight the install choice and press the tab key. That gives you access to the kernel command line. Remove 'quiet' from the end and append the parameter you want to add then press enter to boot up using it.

If installing on a UEFI capable system then the initial install menu is different as it uses grub and then you can just use the normal 'e' to edit, ctrl-x to boot method that you'd use on the normal installed system.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
warron.french
Posts: 283
Joined: 2014/03/27 20:21:58

Re: Capslock light is blinking when installing to Dell XPS 15 9560

Post by warron.french » 2018/08/21 17:32:13

TrevorH wrote:
2018/08/21 08:49:17
When you boot from DVD (or whatever), when you see the first menu which asks whether to install, verify media then install or Troubleshooting, highlight the install choice and press the tba key. That gives you access to the kernel command line. Remove 'quiet' from the end and append the parameter you want to add then press enter to boot up using it.

If installing on a UEFI capable system then the initial install menu is different as it uses grub and then you can just use the normal 'e' to edit, ctrl-x to boot method that you'd use on the normal installed system.
Thanks Trevor, so select the "install option" then hit [Tab] key to gain access to the GRUB menu and remove the 'quiet' attribute and then add in the 'pcie_aspm=off.' I will try that tonight. I am having problems installing CentOS 7 from DvD onto a Dell Latitude D630 machine and it has enough RAM and CPU power from what I can tell. The memfree86+ test has been running for over 24 hours (we are almost into day 2 = 48 hours). I really want to run CentOS on it.
\\War

Post Reply