Not Able to Boot Redhat/CentOS 7.4

General support questions
Post Reply
Mar
Posts: 4
Joined: 2018/08/19 15:15:33

Not Able to Boot Redhat/CentOS 7.4

Post by Mar » 2018/08/19 15:31:03

Hello all,

Thank you in advance and in debt to you.

I have been using Ubuntu since 2010 and Redhat and CentOS since 2017. I build my PC and change hardware all of the time. The last time I did, I had Redhat 7.4 drive with all of my work, KVM with CentOS7.4. I also had windows 10 drive, separate drives that I can load to from BIOS. I changed the PC case, meaning, every hardware had to come and put it all together again. I have done this many times but with windows and Ubuntu. Never an issue before. Except the last time I did this, here are the errors I get.

I had to resize the images, if not clear please let me know. As you can see, I can edit the regular and the rescue and terminal, but I don't know what I am doing or how to get the kernel back without losing all of my work.

If no way to go around it, I understand. It is years of work lost if I have to fresh install.

Thank you again,

Mar
Attachments
20180819_110031-640x311.jpg
20180819_110031-640x311.jpg (27.25 KiB) Viewed 141 times

Mar
Posts: 4
Joined: 2018/08/19 15:15:33

Re: Not Able to Boot Redhat/CentOS 7.4

Post by Mar » 2018/08/19 15:53:36

Also, can boot to the windows 10 fine, no issues at all.

I don't see other images but this is the second important image. Maybe one image per post it seems.
Attachments
20180819_111030-640x311.jpg
20180819_111030-640x311.jpg (35.83 KiB) Viewed 136 times

hunter86_bg
Posts: 1315
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: Not Able to Boot Redhat/CentOS 7.4

Post by hunter86_bg » 2018/08/20 04:21:21

Sometimes UEFI gets picky.
Can you boot a CentOS7 iso and check that everything is fine ? Also make a backup.
I'm pretty bad with UEFI and thus I won't advise you anything beyond that point.

Mar
Posts: 4
Joined: 2018/08/19 15:15:33

Re: Not Able to Boot Redhat/CentOS 7.4

Post by Mar » 2018/08/20 11:29:58

Thank you for your comment.
Yes I can load an USB ISO, troubleshoot, rescue mode with the redhat 7.4.
Select to continue with 1, then write chroot for the sysimage to mount.

However, I can not move beyond that. The ls /dva/sd* shows me the drives but not able to install on the machine passed that.

Mar
Posts: 4
Joined: 2018/08/19 15:15:33

Re: Not Able to Boot Redhat/CentOS 7.4

Post by Mar » 2018/08/21 02:10:56

On a LS command from Grun terminal.

Here is the details. Am I SOL on here?

These are all of the drives that supposed to have a grub on one of them at least.

Is there any other way to load up the grub at all?

Thanks,
Attachments
20180820_220655-640x311.jpg
20180820_220655-640x311.jpg (51.2 KiB) Viewed 67 times

Post Reply