Dropbox - glibc and file systems support

General support questions
DangerD
Posts: 2
Joined: 2018/12/14 08:47:07

Re: Dropbox - glibc and file systems support

Post by DangerD » 2018/12/14 08:49:05

(CentOS 7)
Now i'm getting this:

Code: Select all

[ALERT]: So your files continue to sync, sign in to your Dropbox account and move Dropbox to a supported file system.

 ~/bin/dropbox.py status
Syncing paused
Any solution with that?

User avatar
TrevorH
Forum Moderator
Posts: 26936
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dropbox - glibc and file systems support

Post by TrevorH » 2018/12/14 09:05:35

Is it on an ext4 filesystem?
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

abalogh
Posts: 1
Joined: 2018/12/21 06:25:53

Re: Dropbox - glibc and file systems support

Post by abalogh » 2018/12/21 06:43:16

For me pgreco's fix was working at the beginning of December and now it stopped working.
My file system is default xfs.

User avatar
TrevorH
Forum Moderator
Posts: 26936
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dropbox - glibc and file systems support

Post by TrevorH » 2018/12/21 09:32:19

They made 2 changes: one was to require a newer glibc - which is addressed by pgreco's bypass - and the other to only work if you use ext4 - which is not addressed by that fix and needs to be satisfied. Unfortunately xfs is not ext4...
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

pdwiki
Posts: 1
Joined: 2019/03/22 15:51:13

Re: Dropbox - glibc and file systems support

Post by pdwiki » 2019/03/22 16:36:29

The dropboxcheat.so solution is no longer working with the latest dropbox cli. My dropbox cli stopped working 3 days ago again. Has anyone else run into the same issue and figured out a solution? This is the error I am getting now:

Code: Select all

# LD_PRELOAD=/usr/local/lib64/dropboxcheat.so ./dropboxd
dropbox: locating interpreter
dropbox: logging to /tmp/dropbox-antifreeze-1K4l4u
dropbox: initializing
dropbox: initializing python 3.6.7
dropbox: setting program path '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/dropbox'
dropbox: setting home path '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102'
dropbox: setting python path '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102:/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/python-packages-36.zip'
dropbox: python initialized
dropbox: running dropbox
dropbox: setting args
dropbox: applying overrides
dropbox: running main script
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/cryptography.hazmat.bindings._constant_time.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/cryptography.hazmat.bindings._openssl.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/cryptography.hazmat.bindings._padding.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/psutil._psutil_linux.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/psutil._psutil_posix.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/linuxffi.pthread._linuxffi_pthread.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/cpuid.compiled._cpuid.cpython-36m-x86_64-linux-gnu.so'
dropbox: load fq extension '/root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/dbxlog._dbxlog.cpython-36m-x86_64-linux-gnu.so'
Traceback (most recent call last):
  File "dropbox/client/main.pyc", line 18, in <module>
  File "dropbox/client/features/content_ingest/view_model/server_view_vm.pyc", line 23, in <module>
  File "dropbox/client/features/content_ingest/model/content_ingest_shared_state.pyc", line 18, in <module>
  File "dropbox/client_api/dropbox_connection.pyc", line 56, in <module>
  File "dropbox/client_api/connection_hub.pyc", line 50, in <module>
  File "dropbox/client/proxy/__init__.pyc", line 21, in <module>
  File "dropbox/client/high_trace.pyc", line 51, in <module>
  File "dropbox/client/logging/dbxlog_logger.pyc", line 10, in <module>
  File "dbxlog/api.pyc", line 18, in <module>
  File "<_bootstrap_overrides>", line 153, in load_module
ImportError: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by /root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/dbxlog._dbxlog.cpython-36m-x86_64-linux-gnu.so)
!! dropbox: fatal python exception:
['Traceback (most recent call last):\n', '  File "dropbox/client/main.pyc", line 18, in <module>\n', '  File "dropbox/client/features/content_ingest/view_model/server_view_vm.pyc", line 23, in <module>\n', '  File "dropbox/client/features/content_ingest/model/content_ingest_shared_state.pyc", line 18, in <module>\n', '  File "dropbox/client_api/dropbox_connection.pyc", line 56, in <module>\n', '  File "dropbox/client_api/connection_hub.pyc", line 50, in <module>\n', '  File "dropbox/client/proxy/__init__.pyc", line 21, in <module>\n', '  File "dropbox/client/high_trace.pyc", line 51, in <module>\n', '  File "dropbox/client/logging/dbxlog_logger.pyc", line 10, in <module>\n', '  File "dbxlog/api.pyc", line 18, in <module>\n', '  File "<_bootstrap_overrides>", line 153, in load_module\n', "ImportError: /lib64/libc.so.6: version `GLIBC_2.18' not found (required by /root/.dropbox-dist/dropbox-lnx.x86_64-69.4.102/dbxlog._dbxlog.cpython-36m-x86_64-linux-gnu.so)\n"] (error 3)
Aborted

User avatar
TrevorH
Forum Moderator
Posts: 26936
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dropbox - glibc and file systems support

Post by TrevorH » 2019/03/22 16:42:09

As far as I know, dropbox have now started using some of the features in the newer glibc so the bodge fix no longer works even if it does successfully spoof the glibc version number.

I think it's dead.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - General Support”