updating org and selinux packages

General support questions
Post Reply
mahmood
Posts: 104
Joined: 2017/06/04 12:21:09

updating org and selinux packages

Post by mahmood » 2019/05/23 16:58:17

I want to install xrdp package, but I get the following dependency errors:

Code: Select all

Error: Package: xorgxrdp-0.2.9-1.el7.x86_64 (epel)
           Requires: xorg-x11-server-Xorg(x86-64) = 1.20.1
           Installed: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xorg-x11-server-Xorg(x86-64) = 1.19.3-11.el7
Error: Package: 1:xrdp-selinux-0.9.10-1.el7.x86_64 (epel)
           Requires: selinux-policy >= 3.13.1-229.el7_6.12
           Installed: selinux-policy-3.13.1-166.el7_4.5.noarch (@anaconda/7.0)
               selinux-policy = 3.13.1-166.el7_4.5
As I run yum update, I don't see any update for xorg-x11-server-Xorg or selinux-policy-3.13.1-166

Code: Select all

Resolving Dependencies
--> Running transaction check
---> Package epel-release.noarch 0:7-9 will be updated
---> Package epel-release.noarch 0:7-11 will be an update
---> Package fcgi.x86_64 0:2.4.0-0 will be updated
---> Package fcgi.x86_64 0:2.4.0-25.el7 will be an update
---> Package golang.x86_64 0:1.11.4-1.el7 will be updated
---> Package golang.x86_64 0:1.11.5-1.el7 will be an update
---> Package golang-bin.x86_64 0:1.11.4-1.el7 will be updated
---> Package golang-bin.x86_64 0:1.11.5-1.el7 will be an update
---> Package golang-src.noarch 0:1.11.4-1.el7 will be updated
---> Package golang-src.noarch 0:1.11.5-1.el7 will be an update
---> Package htop.x86_64 0:2.2.0-1.el7 will be updated
---> Package htop.x86_64 0:2.2.0-3.el7 will be an update
---> Package libaec.x86_64 0:1.0.2-1.el7 will be updated
---> Package libaec.x86_64 0:1.0.4-1.el7 will be an update
---> Package libuv.x86_64 1:1.23.2-1.el7 will be updated
---> Package libuv.x86_64 1:1.27.0-1.el7 will be an update
---> Package libuv-devel.x86_64 1:1.23.2-1.el7 will be updated
---> Package libuv-devel.x86_64 1:1.27.0-1.el7 will be an update
---> Package libuv-static.x86_64 1:1.23.2-1.el7 will be updated
---> Package libuv-static.x86_64 1:1.27.0-1.el7 will be an update
---> Package mosh.x86_64 0:1.2.4-1 will be updated
---> Package mosh.x86_64 0:1.3.0-1.el7 will be an update
--> Processing Dependency: perl(IO::Socket::INET6) for package: mosh-1.3.0-1.el7.x86_64
--> Processing Dependency: libprotobuf.so.8()(64bit) for package: mosh-1.3.0-1.el7.x86_64
---> Package ntfs-3g.x86_64 2:2017.3.23-6.el7 will be updated
---> Package ntfs-3g.x86_64 2:2017.3.23-11.el7 will be an update
---> Package python-rpm-macros.noarch 0:3-22.el7 will be updated
---> Package python-rpm-macros.noarch 0:3-24.el7 will be an update
---> Package python-srpm-macros.noarch 0:3-22.el7 will be updated
---> Package python-srpm-macros.noarch 0:3-24.el7 will be an update
---> Package python2-pip.noarch 0:8.1.2-6.el7 will be updated
---> Package python2-pip.noarch 0:8.1.2-8.el7 will be an update
---> Package python3-rpm-macros.noarch 0:3-22.el7 will be updated
---> Package python3-rpm-macros.noarch 0:3-24.el7 will be an update
---> Package python36.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-chardet.noarch 0:2.3.0-4.el7 will be updated
---> Package python36-chardet.noarch 0:2.3.0-6.el7 will be an update
---> Package python36-debug.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36-debug.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-devel.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36-devel.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-idle.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36-idle.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-idna.noarch 0:2.7-1.el7 will be updated
---> Package python36-idna.noarch 0:2.7-2.el7 will be an update
---> Package python36-libs.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36-libs.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-pip.noarch 0:8.1.2-7.el7 will be updated
---> Package python36-pip.noarch 0:8.1.2-8.el7 will be an update
---> Package python36-pysocks.noarch 0:1.6.8-5.el7 will be updated
---> Package python36-pysocks.noarch 0:1.6.8-6.el7 will be an update
---> Package python36-pyvmomi.noarch 0:6.7.1-2.el7 will be updated
---> Package python36-pyvmomi.noarch 0:6.7.1-3.el7 will be an update
---> Package python36-requests.noarch 0:2.12.5-2.el7 will be updated
---> Package python36-requests.noarch 0:2.12.5-3.el7 will be an update
---> Package python36-setuptools.noarch 0:39.2.0-2.el7 will be updated
---> Package python36-setuptools.noarch 0:39.2.0-3.el7 will be an update
---> Package python36-six.noarch 0:1.11.0-1.el7 will be updated
---> Package python36-six.noarch 0:1.11.0-3.el7 will be an update
---> Package python36-test.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36-test.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-tkinter.x86_64 0:3.6.6-2.el7 will be updated
---> Package python36-tkinter.x86_64 0:3.6.8-1.el7 will be an update
---> Package python36-urllib3.noarch 0:1.19.1-4.el7 will be updated
---> Package python36-urllib3.noarch 0:1.19.1-5.el7 will be an update
--> Running transaction check
---> Package mosh.x86_64 0:1.3.0-1.el7 will be an update
--> Processing Dependency: libprotobuf.so.8()(64bit) for package: mosh-1.3.0-1.el7.x86_64
---> Package perl-IO-Socket-INET6.noarch 0:2.69-5.el7 will be installed
--> Processing Dependency: perl(Socket6) for package: perl-IO-Socket-INET6-2.69-5.el7.noarch
--> Running transaction check
---> Package mosh.x86_64 0:1.3.0-1.el7 will be an update
--> Processing Dependency: libprotobuf.so.8()(64bit) for package: mosh-1.3.0-1.el7.x86_64
---> Package perl-Socket6.x86_64 0:0.23-15.el7 will be installed
--> Finished Dependency Resolution
Error: Package: mosh-1.3.0-1.el7.x86_64 (epel)
           Requires: libprotobuf.so.8()(64bit)
 You could try using --skip-broken to work around the problem
Can someone help?

P.S: I am a bit anxious about update for selinux as I had some experiences that incorrect selinux configurations can totally ruin the system and boot stuck.

User avatar
avij
Forum Moderator
Posts: 2956
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: updating org and selinux packages

Post by avij » 2019/05/23 17:08:26

You seem to have disabled CentOS repositories. See /etc/yum.repos.d/CentOS-Base.repo and make sure [base], [updates] and [extras] do not have enabled=0.

mahmood
Posts: 104
Joined: 2017/06/04 12:21:09

Re: updating org and selinux packages

Post by mahmood » 2019/05/23 17:23:51

I enabled them and got soooo many errors for yum update

Code: Select all

Error: Package: cairo-1.14.8-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libEGL-devel-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libglvnd-devel(x86-64)
Error: Package: gnome-session-3.28.1-6.el7.x86_64 (updates)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: gstreamer1-plugins-bad-free-1.10.4-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGLESv2.so.2()(64bit)
           Removing: mesa-libGLES-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGLESv2.so.2()(64bit)
           Updated By: mesa-libGLES-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libgbm-18.0.5-4.el7_6.i686 (updates)
           Requires: libwayland-server.so.0
Error: Package: caribou-0.4.21-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libEGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libwayland-server.so.0
Error: Package: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
           Requires: libmutter-cogl-path.so()(64bit)
           Removing: mutter-3.22.3-11.el7.x86_64 (@anaconda/7.0)
               libmutter-cogl-path.so()(64bit)
           Updated By: mutter-3.28.3-7.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libGLU-9.0.0-4.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: cairo-1.14.8-2.el7.i686 (@Rocks-7.0)
           Requires: libGL.so.1
           Removing: mesa-libGL-17.0.1-6.20170307.el7.i686 (@Rocks-7.0)
               libGL.so.1
           Updated By: mesa-libGL-18.0.5-4.el7_6.i686 (updates)
               Not found
Error: Package: kexec-tools-2.0.15-21.el7_6.3.x86_64 (updates)
           Requires: dracut >= 033-552
           Installed: dracut-033-502.el7.x86_64 (@anaconda/7.0)
               dracut = 033-502.el7
Error: Package: mesa-dri-drivers-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libdrm >= 2.4.83
           Installed: libdrm-2.4.74-1.el7.i686 (@Rocks-7.0)
               libdrm = 2.4.74-1.el7
Error: Package: pango-1.42.4-2.el7_6.i686 (updates)
           Requires: fontconfig(x86-32) >= 2.11.91
           Installed: fontconfig-2.10.95-11.el7.i686 (@Rocks-7.0)
               fontconfig(x86-32) = 2.10.95-11.el7
Error: Package: glx-utils-8.2.0-3.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: xorg-x11-drv-v4l-0.2.0-47.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: 2:cheese-3.22.1-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: policycoreutils-2.5-29.el7_6.1.x86_64 (updates)
           Requires: libsemanage >= 2.5-14
           Installed: libsemanage-2.5-8.el7.x86_64 (@anaconda/7.0)
               libsemanage = 2.5-8.el7
Error: Package: libvirt-daemon-driver-storage-rbd-4.5.0-10.el7_6.9.x86_64 (updates)
           Requires: librbd1 >= 1:10.2.5
           Installed: 1:librbd1-0.94.5-2.el7.x86_64 (@anaconda/7.0)
               librbd1 = 1:0.94.5-2.el7
Error: Package: 1:gdm-3.28.2-12.el7_6.1.x86_64 (updates)
           Requires: gnome-settings-daemon >= 3.27.90
           Installed: gnome-settings-daemon-3.22.2-5.el7.x86_64 (@anaconda/7.0)
               gnome-settings-daemon = 3.22.2-5.el7
Error: Package: xorg-x11-drv-vmware-13.2.1-1.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: gnome-initial-setup-3.22.1-4.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: pango-1.42.4-2.el7_6.x86_64 (updates)
           Requires: fribidi(x86-64) >= 1.0
           Available: fribidi-0.19.4-6.el7.x86_64 (Rocks-7.0)
               fribidi(x86-64) = 0.19.4-6.el7
Error: Package: anydesk-5.0.0-1.el7.x86_64 (installed)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: gnome-session-3.28.1-6.el7.x86_64 (updates)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: webkitgtk3-2.4.11-2.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.212.b04-0.el7_6.x86_64 (updates)
           Requires: copy-jdk-configs >= 3.3
           Installed: copy-jdk-configs-2.2-3.el7.noarch (@anaconda/7.0)
               copy-jdk-configs = 2.2-3.el7
Error: Package: pango-1.42.4-2.el7_6.i686 (updates)
           Requires: fribidi(x86-32) >= 1.0
           Available: fribidi-0.19.4-6.el7.i686 (Rocks-7.0)
               fribidi(x86-32) = 0.19.4-6.el7
Error: Package: nss-3.36.0-7.1.el7_6.x86_64 (updates)
           Requires: nss-softokn(x86-64) >= 3.36.0-1
           Installed: nss-softokn-3.28.3-8.el7_4.x86_64 (@anaconda/7.0)
               nss-softokn(x86-64) = 3.28.3-8.el7_4
Error: Package: systemd-libs-219-62.el7_6.6.i686 (updates)
           Requires: liblz4.so.1
Error: Package: policycoreutils-python-2.5-29.el7_6.1.x86_64 (updates)
           Requires: libsemanage-python >= 2.5-14
           Installed: libsemanage-python-2.5-8.el7.x86_64 (@anaconda/7.0)
               libsemanage-python = 2.5-8.el7
Error: Package: 1:NetworkManager-1.12.0-10.el7_6.x86_64 (updates)
           Requires: glib2 >= 2.56.1
           Installed: glib2-2.50.3-3.el7.i686 (@Rocks-7.0)
               glib2 = 2.50.3-3.el7
Error: Package: mesa-libgbm-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libdrm >= 2.4.83
           Installed: libdrm-2.4.74-1.el7.i686 (@Rocks-7.0)
               libdrm = 2.4.74-1.el7
Error: Package: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libwayland-client.so.0()(64bit)
Error: Package: gnome-tweak-tool-3.28.1-2.el7.2.noarch (updates)
           Requires: gsettings-desktop-schemas >= 3.27.90
           Installed: gsettings-desktop-schemas-3.22.0-1.el7.x86_64 (@anaconda/7.0)
               gsettings-desktop-schemas = 3.22.0-1.el7
Error: Package: systemd-219-62.el7_6.6.x86_64 (updates)
           Requires: libcryptsetup.so.12(CRYPTSETUP_2.0)(64bit)
Error: Package: mutter-3.28.3-7.el7_6.x86_64 (updates)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: fltk-1.3.4-1.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: xorg-x11-drv-dummy-0.3.7-1.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: nss-3.36.0-7.1.el7_6.i686 (updates)
           Requires: nspr >= 4.19.0
           Installed: nspr-4.13.1-1.0.el7_3.i686 (@Rocks-7.0)
               nspr = 4.13.1-1.0.el7_3
Error: Package: mesa-libGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libglvnd-glx(x86-32) >= 1:1.0.1-0.7
Error: Package: mesa-libGLES-devel-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libglvnd-devel(x86-64)
Error: gnome-session conflicts with gnome-settings-daemon-3.22.2-5.el7.x86_64
Error: Package: mesa-libGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libdrm >= 2.4.83
           Installed: libdrm-2.4.74-1.el7.i686 (@Rocks-7.0)
               libdrm = 2.4.74-1.el7
Error: Package: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libwayland-server.so.0()(64bit)
Error: Package: nss-3.36.0-7.1.el7_6.i686 (updates)
           Requires: nss-softokn(x86-32) >= 3.36.0-1
           Installed: nss-softokn-3.28.3-8.el7_4.i686 (@Rocks-7.0)
               nss-softokn(x86-32) = 3.28.3-8.el7_4
Error: Package: firefox-60.6.1-1.el7.centos.x86_64 (updates)
           Requires: nspr >= 4.19.0
           Installed: nspr-4.13.1-1.0.el7_3.i686 (@Rocks-7.0)
               nspr = 4.13.1-1.0.el7_3
Error: Package: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
           Requires: libmutter-cogl.so()(64bit)
           Removing: mutter-3.22.3-11.el7.x86_64 (@anaconda/7.0)
               libmutter-cogl.so()(64bit)
           Updated By: mutter-3.28.3-7.el7_6.x86_64 (updates)
               Not found
Error: Package: 2:cheese-libs-3.22.1-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: compat-cheese314-3.14.2-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libxatracker-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libLLVM-6.0-rhel.so(LLVM_6.0)(64bit)
Error: Package: mesa-libgbm-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libwayland-server.so.0()(64bit)
Error: Package: mesa-dri-drivers-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libLLVM-6.0-rhel.so()(64bit)
Error: Package: xorg-x11-drv-vesa-2.3.2-25.1.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: mesa-libGLU-9.0.0-4.el7.i686 (@Rocks-7.0)
           Requires: libGL.so.1
           Removing: mesa-libGL-17.0.1-6.20170307.el7.i686 (@Rocks-7.0)
               libGL.so.1
           Updated By: mesa-libGL-18.0.5-4.el7_6.i686 (updates)
               Not found
Error: Package: kernel-3.10.0-957.12.2.el7.x86_64 (updates)
           Requires: linux-firmware >= 20180911-68
           Installed: linux-firmware-20170606-56.gitc990aae.el7.noarch (@anaconda/7.0)
               linux-firmware = 20170606-56.gitc990aae.el7
Error: Package: clutter-1.26.0-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libxatracker-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libLLVM-6.0-rhel.so()(64bit)
Error: Package: gnome-session-3.28.1-6.el7.x86_64 (updates)
           Requires: libgnome-desktop-3.so.17()(64bit)
Error: Package: pango-1.42.4-2.el7_6.i686 (updates)
           Requires: harfbuzz(x86-32) >= 1.4.2
           Installed: harfbuzz-1.3.2-1.el7.i686 (@Rocks-7.0)
               harfbuzz(x86-32) = 1.3.2-1.el7
Error: Package: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
           Requires: libmutter-cogl-pango.so()(64bit)
           Removing: mutter-3.22.3-11.el7.x86_64 (@anaconda/7.0)
               libmutter-cogl-pango.so()(64bit)
           Updated By: mutter-3.28.3-7.el7_6.x86_64 (updates)
               Not found
Error: Package: cairo-gobject-1.14.8-2.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: gnome-shell-extension-common-3.28.1-5.el7.1.noarch (updates)
           Requires: gnome-shell >= 3.28.1
           Installed: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
               gnome-shell = 3.22.3-17.el7
Error: Package: webkitgtk4-2.14.7-2.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: cairo-1.14.8-2.el7.i686 (@Rocks-7.0)
           Requires: libEGL.so.1
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.i686 (@Rocks-7.0)
               libEGL.so.1
           Updated By: mesa-libEGL-18.0.5-4.el7_6.i686 (updates)
               Not found
Error: Package: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
           Requires: libmutter.so.0()(64bit)
           Removing: mutter-3.22.3-11.el7.x86_64 (@anaconda/7.0)
               libmutter.so.0()(64bit)
           Updated By: mutter-3.28.3-7.el7_6.x86_64 (updates)
               Not found
Error: Package: mutter-3.28.3-7.el7_6.x86_64 (updates)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: gstreamer1-plugins-bad-free-1.10.4-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-dri-drivers-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libLLVM-6.0-rhel.so(LLVM_6.0)(64bit)
Error: Package: nss-3.36.0-7.1.el7_6.x86_64 (updates)
           Requires: nspr >= 4.19.0
           Installed: nspr-4.13.1-1.0.el7_3.i686 (@Rocks-7.0)
               nspr = 4.13.1-1.0.el7_3
Error: Package: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libglvnd-egl(x86-64)
Error: Package: pango-devel-1.42.4-2.el7_6.x86_64 (updates)
           Requires: glib2-devel(x86-64) >= 2.56.1
           Installed: glib2-devel-2.50.3-3.el7.x86_64 (@anaconda/7.0)
               glib2-devel(x86-64) = 2.50.3-3.el7
Error: Package: 1:totem-3.22.1-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: clutter-gst2-2.0.18-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: 1:qt-x11-4.8.5-15.el7_4.i686 (@Rocks-7.0)
           Requires: libGL.so.1
           Removing: mesa-libGL-17.0.1-6.20170307.el7.i686 (@Rocks-7.0)
               libGL.so.1
           Updated By: mesa-libGL-18.0.5-4.el7_6.i686 (updates)
               Not found
Error: Package: webkitgtk4-2.14.7-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: gnome-tweak-tool-3.28.1-2.el7.2.noarch (updates)
           Requires: gnome-shell >= 3.24
           Installed: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
               gnome-shell = 3.22.3-17.el7
Error: Package: empathy-3.12.12-4.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: policycoreutils-python-2.5-29.el7_6.1.x86_64 (updates)
           Requires: setools-libs >= 3.3.8-4
           Installed: setools-libs-3.3.8-1.1.el7.x86_64 (@anaconda/7.0)
               setools-libs = 3.3.8-1.1.el7
Error: Package: mutter-3.28.3-7.el7_6.x86_64 (updates)
           Requires: libgnome-desktop-3.so.17()(64bit)
Error: Package: mesa-libGL-devel-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libglvnd-devel(x86-64)
Error: Package: webkitgtk4-plugin-process-gtk2-2.14.7-2.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mesa-libgbm-18.0.5-4.el7_6.i686 (updates)
           Requires: libdrm >= 2.4.83
           Installed: libdrm-2.4.74-1.el7.i686 (@Rocks-7.0)
               libdrm = 2.4.74-1.el7
Error: Package: nss-util-3.36.0-1.1.el7_6.i686 (updates)
           Requires: nspr >= 4.19.0-1
           Installed: nspr-4.13.1-1.0.el7_3.i686 (@Rocks-7.0)
               nspr = 4.13.1-1.0.el7_3
Error: Package: webkitgtk3-2.4.11-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: clutter-gtk-1.8.2-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: policycoreutils-2.5-29.el7_6.1.x86_64 (updates)
           Requires: libsepol >= 2.5-10
           Installed: libsepol-2.5-6.el7.i686 (@Rocks-7.0)
               libsepol = 2.5-6.el7
Error: Package: systemd-219-62.el7_6.6.x86_64 (updates)
           Requires: libcryptsetup.so.12()(64bit)
Error: Package: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libdrm >= 2.4.83
           Installed: libdrm-2.4.74-1.el7.i686 (@Rocks-7.0)
               libdrm = 2.4.74-1.el7
Error: Package: mutter-3.28.3-7.el7_6.x86_64 (updates)
           Requires: libwayland-client.so.0()(64bit)
Error: Package: 1:java-1.8.0-openjdk-headless-1.8.0.212.b04-0.el7_6.x86_64 (updates)
           Requires: nss-softokn(x86-64) >= 3.36.0
           Installed: nss-softokn-3.28.3-8.el7_4.x86_64 (@anaconda/7.0)
               nss-softokn(x86-64) = 3.28.3-8.el7_4
Error: Package: mesa-libGLES-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libglvnd-gles(x86-64)
Error: Package: mutter-3.28.3-7.el7_6.x86_64 (updates)
           Requires: libwayland-server.so.0()(64bit)
Error: Package: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
           Requires: libglvnd-glx(x86-64) >= 1:1.0.1-0.7
Error: Package: pango-1.42.4-2.el7_6.x86_64 (updates)
           Requires: harfbuzz(x86-64) >= 1.4.2
           Installed: harfbuzz-1.3.2-1.el7.x86_64 (@anaconda/7.0)
               harfbuzz(x86-64) = 1.3.2-1.el7
Error: Package: gstreamer1-plugins-bad-free-1.10.4-2.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: pango-1.42.4-2.el7_6.i686 (updates)
           Requires: glib2(x86-32) >= 2.56.1
           Installed: glib2-2.50.3-3.el7.i686 (@Rocks-7.0)
               glib2(x86-32) = 2.50.3-3.el7
Error: Package: xorg-x11-drv-intel-2.99.917-26.20160929.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: cairo-1.14.8-2.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: clutter-gst3-3.0.22-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: xorg-x11-drv-qxl-0.1.5-3.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: cogl-1.22.2-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: libreswan-3.25-4.1.el7_6.x86_64 (updates)
           Requires: unbound-libs >= 1.6.6
           Installed: unbound-libs-1.4.20-34.el7.x86_64 (@anaconda/7.0)
               unbound-libs = 1.4.20-34.el7
Error: Package: sushi-3.21.91-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: mosh-1.3.0-1.el7.x86_64 (epel)
           Requires: libprotobuf.so.8()(64bit)
Error: Package: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: 1:qt-x11-4.8.5-15.el7_4.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: policycoreutils-2.5-29.el7_6.1.x86_64 (updates)
           Requires: libselinux-utils >= 2.5-14
           Installed: libselinux-utils-2.5-11.el7.x86_64 (@anaconda/7.0)
               libselinux-utils = 2.5-11.el7
Error: Package: xorg-x11-drv-fbdev-0.4.3-25.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: pango-1.42.4-2.el7_6.x86_64 (updates)
           Requires: glib2(x86-64) >= 2.56.1
           Installed: glib2-2.50.3-3.el7.x86_64 (@anaconda/7.0)
               glib2(x86-64) = 2.50.3-3.el7
Error: Package: pango-1.42.4-2.el7_6.i686 (updates)
           Requires: fribidi(x86-32) >= 1.0
           Installing: fribidi-0.19.4-6.el7.i686 (Rocks-7.0)
               fribidi(x86-32) = 0.19.4-6.el7
Error: Package: selinux-policy-3.13.1-229.el7_6.12.noarch (updates)
           Requires: libsemanage >= 2.5-13
           Installed: libsemanage-2.5-8.el7.x86_64 (@anaconda/7.0)
               libsemanage = 2.5-8.el7
Error: Package: gnome-session-3.28.1-6.el7.x86_64 (updates)
           Requires: libGLESv2.so.2()(64bit)
           Removing: mesa-libGLES-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGLESv2.so.2()(64bit)
           Updated By: mesa-libGLES-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: webkitgtk4-plugin-process-gtk2-2.14.7-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: flatpak-1.0.2-5.el7_6.x86_64 (updates)
           Requires: xdg-desktop-portal > 0.10
           Installed: xdg-desktop-portal-0.5-2.el7.x86_64 (@anaconda/7.0)
               xdg-desktop-portal = 0.5-2.el7
Error: Package: mesa-libGL-devel-18.0.5-4.el7_6.x86_64 (updates)
           Requires: pkgconfig(libdrm) >= 2.4.75
           Installed: libdrm-devel-2.4.74-1.el7.x86_64 (@anaconda/7.0)
               pkgconfig(libdrm) = 2.4.74
Error: Package: 1:xorg-x11-drv-nouveau-1.0.13-3.el7.x86_64 (@anaconda/7.0)
           Requires: xserver-abi(videodrv-23) >= 0
           Removing: xorg-x11-server-Xorg-1.19.3-11.el7.x86_64 (@anaconda/7.0)
               xserver-abi(videodrv-23) = 0
           Updated By: xorg-x11-server-Xorg-1.20.1-5.3.el7_6.x86_64 (updates)
              ~xserver-abi(videodrv-24) = 0
Error: Package: gnome-contacts-3.22.1-1.el7.x86_64 (@anaconda/7.0)
           Requires: libEGL.so.1()(64bit)
           Removing: mesa-libEGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libEGL.so.1()(64bit)
           Updated By: mesa-libEGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: gnome-shell-3.22.3-17.el7.x86_64 (@anaconda/7.0)
           Requires: libmutter-clutter-1.0.so()(64bit)
           Removing: mutter-3.22.3-11.el7.x86_64 (@anaconda/7.0)
               libmutter-clutter-1.0.so()(64bit)
           Updated By: mutter-3.28.3-7.el7_6.x86_64 (updates)
               Not found
Error: Package: pango-devel-1.42.4-2.el7_6.x86_64 (updates)
           Requires: fontconfig-devel(x86-64) >= 2.11.91
           Installed: fontconfig-devel-2.10.95-11.el7.x86_64 (@anaconda/7.0)
               fontconfig-devel(x86-64) = 2.10.95-11.el7
Error: Package: nss-util-3.36.0-1.1.el7_6.x86_64 (updates)
           Requires: nspr >= 4.19.0-1
           Installed: nspr-4.13.1-1.0.el7_3.i686 (@Rocks-7.0)
               nspr = 4.13.1-1.0.el7_3
Error: Package: mesa-libEGL-devel-18.0.5-4.el7_6.x86_64 (updates)
           Requires: pkgconfig(libdrm) >= 2.4.75
           Installed: libdrm-devel-2.4.74-1.el7.x86_64 (@anaconda/7.0)
               pkgconfig(libdrm) = 2.4.74
Error: Package: mesa-libEGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libwayland-client.so.0
Error: Package: kexec-tools-2.0.15-21.el7_6.3.x86_64 (updates)
           Requires: dracut-network >= 033-552
           Installed: dracut-network-033-502.el7.x86_64 (@anaconda/7.0)
               dracut-network = 033-502.el7
Error: Package: mesa-libEGL-18.0.5-4.el7_6.i686 (updates)
           Requires: libglvnd-egl(x86-32)
Error: Package: tigervnc-server-minimal-1.8.0-1.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: pango-1.42.4-2.el7_6.x86_64 (updates)
           Requires: fontconfig(x86-64) >= 2.11.91
           Installed: fontconfig-2.10.95-11.el7.x86_64 (@anaconda/7.0)
               fontconfig(x86-64) = 2.10.95-11.el7
Error: Package: cairo-gobject-1.14.8-2.el7.x86_64 (@anaconda/7.0)
           Requires: libGL.so.1()(64bit)
           Removing: mesa-libGL-17.0.1-6.20170307.el7.x86_64 (@anaconda/7.0)
               libGL.so.1()(64bit)
           Updated By: mesa-libGL-18.0.5-4.el7_6.x86_64 (updates)
               Not found
Error: Package: pango-1.42.4-2.el7_6.x86_64 (updates)
           Requires: fribidi(x86-64) >= 1.0
           Installing: fribidi-0.19.4-6.el7.x86_64 (Rocks-7.0)
               fribidi(x86-64) = 0.19.4-6.el7

User avatar
avij
Forum Moderator
Posts: 2956
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: updating org and selinux packages

Post by avij » 2019/05/23 17:48:11

Oh, "Rocks-7.0" .. that also explains that "anaconda/7.0" which looked odd.

mahmood
Posts: 104
Joined: 2017/06/04 12:21:09

Re: updating org and selinux packages

Post by mahmood » 2019/05/23 18:12:50

Yes... and I think I have to ignore the update as I think several problems with arise. I will do that in the next reinstallation of Rocks. Thank you.

User avatar
avij
Forum Moderator
Posts: 2956
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: updating org and selinux packages

Post by avij » 2019/05/23 18:29:29

If you are running Rocks, maybe you should seek support from the Rocks folks? It's their distro.

Post Reply