Why do I need Evolution?

General support questions
lightman47
Posts: 955
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Why do I need Evolution?

Post by lightman47 » 2019/09/11 17:02:08

I stopped using Evolution for email back in my Fedora days - there was a 'quirk' or two I didn't like. It, or some derivation of it, keeps getting installed on all my CentOS boxes. Attempts to normally remove it result in dependency reports for a hunk of my system files and would render my system unusable.

Is there some reason I need Evolution processes for calendar, addressbook, registry (or parts thereof) of which I am unaware?

Thank you.
Multple login IDs are not your friend when asking for help!

User avatar
TrevorH
Forum Moderator
Posts: 26568
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Why do I need Evolution?

Post by TrevorH » 2019/09/11 17:17:25

It's not installed here so the chances are that it is a Require for a package you do have installed. Attempting to remove it should list all things that require it (and anything that depends on those). Running repoquery --whatrequires evolution doesn't show anything needing it except sub-packages of evolution.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

lightman47
Posts: 955
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Why do I need Evolution?

Post by lightman47 » 2019/09/11 17:21:27

Hmmm. Thank you.

EDIT:
Same here! Wonder what's installing it. (I have a 'ton' of installed packages - but NO 'builds')

Going to try the uninstall route to see "who" complains.

Thank you again.
Multple login IDs are not your friend when asking for help!

chemal
Posts: 587
Joined: 2013/12/08 19:44:49

Re: Why do I need Evolution?

Post by chemal » 2019/09/11 17:34:21

It's evolution-data-server the will take parts of gnome with it when you uninstall it. The package description says: "The evolution-data-server package provides a unified backend for programs that work with contacts, tasks, and calendar information. It was originally developed for Evolution (hence the name), but is now used by other packages." Just keep this one and you can uninstall the rest.

lightman47
Posts: 955
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Why do I need Evolution?

Post by lightman47 » 2019/09/11 17:44:37

Code: Select all

Resolving Dependencies
--> Running transaction check
---> Package evolution-data-server.x86_64 0:3.28.5-1.el7 will be erased
--> Processing Dependency: libebackend-1.2.so.10()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libebook-1.2.so.19()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libebook-contacts-1.2.so.2()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libecal-1.2.so.19()(64bit) for package: gnome-shell-3.28.3-6.el7.x86_64
--> Processing Dependency: libedata-book-1.2.so.25()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libedataserver-1.2.so.23()(64bit) for package: gnome-shell-3.28.3-6.el7.x86_64
--> Processing Dependency: libedataserver-1.2.so.23()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libedataserver-1.2.so.23()(64bit) for package: gnome-contacts-3.28.2-1.el7.x86_64
--> Processing Dependency: libedataserverui-1.2.so.2()(64bit) for package: gnome-contacts-3.28.2-1.el7.x86_64
---> Package evolution-data-server-langpacks.noarch 0:3.28.5-1.el7 will be erased
--> Running transaction check
---> Package folks.x86_64 1:0.11.4-1.el7 will be erased
--> Processing Dependency: libfolks-telepathy.so.25()(64bit) for package: empathy-3.12.13-1.el7.x86_64
--> Processing Dependency: libfolks.so.25()(64bit) for package: empathy-3.12.13-1.el7.x86_64
---> Package gnome-contacts.x86_64 0:3.28.2-1.el7 will be erased
---> Package gnome-shell.x86_64 0:3.28.3-6.el7 will be erased
--> Processing Dependency: desktop-notification-daemon for package: system-config-printer-1.4.1-21.el7.x86_64
--> Processing Dependency: gnome-shell for package: 1:gdm-3.28.2-12.el7_6.2.x86_64
--> Processing Dependency: gnome-shell >= 3.24 for package: gnome-tweak-tool-3.28.1-2.el7.2.noarch
--> Processing Dependency: gnome-shell >= 3.28.1 for package: gnome-shell-extension-common-3.28.1-5.el7.1.noarch
--> Running transaction check
---> Package empathy.x86_64 0:3.12.13-1.el7 will be erased
---> Package gdm.x86_64 1:3.28.2-12.el7_6.2 will be erased
--> Processing Dependency: gdm for package: gnome-initial-setup-3.28.0-1.el7.x86_64
--> Processing Dependency: gdm for package: pulseaudio-gdm-hooks-10.0-5.el7.x86_64
--> Processing Dependency: gdm >= 1:2.22.0 for package: pulseaudio-gdm-hooks-10.0-5.el7.x86_64
--> Processing Dependency: libgdm.so.1()(64bit) for package: gnome-initial-setup-3.28.0-1.el7.x86_64
---> Package gnome-shell-extension-common.noarch 0:3.28.1-5.el7.1 will be erased
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-places-menu-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-alternate-tab-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-user-theme-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-top-icons-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-apps-menu-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-launch-new-instance-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-window-list-3.28.1-5.el7.1.noarch
---> Package gnome-tweak-tool.noarch 0:3.28.1-2.el7.2 will be erased
---> Package system-config-printer.x86_64 0:1.4.1-21.el7 will be erased
--> Running transaction check
---> Package gnome-initial-setup.x86_64 0:3.28.0-1.el7 will be erased
---> Package gnome-shell-extension-alternate-tab.noarch 0:3.28.1-5.el7.1 will be erased
--> Processing Dependency: gnome-shell-extension-alternate-tab = 3.28.1-5.el7.1 for package: gnome-classic-session-3.28.1-5.el7.1.noarch
---> Package gnome-shell-extension-apps-menu.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-launch-new-instance.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-places-menu.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-top-icons.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-user-theme.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-window-list.noarch 0:3.28.1-5.el7.1 will be erased
---> Package pulseaudio-gdm-hooks.x86_64 0:10.0-5.el7 will be erased
--> Running transaction checkResolving Dependencies
--> Running transaction check
---> Package evolution-data-server.x86_64 0:3.28.5-1.el7 will be erased
--> Processing Dependency: libebackend-1.2.so.10()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libebook-1.2.so.19()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libebook-contacts-1.2.so.2()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libecal-1.2.so.19()(64bit) for package: gnome-shell-3.28.3-6.el7.x86_64
--> Processing Dependency: libedata-book-1.2.so.25()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libedataserver-1.2.so.23()(64bit) for package: gnome-shell-3.28.3-6.el7.x86_64
--> Processing Dependency: libedataserver-1.2.so.23()(64bit) for package: 1:folks-0.11.4-1.el7.x86_64
--> Processing Dependency: libedataserver-1.2.so.23()(64bit) for package: gnome-contacts-3.28.2-1.el7.x86_64
--> Processing Dependency: libedataserverui-1.2.so.2()(64bit) for package: gnome-contacts-3.28.2-1.el7.x86_64
---> Package evolution-data-server-langpacks.noarch 0:3.28.5-1.el7 will be erased
--> Running transaction check
---> Package folks.x86_64 1:0.11.4-1.el7 will be erased
--> Processing Dependency: libfolks-telepathy.so.25()(64bit) for package: empathy-3.12.13-1.el7.x86_64
--> Processing Dependency: libfolks.so.25()(64bit) for package: empathy-3.12.13-1.el7.x86_64
---> Package gnome-contacts.x86_64 0:3.28.2-1.el7 will be erased
---> Package gnome-shell.x86_64 0:3.28.3-6.el7 will be erased
--> Processing Dependency: desktop-notification-daemon for package: system-config-printer-1.4.1-21.el7.x86_64
--> Processing Dependency: gnome-shell for package: 1:gdm-3.28.2-12.el7_6.2.x86_64
--> Processing Dependency: gnome-shell >= 3.24 for package: gnome-tweak-tool-3.28.1-2.el7.2.noarch
--> Processing Dependency: gnome-shell >= 3.28.1 for package: gnome-shell-extension-common-3.28.1-5.el7.1.noarch
--> Running transaction check
---> Package empathy.x86_64 0:3.12.13-1.el7 will be erased
---> Package gdm.x86_64 1:3.28.2-12.el7_6.2 will be erased
--> Processing Dependency: gdm for package: gnome-initial-setup-3.28.0-1.el7.x86_64
--> Processing Dependency: gdm for package: pulseaudio-gdm-hooks-10.0-5.el7.x86_64
--> Processing Dependency: gdm >= 1:2.22.0 for package: pulseaudio-gdm-hooks-10.0-5.el7.x86_64
--> Processing Dependency: libgdm.so.1()(64bit) for package: gnome-initial-setup-3.28.0-1.el7.x86_64
---> Package gnome-shell-extension-common.noarch 0:3.28.1-5.el7.1 will be erased
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-places-menu-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-alternate-tab-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-user-theme-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-top-icons-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-apps-menu-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-launch-new-instance-3.28.1-5.el7.1.noarch
--> Processing Dependency: gnome-shell-extension-common = 3.28.1-5.el7.1 for package: gnome-shell-extension-window-list-3.28.1-5.el7.1.noarch
---> Package gnome-tweak-tool.noarch 0:3.28.1-2.el7.2 will be erased
---> Package system-config-printer.x86_64 0:1.4.1-21.el7 will be erased
--> Running transaction check
---> Package gnome-initial-setup.x86_64 0:3.28.0-1.el7 will be erased
---> Package gnome-shell-extension-alternate-tab.noarch 0:3.28.1-5.el7.1 will be erased
--> Processing Dependency: gnome-shell-extension-alternate-tab = 3.28.1-5.el7.1 for package: gnome-classic-session-3.28.1-5.el7.1.noarch
---> Package gnome-shell-extension-apps-menu.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-launch-new-instance.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-places-menu.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-top-icons.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-user-theme.noarch 0:3.28.1-5.el7.1 will be erased
---> Package gnome-shell-extension-window-list.noarch 0:3.28.1-5.el7.1 will be erased
---> Package pulseaudio-gdm-hooks.x86_64 0:10.0-5.el7 will be erased
--> Running transaction check
---> Package gnome-classic-session.noarch 0:3.28.1-5.el7.1 will be erased
--> Finished Dependency Resolution

Dependencies Resolved


---> Package gnome-classic-session.noarch 0:3.28.1-5.el7.1 will be erased
--> Finished Dependency Resolution

Dependencies Resolved
Multple login IDs are not your friend when asking for help!

lightman47
Posts: 955
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Why do I need Evolution?

Post by lightman47 » 2019/09/11 17:49:03

Now seeing chemals reply -

So Gnome has essentially 'backlinked' into Evolution? If you use (default) Gnome you get Evolution data server?
- as well as my next target 'tracker'
Multple login IDs are not your friend when asking for help!

desertcat
Posts: 631
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: Why do I need Evolution?

Post by desertcat » 2019/09/11 23:46:51

lightman47 wrote:
2019/09/11 17:21:27
Hmmm. Thank you.

EDIT:
Same here! Wonder what's installing it. (I have a 'ton' of installed packages - but NO 'builds')

Going to try the uninstall route to see "who" complains.

Thank you again.
Hummmmmm.

Just for FUN (and not having anything better to do) I ran repoquery --whatrequires evolution


And it it spit out the following:

evolution-bogofilter-0:3.28.5-2.el7.x86_64
evolution-devel-0:3.28.5-2.el7.i686
evolution-devel-0:3.28.5-2.el7.x86_64
evolution-ews-0:3.28.5-1.el7.i686
evolution-ews-0:3.28.5-1.el7.x86_64
evolution-help-0:3.28.5-2.el7.noarch
evolution-langpacks-0:3.28.5-2.el7.noarch
evolution-mapi-0:3.28.3-2.el7.i686
evolution-mapi-0:3.28.3-2.el7.x86_64
evolution-pst-0:3.28.5-2.el7.x86_64
evolution-spamassassin-0:3.28.5-2.el7.x86_64
evolution-tests-0:3.28.5-2.el7.x86_64


The only time it pops up is usually a email reply type thing, which I usually skip around. It *may* have been installed with GNOME, or some other dm system I've installed and played around with, but really it does not bother me too much.

MartinR
Posts: 453
Joined: 2015/05/11 07:53:27
Location: UK

Re: Why do I need Evolution?

Post by MartinR » 2019/09/12 07:56:41

On my system (CentOS 7.6, fully patched one minute earlier) I see the following:

Code: Select all

# yum remove evolution
Loaded plugins: fastestmirror, langpacks, priorities
Resolving Dependencies
--> Running transaction check
---> Package evolution.x86_64 0:3.28.5-2.el7 will be erased
--> Processing Dependency: evolution >= 3.28.3 for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: evolution >= 3.28.5 for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: evolution = 3.28.5-2.el7 for package: evolution-langpacks-3.28.5-2.el7.noarch
--> Processing Dependency: evolution = 3.28.5-2.el7 for package: evolution-help-3.28.5-2.el7.noarch
--> Processing Dependency: libemail-engine.so()(64bit) for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: libemail-engine.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: libevolution-calendar.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: libevolution-mail-composer.so()(64bit) for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: libevolution-mail-composer.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: libevolution-mail-formatter.so()(64bit) for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: libevolution-mail-formatter.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: libevolution-mail.so()(64bit) for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: libevolution-mail.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: libevolution-shell.so()(64bit) for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: libevolution-shell.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Processing Dependency: libevolution-util.so()(64bit) for package: evolution-mapi-3.28.3-2.el7.x86_64
--> Processing Dependency: libevolution-util.so()(64bit) for package: evolution-ews-3.28.5-1.el7.x86_64
--> Running transaction check
---> Package evolution-ews.x86_64 0:3.28.5-1.el7 will be erased
--> Processing Dependency: evolution-ews = 3.28.5-1.el7 for package: evolution-ews-langpacks-3.28.5-1.el7.noarch
---> Package evolution-help.noarch 0:3.28.5-2.el7 will be erased
---> Package evolution-langpacks.noarch 0:3.28.5-2.el7 will be erased
---> Package evolution-mapi.x86_64 0:3.28.3-2.el7 will be erased
--> Processing Dependency: evolution-mapi = 3.28.3-2.el7 for package: evolution-mapi-langpacks-3.28.3-2.el7.noarch
--> Running transaction check
---> Package evolution-ews-langpacks.noarch 0:3.28.5-1.el7 will be erased
---> Package evolution-mapi-langpacks.noarch 0:3.28.3-2.el7 will be erased
--> Finished Dependency Resolution

Dependencies Resolved

===================================================================================================================================================
 Package                                        Arch                         Version                             Repository                   Size
===================================================================================================================================================
Removing:
 evolution                                      x86_64                       3.28.5-2.el7                        @base                        15 M
Removing for dependencies:
 evolution-ews                                  x86_64                       3.28.5-1.el7                        @base                       1.2 M
 evolution-ews-langpacks                        noarch                       3.28.5-1.el7                        @base                       878 k
 evolution-help                                 noarch                       3.28.5-2.el7                        @base                        13 M
 evolution-langpacks                            noarch                       3.28.5-2.el7                        @base                        35 M
 evolution-mapi                                 x86_64                       3.28.3-2.el7                        @base                       837 k
 evolution-mapi-langpacks                       noarch                       3.28.3-2.el7                        @base                       1.0 M

Transaction Summary
===================================================================================================================================================
Remove  1 Package (+6 Dependent packages)

Installed size: 66 M
Is this ok [y/N]: y
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Erasing    : evolution-ews-3.28.5-1.el7.x86_64                                                                                               1/7 
  Erasing    : evolution-ews-langpacks-3.28.5-1.el7.noarch                                                                                     2/7 
  Erasing    : evolution-help-3.28.5-2.el7.noarch                                                                                              3/7 
  Erasing    : evolution-mapi-langpacks-3.28.3-2.el7.noarch                                                                                    4/7 
  Erasing    : evolution-mapi-3.28.3-2.el7.x86_64                                                                                              5/7 
  Erasing    : evolution-3.28.5-2.el7.x86_64                                                                                                   6/7 
  Erasing    : evolution-langpacks-3.28.5-2.el7.noarch                                                                                         7/7 
  Verifying  : evolution-langpacks-3.28.5-2.el7.noarch                                                                                         1/7 
  Verifying  : evolution-mapi-3.28.3-2.el7.x86_64                                                                                              2/7 
  Verifying  : evolution-mapi-langpacks-3.28.3-2.el7.noarch                                                                                    3/7 
  Verifying  : evolution-ews-langpacks-3.28.5-1.el7.noarch                                                                                     4/7 
  Verifying  : evolution-ews-3.28.5-1.el7.x86_64                                                                                               5/7 
  Verifying  : evolution-help-3.28.5-2.el7.noarch                                                                                              6/7 
  Verifying  : evolution-3.28.5-2.el7.x86_64                                                                                                   7/7 

Removed:
  evolution.x86_64 0:3.28.5-2.el7                                                                                                                  

Dependency Removed:
  evolution-ews.x86_64 0:3.28.5-1.el7          evolution-ews-langpacks.noarch 0:3.28.5-1.el7    evolution-help.noarch 0:3.28.5-2.el7             
  evolution-langpacks.noarch 0:3.28.5-2.el7    evolution-mapi.x86_64 0:3.28.3-2.el7             evolution-mapi-langpacks.noarch 0:3.28.3-2.el7   

Complete!
Were you by any chance removing evolution\*?

User avatar
TrevorH
Forum Moderator
Posts: 26568
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Why do I need Evolution?

Post by TrevorH » 2019/09/12 12:13:21

I run MATE not gnome3 so I wonder if it's a Require from there. It's not required by MATE.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 2307
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Why do I need Evolution?

Post by jlehtone » 2019/09/12 12:25:07

I run gnome3 and have neither evolution nor tracker.

The evolution-data-server and evolution-data-server-langpacks are installed/required by gnome.

Nautilus requires tracker.

Post Reply

Return to “CentOS 7 - General Support”