Failed to Start GUI

General support questions
Post Reply
hcsf
Posts: 7
Joined: 2019/11/27 07:21:02

Failed to Start GUI

Post by hcsf » 2019/11/27 07:36:58

Hi,

I upgraded kernel from 3.10.0-957.1.3.e17.x86_64 to 3.10.0-1062.4.3.e17.x86_64.

Then, I couldn't start GDM anymore.

If I rebooted with 3.10.0-862.2.3.el7.x86_64, it worked fine again. (for some reason, 3.10.0-957 wasn't a choice in grub menu after the kernel upgrade).

Then, I manually yum upgraded kmod-nvidia to 440.30 (my video card is 1050 ti), and gdm, and rebooted (after this upgrade, even booting with 3.10.0-862 won't work).

Then, I saw mouse cursor for 10 sec, and then it left the graphic mode and went back to command line mode (no text but cursor).

According to /var/log/Xorg.0.log, it failed to load the nvidia kernel module:

Code: Select all

[    31.657] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov 27 11:00:21 2019
[    31.658] (==) Using config file: "/etc/X11/xorg.conf"
[    31.658] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    31.658] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    31.659] (==) No Layout section.  Using the first Screen section.
[    31.659] (==) No screen section available. Using defaults.
[    31.659] (**) |-->Screen "Default Screen Section" (0)
[    31.659] (**) |   |-->Monitor "<default monitor>"
[    31.659] (==) No device specified for screen "Default Screen Section".
    Using the first device section listed.
[    31.659] (**) |   |-->Device "Videocard0"
[    31.659] (==) No monitor specified for screen "Default Screen Section".
    Using a default monitor configuration.
[    31.659] (==) Automatically adding devices
[    31.659] (==) Automatically enabling devices
[    31.659] (==) Automatically adding GPU devices
[    31.659] (==) Automatically binding GPU devices
[    31.659] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    31.659] (==) FontPath set to:
    catalogue:/etc/X11/fontpath.d,
    built-ins
[    31.659] (==) ModulePath set to "/usr/lib64/xorg/modules"
[    31.659] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
[    31.660] (II) Loader magic: 0x56065dada020
[    31.660] (II) Module ABI versions:
[    31.660]    X.Org ANSI C Emulation: 0.4
[    31.660]    X.Org Video Driver: 24.0
[    31.660]    X.Org XInput driver : 24.1
[    31.660]    X.Org Server Extension : 10.0
[    31.661] (--) PCI:*(1@0:0:0) 10de:1c82:1462:8c96 rev 161, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[    31.661] (II) LoadModule: "glx"
[    31.662] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[    31.679] (II) Module glx: vendor="X.Org Foundation"
[    31.679]    compiled for 1.20.4, module version = 1.0.0
[    31.679]    ABI class: X.Org Server Extension, version 10.0
[    31.679] (II) LoadModule: "nvidia"
[    31.679] (II) Loading /usr/lib64/xorg/modules/drivers/nvidia_drv.so
[    31.688] (II) Module nvidia: vendor="NVIDIA Corporation"
[    31.688]    compiled for 1.6.99.901, module version = 1.0.0
[    31.688]    Module class: X.Org Video Driver
[    31.689] (II) NVIDIA dlloader X Driver  440.36  Tue Nov 12 08:17:24 UTC 2019
[    31.689] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    31.690] (++) using VT number 1

[    31.694] (II) Loading sub module "fb"
[    31.694] (II) LoadModule: "fb"
[    31.695] (II) Loading /usr/lib64/xorg/modules/libfb.so
[    31.696] (II) Module fb: vendor="X.Org Foundation"
[    31.696]    compiled for 1.20.4, module version = 1.0.0
[    31.696]    ABI class: X.Org ANSI C Emulation, version 0.4
[    31.696] (II) Loading sub module "wfb"
[    31.696] (II) LoadModule: "wfb"
[    31.696] (II) Loading /usr/lib64/xorg/modules/libwfb.so
[    31.697] (II) Module wfb: vendor="X.Org Foundation"
[    31.697]    compiled for 1.20.4, module version = 1.0.0
[    31.697]    ABI class: X.Org ANSI C Emulation, version 0.4
[    31.697] (II) Loading sub module "ramdac"
[    31.697] (II) LoadModule: "ramdac"
[    31.697] (II) Module "ramdac" already built-in
[    31.701] (EE) NVIDIA: Failed to initialize the NVIDIA kernel module. Please see the
[    31.701] (EE) NVIDIA:     system's kernel log for additional error messages and
[    31.701] (EE) NVIDIA:     consult the NVIDIA README for details.
[    31.701] (EE) No devices detected.
[    31.701] (EE) 
Fatal server error:
[    31.701] (EE) no screens found(EE) 
[    31.702] (EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
[    31.702] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    31.702] (EE) 
[    31.703] (EE) Server terminated with error (1). Closing log file.
Then, I erased nvidia-x11-drv and kmod-nvidia again and installed the latest again. This time Xorg.0.log shows no failure in loading the module. But I got:

Code: Select all

[    31.204] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[    31.204] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[    31.204] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[    31.204] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[    31.204] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[    31.204] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[    31.204] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[    31.204] (II) NVIDIA(0):     Config Options in the README.
[    31.218] (II) NVIDIA(0): Setting mode "DFP-1:nvidia-auto-select"
[    31.277] (==) NVIDIA(0): Disabling shared memory pixmaps
Not sure whether the ACPI error prevents GDM from starting tho. According to this https://forum.manjaro.org/t/nvidia-driv ... reen/61572, it doesn't seem like an issue. I attached the latest /var/log/xorg.0.log

Here is my /etc/x11/xorg.conf (which hasn't been changed since 2014):

Code: Select all

# /etc/X11/nvidia-xorg.conf provided by http://elrepo.org

Section "Device"
	Identifier  "Videocard0"
	Driver      "nvidia"
EndSection
This page https://elrepo.org/tiki/kmod-nvidia suggests that glamoregl might conflict with nvidia driver. I checked that it isn't installed, and ldconfig -p | grep glam shows nothing.

nvidia-detect shows that I should install kmod-nvidia, which I did.

I also tried to download the driver from nvidia's website to rebuild and install. Same issue. Hence, uninstalled.

Any pointer is highly appreciate. Even pointing to an appropriate mailing list/forum is great.

Thanks!
Last edited by hcsf on 2019/11/29 01:37:09, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 27138
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Failed to Start GUI

Post by TrevorH » 2019/11/27 09:02:49

You've gone from a 7.6 to a 7.7 kernel so the nvidia driver that you have installed will require to be updated to match. If you are using the ELRepo copy of the driver then make sure that the elrepo repo is enabled and run yum update to make sure you have the 7.7 version of the package installed. If it updates then reboot to make it take effect.

If you have installed the nvidia driver from their .run file then you will need to reinstall that .run file each and every time the kernel is updated.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

hcsf
Posts: 7
Joined: 2019/11/27 07:21:02

Re: Failed to Start GUI

Post by hcsf » 2019/11/28 01:18:51

Thanks for the tips.

When I upgraded the kernel and other packages (including gdm, kmod-nvidia, nvidia-x11-drv, etc), elrepo was enabled because I just yum info on kmod-nvidia and nvidia-x11-drv. And both are from elrepo.

nash39619
Posts: 1
Joined: 2019/11/28 02:13:56
Contact:

Recent Nvidia driver update and older hardware

Post by nash39619 » 2019/11/28 02:22:55

An update to kmod-nvidia was just released that may render the GUI on older hardware unusable. Users with older unsupported cards should migrate to the legacy kmod-nvidia-340xx package. For more details, please see the Notice on the ELRepo's kmod-nvidia web page.

hcsf
Posts: 7
Joined: 2019/11/27 07:21:02

Re: Failed to Start GUI

Post by hcsf » 2019/11/29 01:36:14

Thanks for sharing the notice.

I just checked nvidia's official page about the latest driver: https://www.nvidia.com/Download/driverR ... 4997/en-us

My card (GT 1050 ti) is supported by the latest driver 440.36 (which is also the version of the latest kmod-nvidia).

And I also ran the latest nvidia-detect, and it printed "kmod-nvidia" instead of "kmod-nvidia-340xx".

So maybe mine is a different issue?

User avatar
jlehtone
Posts: 2431
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Failed to Start GUI

Post by jlehtone » 2019/11/29 09:21:27

Most likely different issue.

What do you get with:

Code: Select all

yum list kernel \*nvidia\*
df -h /boot /
[edit] @nash: There is kmod-nvidia-390xx too.

Code: Select all

# yum -q --enablerepo=elrepo list kmod-nvidia\*
Installed Packages
kmod-nvidia.x86_64                        440.36-1.el7_7.elrepo                   @elrepo
Available Packages
kmod-nvidia-340xx.x86_64                  340.107-3.el7_7.elrepo                  elrepo 
kmod-nvidia-390xx.x86_64                  390.116-2.el7_7.elrepo                  elrepo

lightman47
Posts: 999
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: Failed to Start GUI

Post by lightman47 » 2019/11/29 12:23:05

For mine I use kmod-nvidia (not the kmod-nvidia-340xx). Because I also have the Intel card, I use Bumblebee. I don't have to fiddle anything; it just works.
Multple login IDs are not your friend when asking for help!

hcsf
Posts: 7
Joined: 2019/11/27 07:21:02

Re: Failed to Start GUI

Post by hcsf » 2019/11/30 04:03:26

@jlehtone thanks for the suggestion.

I gave up and went ahead with a clean installation before I read your post. (altho, a clean installation shows another issue...seems like an issue with the latest kernel and/or nvidia; posted: viewtopic.php?f=47&t=72668).

Thanks for your help tho.

Post Reply

Return to “CentOS 7 - General Support”