libNX problem

Issues related to applications and software problems
Post Reply
sheikki
Posts: 11
Joined: 2015/12/22 06:26:32

libNX problem

Post by sheikki » 2018/08/10 07:26:40

yum update results in:

Code: Select all

Resolving Dependencies
--> Running transaction check
---> Package libNX_X11.x86_64 0:3.5.0.33-4.el7 will be updated
---> Package libNX_X11.x86_64 0:3.5.99.16-1.el7 will be an update
---> Package libNX_Xext.x86_64 0:3.5.0.33-4.el7 will be obsoleted
---> Package libNX_Xpm.x86_64 0:3.5.0.33-4.el7 will be obsoleted
--> Processing Dependency: libNX_Xpm(x86-64) = 3.5.0.33-4.el7 for package: libNX_Xpm-devel-3.5.0.33-4.el7.x86_64
--> Processing Dependency: libNX_Xpm.so.4()(64bit) for package: libNX_Xpm-devel-3.5.0.33-4.el7.x86_64
---> Package libXcomp.x86_64 0:3.5.0.33-4.el7 will be updated
---> Package libXcomp.x86_64 0:3.5.99.16-1.el7 will be an update
---> Package nx-libs.x86_64 0:3.5.0.33-4.el7 will be updated
---> Package nx-libs.x86_64 0:3.5.99.16-1.el7 will be obsoleting
--> Finished Dependency Resolution
Error: Package: libNX_Xpm-devel-3.5.0.33-4.el7.x86_64 (@epel)
           Requires: libNX_Xpm.so.4()(64bit)
           Removing: libNX_Xpm-3.5.0.33-4.el7.x86_64 (@epel)
               libNX_Xpm.so.4()(64bit)
           Obsoleted By: nx-libs-3.5.99.16-1.el7.x86_64 (epel)
               Not found
Error: Package: libNX_Xpm-devel-3.5.0.33-4.el7.x86_64 (@epel)
           Requires: libNX_Xpm(x86-64) = 3.5.0.33-4.el7
           Removing: libNX_Xpm-3.5.0.33-4.el7.x86_64 (@epel)
               libNX_Xpm(x86-64) = 3.5.0.33-4.el7
           Obsoleted By: nx-libs-3.5.99.16-1.el7.x86_64 (epel)
               Not found
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Did anyone else run into this?

amk
Posts: 16
Joined: 2015/06/02 08:02:58

Re: libNX problem

Post by amk » 2018/08/10 14:13:15

Yes, same problem here.
Seeing the output, all of the packages are form epel, so it just seems to be epel problem. First I thought I had priorities clashing or something, but no, it all comes form the same repo.
I tried disabling obsoletes as well, to no avail.
Yeah, seems like packaging problem.

sheikki
Posts: 11
Joined: 2015/12/22 06:26:32

Re: libNX problem

Post by sheikki » 2018/08/15 13:23:26

So, I wonder.. will this problem go away by itself? I don't want to do --skip-broken every time I yum update..

User avatar
TrevorH
Forum Moderator
Posts: 24095
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: libNX problem

Post by TrevorH » 2018/08/15 13:37:54

Just yum remove libNX_Xpm-devel then read the list of things it wants to remove with it and only reply Y if there's nothing critical being removed with it.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

amk
Posts: 16
Joined: 2015/06/02 08:02:58

Re: libNX problem

Post by amk » 2018/08/16 08:14:16

Well, it will not go away by itself. After discovering it I searched the bugzilla and it's been reported already, as you perhaps noticed?

Anyway, I just removed nx-libs, it took the rest with it and then I installed the new ones. All is well again.

Post Reply