Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Issues related to applications and software problems
xbatx
Posts: 76
Joined: 2010/08/28 08:49:31

Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by xbatx » 2019/08/13 17:17:53

I keep getting this error - Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1 ?? Any idea how to fix it?

User avatar
TrevorH
Forum Moderator
Posts: 27164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by TrevorH » 2019/08/13 17:52:46

Yes. That's a package intended for RHEL 7.7 which you cannot use because there is no CentOS 7.7 yet. ELRepo have a yum pluyin to avoid this or you can just --exclude=\*nvidia\* until 7.7 shows up.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

xbatx
Posts: 76
Joined: 2010/08/28 08:49:31

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by xbatx » 2019/08/13 19:09:17

Thank you trevor you truly are the best... I assume 7_7 is the version so I should be looking for 7_6 ??

User avatar
jlehtone
Posts: 2433
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by jlehtone » 2019/08/14 10:44:50

TrevorH wrote:
2019/08/13 17:52:46
ELRepo have a yum pluyin to avoid this
Alas, the yum-plugin-nvidia excludes (all versions of) package kmod-nvidia
ONLY IF the hardware requires a legacy branch driver (e.g. kmod-nvidia-390xx, kmod-nvidia-340xx, ...)
It does not protect 7_6 from 7_7.

The last kmod-nvidia for 7.6 is kmod-nvidia-430.40-1.el7_6.elrepo.


My strategy is to keep elrepo repository disabled at all times. That way I won't get implicit updates from it.

User avatar
TrevorH
Forum Moderator
Posts: 27164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by TrevorH » 2019/08/14 12:58:01

It does not protect 7_6 from 7_7.
I don't think it's kmod-nvidia that does it. There is a new ELRepo yum plugin that is designed specifically for the 7.x -> 7.y transition.

Code: Select all

# yum info yum-plugin-elrepo.noarch
Loaded plugins: priorities
725 packages excluded due to repository priority protections
Available Packages
Name        : yum-plugin-elrepo
Arch        : noarch
Version     : 7.5.1
Release     : 1.el7.elrepo
Size        : 12 k
Repo        : elrepo
Summary     : Yum plugin to exclude kmod packages where the required kernel is missing
URL         : https://github.com/elrepo/packages/tree/master/yum-plugin-elrepo
Licence     : GPLv2
Description : A yum plugin to exclude kmod packages from the yum transaction set which
            : require kernels that are not yet available.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

CaveDann
Posts: 21
Joined: 2018/12/14 15:05:27
Location: UK

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by CaveDann » 2019/08/14 13:11:25

Can I jump on this thread too with my problem? (Edit: I should point out that I only ended up at this step from reading the posts above.)

Mine pertains to kmod-nvidia-430.40-1.el7_6.elrepo.x86_64, so I'll make a new post if I'm told to do so.

I'm using:
  • CentOS Linux release 7.6.1810 (Core)
  • kernel 3.10.0-957.21.3.el7 .
I'm trying to install the kmod-nvidia package.

Code: Select all

yum --enablerepo=elrepo install kmod-nvidia-430.40-1.el7_6.elrepo
This gives the following output.

Code: Select all

Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mozart.ee.ic.ac.uk
 * elrepo: mirrors.coreix.net
 * epel: anorien.csc.warwick.ac.uk
 * extras: anorien.csc.warwick.ac.uk
 * rpmfusion-free-updates: ftp.nluug.nl
 * updates: mozart.ee.ic.ac.uk
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 0:430.40-1.el7_6.elrepo will be installed
--> Processing Dependency: nvidia-x11-drv = 430.40 for package: kmod-nvidia-430.40-1.el7_6.elrepo.x86_64
--> Running transaction check
---> Package nvidia-x11-drv.x86_64 0:430.40-1.el7_6.elrepo will be installed
--> Processing Dependency: nvidia-x11-drv-libs(x86-64) = 430.40-1.el7_6.elrepo for package: nvidia-x11-drv-430.40-1.el7_6.elrepo.x86_64
--> Processing Dependency: yum-plugin-nvidia >= 1.0.2 for package: nvidia-x11-drv-430.40-1.el7_6.elrepo.x86_64
--> Processing Dependency: libnvidia-tls.so.430.40()(64bit) for package: nvidia-x11-drv-430.40-1.el7_6.elrepo.x86_64
--> Processing Dependency: libnvidia-ml.so.1()(64bit) for package: nvidia-x11-drv-430.40-1.el7_6.elrepo.x86_64
--> Processing Dependency: libnvidia-glcore.so.430.40()(64bit) for package: nvidia-x11-drv-430.40-1.el7_6.elrepo.x86_64
--> Running transaction check
---> Package nvidia-x11-drv-libs.x86_64 0:430.40-1.el7_6.elrepo will be installed
---> Package yum-plugin-nvidia.noarch 0:1.0.2-1.el7.elrepo will be installed
--> Processing Conflict: nvidia-x11-drv-430.40-1.el7_6.elrepo.x86_64 conflicts ocl-icd
--> Finished Dependency Resolution
Error: nvidia-x11-drv conflicts with ocl-icd-2.2.12-1.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
Is there an obvious way around the conflict, between nvidia-x11-drv and ocl-icd, to get the kmod-nvidia drivers on the machine?

Cheers,
CD

User avatar
TrevorH
Forum Moderator
Posts: 27164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by TrevorH » 2019/08/14 13:36:18

Error: nvidia-x11-drv conflicts with ocl-icd-2.2.12-1.el7.x86_64
You can only pick one or the other. If you want kmod-nvidia then you have to remove the other package (and whatever else might depend on it).
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

CaveDann
Posts: 21
Joined: 2018/12/14 15:05:27
Location: UK

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by CaveDann » 2019/08/14 13:46:14

Thanks for the response. It's kind of unfortunate. The issue I'm facing is that GNOME keeps locking up and I'm assuming it has something to do with using the nouveau driver instead of the kmod-nvidia drivers. Could be wrong though.

If I was to go through rpmfusion instead of elrepo I get the following result.

Code: Select all

# yum install kmod-nvidia
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mozart.ee.ic.ac.uk
 * elrepo: mirrors.coreix.net
 * epel: anorien.csc.warwick.ac.uk
 * extras: anorien.csc.warwick.ac.uk
 * rpmfusion-free-updates: ftp.nluug.nl
 * rpmfusion-nonfree-updates: ftp.nluug.nl
 * updates: mozart.ee.ic.ac.uk
Resolving Dependencies
--> Running transaction check
---> Package kmod-nvidia.x86_64 3:430.40-1.el7 will be installed
--> Processing Dependency: kmod-nvidia-3.10.0-957.el7.x86_64 >= 3:430.40-1.el7 for package: 3:kmod-nvidia-430.40-1.el7.x86_64
--> Running transaction check
---> Package kmod-nvidia-3.10.0-957.el7.x86_64.x86_64 3:430.40-1.el7 will be installed
--> Processing Dependency: nvidia-kmod-common >= 3:430.40 for package: 3:kmod-nvidia-3.10.0-957.el7.x86_64-430.40-1.el7.x86_64
--> Running transaction check
---> Package xorg-x11-drv-nvidia.x86_64 3:430.40-1.el7 will be installed
--> Processing Dependency: xorg-x11-drv-nvidia-libs(x86-64) = 3:430.40-1.el7 for package: 3:xorg-x11-drv-nvidia-430.40-1.el7.x86_64
--> Processing Dependency: nvidia-xconfig(x86-64) = 3:430.40 for package: 3:xorg-x11-drv-nvidia-430.40-1.el7.x86_64
--> Processing Dependency: nvidia-settings(x86-64) = 3:430.40 for package: 3:xorg-x11-drv-nvidia-430.40-1.el7.x86_64
--> Processing Dependency: libnvidia-tls.so.430.40()(64bit) for package: 3:xorg-x11-drv-nvidia-430.40-1.el7.x86_64
--> Processing Dependency: libnvidia-glcore.so.430.40()(64bit) for package: 3:xorg-x11-drv-nvidia-430.40-1.el7.x86_64
--> Running transaction check
---> Package nvidia-settings.x86_64 3:430.40-1.el7 will be installed
---> Package nvidia-xconfig.x86_64 3:430.40-1.el7 will be installed
---> Package xorg-x11-drv-nvidia-libs.x86_64 3:430.40-1.el7 will be installed
--> Processing Dependency: mesa-libGLES(x86-64) >= 13.0.3-3 for package: 3:xorg-x11-drv-nvidia-libs-430.40-1.el7.x86_64
--> Processing Dependency: egl-wayland >= 1.0.0 for package: 3:xorg-x11-drv-nvidia-libs-430.40-1.el7.x86_64
--> Processing Dependency: libnvidia-fatbinaryloader.so.430.40()(64bit) for package: 3:xorg-x11-drv-nvidia-libs-430.40-1.el7.x86_64
--> Running transaction check
---> Package egl-wayland.x86_64 0:1.1.3-1.el7 will be installed
---> Package mesa-libGLES.x86_64 0:18.0.5-4.el7_6 will be installed
---> Package xorg-x11-drv-nvidia-cuda-libs.x86_64 3:430.40-1.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

==================================================================================================================================
 Package                                     Arch             Version                   Repository                           Size
==================================================================================================================================
Installing:
 kmod-nvidia                                 x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates            49 k
Installing for dependencies:
 egl-wayland                                 x86_64           1.1.3-1.el7               epel                                 29 k
 kmod-nvidia-3.10.0-957.el7.x86_64           x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates            12 M
 mesa-libGLES                                x86_64           18.0.5-4.el7_6            updates                              15 k
 nvidia-settings                             x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates           1.6 M
 nvidia-xconfig                              x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates            93 k
 xorg-x11-drv-nvidia                         x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates           2.3 M
 xorg-x11-drv-nvidia-cuda-libs               x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates            24 M
 xorg-x11-drv-nvidia-libs                    x86_64           3:430.40-1.el7            rpmfusion-nonfree-updates            35 M

Transaction Summary
==================================================================================================================================
Install  1 Package (+8 Dependent packages)

Total download size: 75 M
Installed size: 305 M
Is this ok [y/d/N]: 
Evidently this doesn't find a conflict at this stage. I'm reluctant though as I've seen elrepo is frequently suggested as the choice for NVIDIA drivers rather than rpmfusion.

Any further thoughts on this?

Cheers,
CD

User avatar
TrevorH
Forum Moderator
Posts: 27164
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by TrevorH » 2019/08/14 14:52:06

The ELRepo copy of kmod-nvidia (actually nvidia-x11-drv-libs) also provides the libs that come from ocl-icd which is why they conflict. If you have ELRepo's nvidia-x11-drv-libs then you don't need ocl-icd installed. Try yum remove ocl-icd and see what else it wants to remove with it.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 2433
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Error: Package: kmod-nvidia-430.40-2.el7_7.elrepo.x86_64 (elrepo) Requires: kernel(drm_mode_object_put) = 0x1

Post by jlehtone » 2019/08/14 16:44:17

TrevorH wrote:
2019/08/14 12:58:01
There is a new ELRepo yum plugin that is designed specifically for the 7.x -> 7.y transition.
Thanks! 8-)

Post Reply

Return to “CentOS 7 - Software Support”