can I install compat-gcc-34-g77 on CentOS 7.7?

Issues related to applications and software problems
Post Reply
LMHmedchem
Posts: 9
Joined: 2011/03/22 17:32:25
Location: Boston

can I install compat-gcc-34-g77 on CentOS 7.7?

Post by LMHmedchem » 2019/10/09 19:13:22

Hello,

I have some old code that needs to be recompiled with gcc34. I have a 5.9 VM that I can use to compile and the binaries run on 7.7 with no issues. I would also like to be able to rebuild on 7.7 to update some related components. Can I install the compat-gcc-34-g77-3.4.6-19.el6.x86_64.rpm on 7.7? Would I need any other compatibility libraries to get it working.

It would really help if I could get this working, so suggestions are definitely appreciated.

LMHmedchem

User avatar
jlehtone
Posts: 2308
Joined: 2007/12/11 08:17:33
Location: Finland

Re: can I install compat-gcc-34-g77 on CentOS 7.7?

Post by jlehtone » 2019/10/10 12:58:07

LMHmedchem wrote:
2019/10/09 19:13:22
Can I install the compat-gcc-34-g77-3.4.6-19.el6.x86_64.rpm on 7.7?
Short answer: no.

You say "gcc34", but then mention the Fortran 77 package. Is it Fortran 77 that you need, rather than GCC's C/C++?

If it is Fortran, what would you get with gcc-gfortran-4.8.5-39.el7:

Code: Select all

gfortran -std=legacy

Post Reply

Return to “CentOS 7 - Software Support”