Skype

Issues related to applications and software problems
Post Reply
murphy
Posts: 4
Joined: 2014/07/11 09:16:55

Skype

Post by murphy » 2014/07/11 13:46:18

I know skype was quite hard to install in previous versions of CentOS because of old gcc kernel version, but with new v7 it could change now.
It is too soon to wait for skype to prepare easy installation package for CentOS 7, meanwhile I tried the old way of installing compatibility 32bit libraries but I always end up with unresolvable yum dependencies.

Did anyone successfully installed the skype on C7?

thank you

stevemowbray
Posts: 480
Joined: 2012/06/26 14:20:47

Re: Skype

Post by stevemowbray » 2014/07/11 14:55:13

It's in the nux dextop repo for 7.

nbritton
Posts: 38
Joined: 2014/07/09 23:38:46

Re: Skype

Post by nbritton » 2014/07/11 17:59:26

I don't see Skype working on a stock el7 system until they release a 64-bit version. RHEL7 is 64-bit x86_64 only now, Red Hat withdrew the 32-bit i686 distribution. The unresolvable dependancies you encountered (i.g. qtwebkit) are due to the 32-bit version of the package no longer being contained in the epel repo. Only the 64-bit package of qtwebkit is provided by epel. While CentOS has plans in the works to release an i686 distribution, I don't believe the epel repository has plans to release el7 32-bit i686 packages.

I tried using mock to build the i686 packages from source rpm, i.g. "wget http://dl.fedoraproject.org/pub/epel/be ... l7.src.rpm && mock --target=i686 qtwebkit-2.3.3-3.el7.src.rpm", but the build fails.

User avatar
TrevorH
Forum Moderator
Posts: 27127
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Skype

Post by TrevorH » 2014/07/11 18:06:25

I believe the 32 bit libraries required by Skype on el7 are available in the nux-dextop repo.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

nbritton
Posts: 38
Joined: 2014/07/09 23:38:46

Re: Skype

Post by nbritton » 2014/07/11 18:19:25

TrevorH wrote:I believe the 32 bit libraries required by Skype on el7 are available in the nux-dextop repo.
http://li.nux.ro/repos.html

That worked. The only package it need from nux-dextop was qtwebkit, all of the other dependancies came from the base repo.

Code: Select all

rpm -Uvh http://li.nux.ro/download/nux/dextop/el7/x86_64/nux-dextop-release-0-1.el7.nux.noarch.rpm;
yum localinstall http://download.skype.com/linux/skype-4.3.0.37-fedora.i586.rpm;

Code: Select all

[root@localhost ~]# yum localinstall http://download.skype.com/linux/skype-4.3.0.37-fedora.i586.rpm
Loaded plugins: fastestmirror, langpacks
skype-4.3.0.37-fedora.i586.rpm                                                                                                                 |  19 MB  00:00:06     
Examining /var/tmp/yum-root-KsnLvH/skype-4.3.0.37-fedora.i586.rpm: skype-4.3.0.37-fc16.i586
Marking /var/tmp/yum-root-KsnLvH/skype-4.3.0.37-fedora.i586.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package skype.i586 0:4.3.0.37-fc16 will be installed
--> Processing Dependency: alsa-plugins-pulseaudio(x86-32) for package: skype-4.3.0.37-fc16.i586
nux-dextop                                                                                                                                     | 2.9 kB  00:00:00     
nux-dextop/x86_64/primary_db                                                                                                                   | 405 kB  00:00:02     
Loading mirror speeds from cached hostfile
 * base: mirror.atlanticmetro.net
 * epel: mirror.cogentco.com
 * extras: mirror.es.its.nyu.edu
 * nux-dextop: li.nux.ro
 * updates: mirror.anl.gov
--> Processing Dependency: libQtWebKit.so.4 for package: skype-4.3.0.37-fc16.i586
--> Running transaction check
---> Package alsa-plugins-pulseaudio.i686 0:1.0.27-3.el7 will be installed
--> Processing Dependency: libpulse.so.0(PULSE_0) for package: alsa-plugins-pulseaudio-1.0.27-3.el7.i686
--> Processing Dependency: libpulse.so.0 for package: alsa-plugins-pulseaudio-1.0.27-3.el7.i686
---> Package qtwebkit.i686 0:2.3.3-3.el7 will be installed
--> Processing Dependency: libxslt.so.1(LIBXML2_1.1.9) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxslt.so.1 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.6) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.6.0) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxml2.so.2(LIBXML2_2.4.30) for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libxml2.so.2 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libwebp.so.4 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libgstvideo-0.10.so.0 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libgstreamer-0.10.so.0 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libgstpbutils-0.10.so.0 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libgstinterfaces-0.10.so.0 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libgstbase-0.10.so.0 for package: qtwebkit-2.3.3-3.el7.i686
--> Processing Dependency: libgstapp-0.10.so.0 for package: qtwebkit-2.3.3-3.el7.i686
--> Running transaction check
---> Package gstreamer.i686 0:0.10.36-7.el7 will be installed
---> Package gstreamer-plugins-base.i686 0:0.10.36-10.el7 will be installed
--> Processing Dependency: libvorbisenc.so.2 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libvorbis.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libvisual-0.4.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libtheoraenc.so.1(libtheoraenc_1.0) for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libtheoraenc.so.1 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libtheoradec.so.1(libtheoradec_1.0) for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libtheoradec.so.1 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libpangocairo-1.0.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libpango-1.0.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: liborc-test-0.4.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: liborc-0.4.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libogg.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libcdda_paranoia.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libcdda_interface.so.0 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
--> Processing Dependency: libcairo.so.2 for package: gstreamer-plugins-base-0.10.36-10.el7.i686
---> Package libwebp.i686 0:0.3.0-3.el7 will be installed
---> Package libxml2.i686 0:2.9.1-5.el7 will be installed
---> Package libxslt.i686 0:1.1.28-5.el7 will be installed
--> Processing Dependency: libgpg-error.so.0 for package: libxslt-1.1.28-5.el7.i686
--> Processing Dependency: libgcrypt.so.11(GCRYPT_1.2) for package: libxslt-1.1.28-5.el7.i686
--> Processing Dependency: libgcrypt.so.11 for package: libxslt-1.1.28-5.el7.i686
---> Package pulseaudio-libs.i686 0:3.0-22.el7 will be installed
--> Processing Dependency: libwrap.so.0 for package: pulseaudio-libs-3.0-22.el7.i686
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: pulseaudio-libs-3.0-22.el7.i686
--> Processing Dependency: libsndfile.so.1 for package: pulseaudio-libs-3.0-22.el7.i686
--> Processing Dependency: libjson-c.so.2 for package: pulseaudio-libs-3.0-22.el7.i686
--> Processing Dependency: libcap.so.2 for package: pulseaudio-libs-3.0-22.el7.i686
--> Processing Dependency: libasyncns.so.0 for package: pulseaudio-libs-3.0-22.el7.i686
--> Processing Dependency: libXtst.so.6 for package: pulseaudio-libs-3.0-22.el7.i686
--> Running transaction check
---> Package cairo.i686 0:1.12.14-6.el7 will be installed
--> Processing Dependency: libpixman-1.so.0 for package: cairo-1.12.14-6.el7.i686
--> Processing Dependency: libEGL.so.1 for package: cairo-1.12.14-6.el7.i686
---> Package cdparanoia-libs.i686 0:10.2-17.el7 will be installed
---> Package json-c.i686 0:0.11-4.el7_0 will be installed
---> Package libXtst.i686 0:1.2.2-2.1.el7 will be installed
---> Package libasyncns.i686 0:0.8-7.el7 will be installed
---> Package libcap.i686 0:2.22-8.el7 will be installed
--> Processing Dependency: libattr.so.1(ATTR_1.0) for package: libcap-2.22-8.el7.i686
--> Processing Dependency: libattr.so.1 for package: libcap-2.22-8.el7.i686
---> Package libgcrypt.i686 0:1.5.3-4.el7 will be installed
---> Package libgpg-error.i686 0:1.12-3.el7 will be installed
---> Package libogg.i686 2:1.3.0-7.el7 will be installed
---> Package libsndfile.i686 0:1.0.25-9.el7 will be installed
--> Processing Dependency: libgsm.so.1 for package: libsndfile-1.0.25-9.el7.i686
--> Processing Dependency: libFLAC.so.8 for package: libsndfile-1.0.25-9.el7.i686
---> Package libtheora.i686 1:1.1.1-8.el7 will be installed
---> Package libvisual.i686 0:0.4.0-16.el7 will be installed
---> Package libvorbis.i686 1:1.3.3-8.el7 will be installed
---> Package orc.i686 0:0.4.17-5.el7 will be installed
---> Package pango.i686 0:1.34.1-5.el7 will be installed
--> Processing Dependency: libthai.so.0(LIBTHAI_0.1) for package: pango-1.34.1-5.el7.i686
--> Processing Dependency: libthai.so.0 for package: pango-1.34.1-5.el7.i686
--> Processing Dependency: libharfbuzz.so.0 for package: pango-1.34.1-5.el7.i686
--> Processing Dependency: libXft.so.2 for package: pango-1.34.1-5.el7.i686
---> Package tcp_wrappers-libs.i686 0:7.6-77.el7 will be installed
--> Running transaction check
---> Package flac-libs.i686 0:1.3.0-4.el7 will be installed
---> Package gsm.i686 0:1.0.13-11.el7 will be installed
---> Package harfbuzz.i686 0:0.9.20-3.el7 will be installed
--> Processing Dependency: libgraphite2.so.3 for package: harfbuzz-0.9.20-3.el7.i686
---> Package libXft.i686 0:2.3.1-5.1.el7 will be installed
---> Package libattr.i686 0:2.4.46-12.el7 will be installed
---> Package libthai.i686 0:0.1.14-9.el7 will be installed
---> Package mesa-libEGL.i686 0:9.2.5-5.20131218.el7 will be installed
--> Processing Dependency: libudev.so.1(LIBUDEV_183) for package: mesa-libEGL-9.2.5-5.20131218.el7.i686
--> Processing Dependency: libudev.so.1 for package: mesa-libEGL-9.2.5-5.20131218.el7.i686
--> Processing Dependency: libgbm.so.1 for package: mesa-libEGL-9.2.5-5.20131218.el7.i686
---> Package pixman.i686 0:0.32.4-3.el7 will be installed
--> Running transaction check
---> Package graphite2.i686 0:1.2.2-5.el7 will be installed
---> Package mesa-libgbm.i686 0:9.2.5-5.20131218.el7 will be installed
---> Package systemd-libs.i686 0:208-11.el7 will be installed
--> Processing Dependency: libpam_misc.so.0(LIBPAM_MISC_1.0) for package: systemd-libs-208-11.el7.i686
--> Processing Dependency: libpam_misc.so.0 for package: systemd-libs-208-11.el7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_MODUTIL_1.0) for package: systemd-libs-208-11.el7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_EXTENSION_1.0) for package: systemd-libs-208-11.el7.i686
--> Processing Dependency: libpam.so.0(LIBPAM_1.0) for package: systemd-libs-208-11.el7.i686
--> Processing Dependency: libpam.so.0 for package: systemd-libs-208-11.el7.i686
--> Running transaction check
---> Package pam.i686 0:1.1.8-9.el7 will be installed
--> Processing Dependency: libdb-5.3.so for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libcrack.so.2 for package: pam-1.1.8-9.el7.i686
--> Processing Dependency: libaudit.so.1 for package: pam-1.1.8-9.el7.i686
--> Running transaction check
---> Package audit-libs.i686 0:2.3.3-4.el7 will be installed
---> Package cracklib.i686 0:2.9.0-11.el7 will be installed
---> Package libdb.i686 0:5.3.21-17.el7 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

======================================================================================================================================================================
 Package                                     Arch                     Version                                   Repository                                       Size
======================================================================================================================================================================
Installing:
 skype                                       i586                     4.3.0.37-fc16                             /skype-4.3.0.37-fedora.i586                      42 M
Installing for dependencies:
 alsa-plugins-pulseaudio                     i686                     1.0.27-3.el7                              base                                             40 k
 audit-libs                                  i686                     2.3.3-4.el7                               base                                             77 k
 cairo                                       i686                     1.12.14-6.el7                             base                                            722 k
 cdparanoia-libs                             i686                     10.2-17.el7                               base                                             55 k
 cracklib                                    i686                     2.9.0-11.el7                              base                                             79 k
 flac-libs                                   i686                     1.3.0-4.el7                               base                                            171 k
 graphite2                                   i686                     1.2.2-5.el7                               base                                             82 k
 gsm                                         i686                     1.0.13-11.el7                             base                                             30 k
 gstreamer                                   i686                     0.10.36-7.el7                             base                                            964 k
 gstreamer-plugins-base                      i686                     0.10.36-10.el7                            base                                            1.2 M
 harfbuzz                                    i686                     0.9.20-3.el7                              base                                            144 k
 json-c                                      i686                     0.11-4.el7_0                              updates                                          31 k
 libXft                                      i686                     2.3.1-5.1.el7                             base                                             57 k
 libXtst                                     i686                     1.2.2-2.1.el7                             base                                             20 k
 libasyncns                                  i686                     0.8-7.el7                                 base                                             26 k
 libattr                                     i686                     2.4.46-12.el7                             base                                             18 k
 libcap                                      i686                     2.22-8.el7                                base                                             47 k
 libdb                                       i686                     5.3.21-17.el7                             base                                            729 k
 libgcrypt                                   i686                     1.5.3-4.el7                               base                                            254 k
 libgpg-error                                i686                     1.12-3.el7                                base                                             87 k
 libogg                                      i686                     2:1.3.0-7.el7                             base                                             25 k
 libsndfile                                  i686                     1.0.25-9.el7                              base                                            159 k
 libthai                                     i686                     0.1.14-9.el7                              base                                            188 k
 libtheora                                   i686                     1:1.1.1-8.el7                             base                                            139 k
 libvisual                                   i686                     0.4.0-16.el7                              base                                            140 k
 libvorbis                                   i686                     1:1.3.3-8.el7                             base                                            195 k
 libwebp                                     i686                     0.3.0-3.el7                               base                                            169 k
 libxml2                                     i686                     2.9.1-5.el7                               base                                            649 k
 libxslt                                     i686                     1.1.28-5.el7                              base                                            237 k
 mesa-libEGL                                 i686                     9.2.5-5.20131218.el7                      base                                             69 k
 mesa-libgbm                                 i686                     9.2.5-5.20131218.el7                      base                                             30 k
 orc                                         i686                     0.4.17-5.el7                              base                                            170 k
 pam                                         i686                     1.1.8-9.el7                               base                                            710 k
 pango                                       i686                     1.34.1-5.el7                              base                                            283 k
 pixman                                      i686                     0.32.4-3.el7                              base                                            254 k
 pulseaudio-libs                             i686                     3.0-22.el7                                base                                            543 k
 qtwebkit                                    i686                     2.3.3-3.el7                               nux-dextop                                       20 M
 systemd-libs                                i686                     208-11.el7                                base                                            159 k
 tcp_wrappers-libs                           i686                     7.6-77.el7                                base                                             66 k

Transaction Summary
======================================================================================================================================================================
Install  1 Package (+39 Dependent packages)

Total size: 71 M
Total download size: 29 M
Installed size: 135 M
Is this ok [y/d/N]: y
Downloading packages:
(1/39): alsa-plugins-pulseaudio-1.0.27-3.el7.i686.rpm                                                                                          |  40 kB  00:00:00     
(2/39): cracklib-2.9.0-11.el7.i686.rpm                                                                                                         |  79 kB  00:00:00     
(3/39): cdparanoia-libs-10.2-17.el7.i686.rpm                                                                                                   |  55 kB  00:00:00     
(4/39): audit-libs-2.3.3-4.el7.i686.rpm                                                                                                        |  77 kB  00:00:00     
(5/39): graphite2-1.2.2-5.el7.i686.rpm                                                                                                         |  82 kB  00:00:00     
(6/39): gsm-1.0.13-11.el7.i686.rpm                                                                                                             |  30 kB  00:00:00     
(7/39): flac-libs-1.3.0-4.el7.i686.rpm                                                                                                         | 171 kB  00:00:00     
(8/39): cairo-1.12.14-6.el7.i686.rpm                                                                                                           | 722 kB  00:00:01     
(9/39): harfbuzz-0.9.20-3.el7.i686.rpm                                                                                                         | 144 kB  00:00:00     
(10/39): libXtst-1.2.2-2.1.el7.i686.rpm                                                                                                        |  20 kB  00:00:00     
(11/39): json-c-0.11-4.el7_0.i686.rpm                                                                                                          |  31 kB  00:00:00     
(12/39): libasyncns-0.8-7.el7.i686.rpm                                                                                                         |  26 kB  00:00:00     
(13/39): libattr-2.4.46-12.el7.i686.rpm                                                                                                        |  18 kB  00:00:00     
(14/39): libXft-2.3.1-5.1.el7.i686.rpm                                                                                                         |  57 kB  00:00:00     
(15/39): libcap-2.22-8.el7.i686.rpm                                                                                                            |  47 kB  00:00:00     
(16/39): libgcrypt-1.5.3-4.el7.i686.rpm                                                                                                        | 254 kB  00:00:00     
(17/39): gstreamer-plugins-base-0.10.36-10.el7.i686.rpm                                                                                        | 1.2 MB  00:00:01     
(18/39): gstreamer-0.10.36-7.el7.i686.rpm                                                                                                      | 964 kB  00:00:01     
(19/39): libdb-5.3.21-17.el7.i686.rpm                                                                                                          | 729 kB  00:00:00     
(20/39): libgpg-error-1.12-3.el7.i686.rpm                                                                                                      |  87 kB  00:00:00     
(21/39): libogg-1.3.0-7.el7.i686.rpm                                                                                                           |  25 kB  00:00:00     
(22/39): libtheora-1.1.1-8.el7.i686.rpm                                                                                                        | 139 kB  00:00:00     
(23/39): libsndfile-1.0.25-9.el7.i686.rpm                                                                                                      | 159 kB  00:00:00     
(24/39): libvisual-0.4.0-16.el7.i686.rpm                                                                                                       | 140 kB  00:00:00     
(25/39): libwebp-0.3.0-3.el7.i686.rpm                                                                                                          | 169 kB  00:00:00     
(26/39): libvorbis-1.3.3-8.el7.i686.rpm                                                                                                        | 195 kB  00:00:00     
(27/39): libthai-0.1.14-9.el7.i686.rpm                                                                                                         | 188 kB  00:00:00     
(28/39): mesa-libgbm-9.2.5-5.20131218.el7.i686.rpm                                                                                             |  30 kB  00:00:00     
(29/39): mesa-libEGL-9.2.5-5.20131218.el7.i686.rpm                                                                                             |  69 kB  00:00:00     
(30/39): libxslt-1.1.28-5.el7.i686.rpm                                                                                                         | 237 kB  00:00:00     
(31/39): libxml2-2.9.1-5.el7.i686.rpm                                                                                                          | 649 kB  00:00:00     
(32/39): pixman-0.32.4-3.el7.i686.rpm                                                                                                          | 254 kB  00:00:00     
(33/39): pango-1.34.1-5.el7.i686.rpm                                                                                                           | 283 kB  00:00:00     
(34/39): systemd-libs-208-11.el7.i686.rpm                                                                                                      | 159 kB  00:00:00     
(35/39): orc-0.4.17-5.el7.i686.rpm                                                                                                             | 170 kB  00:00:00     
(36/39): tcp_wrappers-libs-7.6-77.el7.i686.rpm                                                                                                 |  66 kB  00:00:00     
(37/39): pulseaudio-libs-3.0-22.el7.i686.rpm                                                                                                   | 543 kB  00:00:00     
(38/39): pam-1.1.8-9.el7.i686.rpm                                                                                                              | 710 kB  00:00:01     
warning: /var/cache/yum/x86_64/7/nux-dextop/packages/qtwebkit-2.3.3-3.el7.i686.rpm: Header V4 RSA/SHA1 Signature, key ID 85c6cd8a: NOKEY2 MB/s |  28 MB  00:00:00 ETA 
Public key for qtwebkit-2.3.3-3.el7.i686.rpm is not installed
(39/39): qtwebkit-2.3.3-3.el7.i686.rpm                                                                                                         |  20 MB  00:00:14     
----------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                 1.6 MB/s |  29 MB  00:00:18     
Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
Importing GPG key 0x85C6CD8A:
 Userid     : "Nux.Ro (rpm builder) <rpm@li.nux.ro>"
 Fingerprint: 561c 96bd 2f7f dc2a db5a fd46 e98b fbe7 85c6 cd8a
 Package    : nux-dextop-release-0-1.el7.nux.noarch (installed)
 From       : /etc/pki/rpm-gpg/RPM-GPG-KEY-nux.ro
Is this ok [y/N]: y
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Warning: RPMDB altered outside of yum.
  Installing : 2:libogg-1.3.0-7.el7.i686                                                                                                                         1/40 
  Installing : libxml2-2.9.1-5.el7.i686                                                                                                                          2/40 
  Installing : libgpg-error-1.12-3.el7.i686                                                                                                                      3/40 
  Installing : libgcrypt-1.5.3-4.el7.i686                                                                                                                        4/40 
  Installing : gstreamer-0.10.36-7.el7.i686                                                                                                                      5/40 
  Installing : 1:libvorbis-1.3.3-8.el7.i686                                                                                                                      6/40 
  Installing : libxslt-1.1.28-5.el7.i686                                                                                                                         7/40 
  Installing : 1:libtheora-1.1.1-8.el7.i686                                                                                                                      8/40 
  Installing : flac-libs-1.3.0-4.el7.i686                                                                                                                        9/40 
  Installing : libwebp-0.3.0-3.el7.i686                                                                                                                         10/40 
  Installing : libvisual-0.4.0-16.el7.i686                                                                                                                      11/40 
  Installing : libthai-0.1.14-9.el7.i686                                                                                                                        12/40 
  Installing : tcp_wrappers-libs-7.6-77.el7.i686                                                                                                                13/40 
  Installing : gsm-1.0.13-11.el7.i686                                                                                                                           14/40 
  Installing : libsndfile-1.0.25-9.el7.i686                                                                                                                     15/40 
  Installing : libattr-2.4.46-12.el7.i686                                                                                                                       16/40 
  Installing : libcap-2.22-8.el7.i686                                                                                                                           17/40 
  Installing : cdparanoia-libs-10.2-17.el7.i686                                                                                                                 18/40 
  Installing : json-c-0.11-4.el7_0.i686                                                                                                                         19/40 
  Installing : graphite2-1.2.2-5.el7.i686                                                                                                                       20/40 
  Installing : harfbuzz-0.9.20-3.el7.i686                                                                                                                       21/40 
  Installing : libXtst-1.2.2-2.1.el7.i686                                                                                                                       22/40 
  Installing : audit-libs-2.3.3-4.el7.i686                                                                                                                      23/40 
  Installing : cracklib-2.9.0-11.el7.i686                                                                                                                       24/40 
  Installing : libXft-2.3.1-5.1.el7.i686                                                                                                                        25/40 
  Installing : pixman-0.32.4-3.el7.i686                                                                                                                         26/40 
  Installing : libdb-5.3.21-17.el7.i686                                                                                                                         27/40 
  Installing : pam-1.1.8-9.el7.i686                                                                                                                             28/40 
  Installing : systemd-libs-208-11.el7.i686                                                                                                                     29/40 
  Installing : mesa-libgbm-9.2.5-5.20131218.el7.i686                                                                                                            30/40 
  Installing : mesa-libEGL-9.2.5-5.20131218.el7.i686                                                                                                            31/40 
  Installing : cairo-1.12.14-6.el7.i686                                                                                                                         32/40 
  Installing : pango-1.34.1-5.el7.i686                                                                                                                          33/40 
  Installing : libasyncns-0.8-7.el7.i686                                                                                                                        34/40 
  Installing : pulseaudio-libs-3.0-22.el7.i686                                                                                                                  35/40 
  Installing : alsa-plugins-pulseaudio-1.0.27-3.el7.i686                                                                                                        36/40 
  Installing : orc-0.4.17-5.el7.i686                                                                                                                            37/40 
  Installing : gstreamer-plugins-base-0.10.36-10.el7.i686                                                                                                       38/40 
  Installing : qtwebkit-2.3.3-3.el7.i686                                                                                                                        39/40 
  Installing : skype-4.3.0.37-fc16.i586                                                                                                                         40/40 
  Verifying  : orc-0.4.17-5.el7.i686                                                                                                                             1/40 
  Verifying  : libasyncns-0.8-7.el7.i686                                                                                                                         2/40 
  Verifying  : cairo-1.12.14-6.el7.i686                                                                                                                          3/40 
  Verifying  : libdb-5.3.21-17.el7.i686                                                                                                                          4/40 
  Verifying  : 1:libtheora-1.1.1-8.el7.i686                                                                                                                      5/40 
  Verifying  : 1:libvorbis-1.3.3-8.el7.i686                                                                                                                      6/40 
  Verifying  : pango-1.34.1-5.el7.i686                                                                                                                           7/40 
  Verifying  : mesa-libgbm-9.2.5-5.20131218.el7.i686                                                                                                             8/40 
  Verifying  : systemd-libs-208-11.el7.i686                                                                                                                      9/40 
  Verifying  : pixman-0.32.4-3.el7.i686                                                                                                                         10/40 
  Verifying  : libXft-2.3.1-5.1.el7.i686                                                                                                                        11/40 
  Verifying  : mesa-libEGL-9.2.5-5.20131218.el7.i686                                                                                                            12/40 
  Verifying  : cracklib-2.9.0-11.el7.i686                                                                                                                       13/40 
  Verifying  : libcap-2.22-8.el7.i686                                                                                                                           14/40 
  Verifying  : libsndfile-1.0.25-9.el7.i686                                                                                                                     15/40 
  Verifying  : audit-libs-2.3.3-4.el7.i686                                                                                                                      16/40 
  Verifying  : 2:libogg-1.3.0-7.el7.i686                                                                                                                        17/40 
  Verifying  : libxml2-2.9.1-5.el7.i686                                                                                                                         18/40 
  Verifying  : skype-4.3.0.37-fc16.i586                                                                                                                         19/40 
  Verifying  : pam-1.1.8-9.el7.i686                                                                                                                             20/40 
  Verifying  : libXtst-1.2.2-2.1.el7.i686                                                                                                                       21/40 
  Verifying  : graphite2-1.2.2-5.el7.i686                                                                                                                       22/40 
  Verifying  : json-c-0.11-4.el7_0.i686                                                                                                                         23/40 
  Verifying  : cdparanoia-libs-10.2-17.el7.i686                                                                                                                 24/40 
  Verifying  : libattr-2.4.46-12.el7.i686                                                                                                                       25/40 
  Verifying  : gsm-1.0.13-11.el7.i686                                                                                                                           26/40 
  Verifying  : flac-libs-1.3.0-4.el7.i686                                                                                                                       27/40 
  Verifying  : tcp_wrappers-libs-7.6-77.el7.i686                                                                                                                28/40 
  Verifying  : pulseaudio-libs-3.0-22.el7.i686                                                                                                                  29/40 
  Verifying  : libxslt-1.1.28-5.el7.i686                                                                                                                        30/40 
  Verifying  : alsa-plugins-pulseaudio-1.0.27-3.el7.i686                                                                                                        31/40 
  Verifying  : qtwebkit-2.3.3-3.el7.i686                                                                                                                        32/40 
  Verifying  : harfbuzz-0.9.20-3.el7.i686                                                                                                                       33/40 
  Verifying  : libthai-0.1.14-9.el7.i686                                                                                                                        34/40 
  Verifying  : libvisual-0.4.0-16.el7.i686                                                                                                                      35/40 
  Verifying  : libwebp-0.3.0-3.el7.i686                                                                                                                         36/40 
  Verifying  : gstreamer-0.10.36-7.el7.i686                                                                                                                     37/40 
  Verifying  : gstreamer-plugins-base-0.10.36-10.el7.i686                                                                                                       38/40 
  Verifying  : libgcrypt-1.5.3-4.el7.i686                                                                                                                       39/40 
  Verifying  : libgpg-error-1.12-3.el7.i686                                                                                                                     40/40 

Installed:
  skype.i586 0:4.3.0.37-fc16                                                                                                                                          

Dependency Installed:
  alsa-plugins-pulseaudio.i686 0:1.0.27-3.el7 audit-libs.i686 0:2.3.3-4.el7                cairo.i686 0:1.12.14-6.el7              cdparanoia-libs.i686 0:10.2-17.el7
  cracklib.i686 0:2.9.0-11.el7                flac-libs.i686 0:1.3.0-4.el7                 graphite2.i686 0:1.2.2-5.el7            gsm.i686 0:1.0.13-11.el7          
  gstreamer.i686 0:0.10.36-7.el7              gstreamer-plugins-base.i686 0:0.10.36-10.el7 harfbuzz.i686 0:0.9.20-3.el7            json-c.i686 0:0.11-4.el7_0        
  libXft.i686 0:2.3.1-5.1.el7                 libXtst.i686 0:1.2.2-2.1.el7                 libasyncns.i686 0:0.8-7.el7             libattr.i686 0:2.4.46-12.el7      
  libcap.i686 0:2.22-8.el7                    libdb.i686 0:5.3.21-17.el7                   libgcrypt.i686 0:1.5.3-4.el7            libgpg-error.i686 0:1.12-3.el7    
  libogg.i686 2:1.3.0-7.el7                   libsndfile.i686 0:1.0.25-9.el7               libthai.i686 0:0.1.14-9.el7             libtheora.i686 1:1.1.1-8.el7      
  libvisual.i686 0:0.4.0-16.el7               libvorbis.i686 1:1.3.3-8.el7                 libwebp.i686 0:0.3.0-3.el7              libxml2.i686 0:2.9.1-5.el7        
  libxslt.i686 0:1.1.28-5.el7                 mesa-libEGL.i686 0:9.2.5-5.20131218.el7      mesa-libgbm.i686 0:9.2.5-5.20131218.el7 orc.i686 0:0.4.17-5.el7           
  pam.i686 0:1.1.8-9.el7                      pango.i686 0:1.34.1-5.el7                    pixman.i686 0:0.32.4-3.el7              pulseaudio-libs.i686 0:3.0-22.el7 
  qtwebkit.i686 0:2.3.3-3.el7                 systemd-libs.i686 0:208-11.el7               tcp_wrappers-libs.i686 0:7.6-77.el7    

Complete!

bertan
Posts: 55
Joined: 2014/01/12 23:43:19
Location: Canada

Re: Skype

Post by bertan » 2014/07/13 00:55:47

Have you tried the "Fedora 16" rpm from http://www.skype.com/en/download-skype/skype-for-linux/ ? It works with Fedora 20.

User avatar
TrevorH
Forum Moderator
Posts: 27127
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Skype

Post by TrevorH » 2014/07/13 01:02:56

Whichever skype rpm you use, it will be 32 bit so it needs libraries that are not supplied by base CentOS repos. Currently the only place I am aware of that has those required 32 bit libraries is nux-dextop. Once you have those then you can use the latest skype rpm so you might as well do that.
CentOS 6 will die in November 2020 - migrate sooner rather than later!
CentOS 5 has been EOL for nearly 3 years and should no longer be used for anything!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”