Nvidia drivers not working on brand new centos 7 workstation

Issues related to applications and software problems
User avatar
toracat
Forum Moderator
Posts: 7383
Joined: 2006/09/03 16:37:24
Location: California, US
Contact:

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by toracat » 2015/02/01 19:34:51

Hmmm I have no idea. Your card (GeForce GT 440) is apparently supported by that driver. Do you see any hint in /var/log/Xorg.0.log(.old)?
CentOS Forum FAQ

chemal
Posts: 589
Joined: 2013/12/08 19:44:49

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by chemal » 2015/02/01 20:20:37

If you are seeing penguins, you are using a non-VGA console. Are you booting via UEFI?

lpallard
Posts: 50
Joined: 2014/09/17 02:39:48

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by lpallard » 2015/02/02 12:05:08

Hmm good question... TO be honest until centos 7 I had no experience with UEFI (my supermicro servers dont have that horror) but my workstation does have a UEFI bios...

I just looked at the partition scheme and

Code: Select all

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk label type: gpt

#         Start          End    Size  Type            Name
 1         2048       411647    200M  EFI System      EFI System Partition
 2       411648      1435647    500M  Microsoft basic 
 3      1435648   1953523711  930.8G  Microsoft basic 
and

Code: Select all

[root@workstation workstation-user]# mount | grep /dev
devtmpfs on /dev type devtmpfs (rw,nosuid,seclabel,size=4027196k,nr_inodes=1006799,mode=755)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev,seclabel)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,seclabel,gid=5,mode=620,ptmxmode=000)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
/dev/mapper/centos-root on / type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
mqueue on /dev/mqueue type mqueue (rw,relatime,seclabel)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,seclabel)
/dev/sda2 on /boot type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
/dev/sda1 on /boot/efi type vfat (rw,relatime,fmask=0077,dmask=0077,codepage=437,iocharset=ascii,shortname=winnt,errors=remount-ro)
/dev/mapper/centos-home on /home type xfs (rw,relatime,seclabel,attr2,inode64,noquota)
OK that raises 2 questions: what the hell is EFI System and why is there 2 boot mount points (/boot and /efi)??

You may be on the right track chemal!!

chemal
Posts: 589
Joined: 2013/12/08 19:44:49

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by chemal » 2015/02/02 17:27:02

Point is that nvidia's drivers officially only support plain old vga console, not the more fancy framebuffer stuff that produces the penguins. But with UEFI you always get a framebuffer console. My suggestion is therefore to do a non-UEFI installation and see if that helps.

lpallard
Posts: 50
Joined: 2014/09/17 02:39:48

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by lpallard » 2015/02/02 21:54:43

plain old vga console, not the more fancy framebuffer stuff
Plain old worked perfect, fancy stuff create problems. Especially with a OS supposedly tailored for stability and dependability....

Is there a way to revert this EFI boot crap to standard /boot that Ive been used since the early 90's without reinstalling centos from scratch?

Ill do a search on this one but Im interested to hear what you guys have to say..

lpallard
Posts: 50
Joined: 2014/09/17 02:39:48

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by lpallard » 2015/02/07 22:25:56

Oh well, at the expense of frustrating some maintainers, developers or contributors, I feel compelled to post what happened as a FU.

While searching on this topic and issue (which appeared *sketchy* and suspicious to me), I ended up confirming that UEFI+Nvidia=No boot! It appears that at this moment, the nvidia proprietary blob doesnt support UEFI. So chemal, you hit the nail on the head!

Trying all kind of things from web sites claiming that they went through the same issue and claimed having found a solution, I tried to no avail to bypass the UEFI process and have a normal grub boot process in which the nvidia modules could be loaded. Nothing worked and I ended up tired and deluded. Clock ticking and facing a totally wrecked system, I decided to reinstall Centos 7 from scratch (lost hours of config and setup!!!!) thinking I'd avoid the UEFI partitioning alltogether and get rid of the /boot/uefi partition containing the malicious stuff. Anaconda wouldnt let me have a traditional /boot, /, /home partitioning scheme that worked so well for decades and that posed very little limitations to its users. Anaconda was very rigid and insisted a /boot/uefi partition be created. Cant remember the exact error messages but it was something like "error missing second stage boot partition" or similar... Adding a /boot/uefi mountpoint solved everything from a partition POV but that didnt work for me. At last, I tried to disable all that nonsense in the machine's BIOS, I couldnt. Googling for the motherboard model and BIOS version revealed that there is no way to disable UEFI.

That experience made me realize that force-feeding UEFI is unacceptable. I understand that red hat opted to force UEFI down its customer's throat but this is unacceptable and actually quite frustrating. That means, starting with RHEL 7.0, the complete lineup of Centos/RHEL/Fedora is now practically useless to me.

I ended up re-installing 6.5 which Im using right now. All works well. Same old stuff that worked for years. Will never "upgrade" to RHEL7 unless things change.

More reading: while searching for a solution, I came across this page, I must say, this guy literally took the words out of my mouth and I couldnt have said better. This is almost an exact replica of what happened to me.

https://ask.fedoraproject.org/en/questi ... if-so-how/

I *sincerely* hope this post is seen as constructive criticism and constructive feedback rather than rant, I usually dont bother typing for half hour only to complain.. :)

chemal
Posts: 589
Joined: 2013/12/08 19:44:49

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by chemal » 2015/02/08 20:28:45

It is of course possible to install C7 in none-uefi legacy mode. If you managed to install C6 this way but not C7, you are most probably doing something wrong. The choice is made by either booting the installation medium in uefi or legacy mode. If your system always boots the C7 installer in uefi mode, you can still force a non-uefi installation by adding "noefi" to the installer's kernel parameters.

lpallard
Posts: 50
Joined: 2014/09/17 02:39:48

Re: Nvidia drivers not working on brand new centos 7 worksta

Post by lpallard » 2015/02/08 20:44:59

Sounds good! I will make a clone with clonezilla, then try again with the kernel parameter you suggests.

That way, if that doesnt work, at least I'll have a backup to go back! Thanks for the hint chemal!

Post Reply

Return to “CentOS 7 - Software Support”