Upgrading to PHP 5.6.9

Issues related to applications and software problems
sadue
Posts: 55
Joined: 2016/01/08 19:08:26

Re: Upgrading to PHP 5.6.9

Postby sadue » 2016/01/26 12:18:39

Stevemowbray thanks very much. That worked it.

sneakyimp
Posts: 8
Joined: 2007/10/18 01:19:38
Contact:

Re: Upgrading to PHP 5.6.9

Postby sneakyimp » 2016/04/26 21:41:39

gerald_clark wrote:Please read the FAQ.
http://wiki.centos.org/FAQ/General#head ... 629ac835c7


I'm sorry but PHP 5.4.16 (the version I see after installing php via yum) is REALLY REALLY OLD. It is in fact an unsupported branch which received its last security update on Sep 3 2015.

What does CentOS community suggest to get a version of php that is not dead for CentOS 7?

User avatar
TrevorH
Forum Moderator
Posts: 20569
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Upgrading to PHP 5.6.9

Postby TrevorH » 2016/04/26 22:56:34

Via yum update of course. And reading the https://access.redhat.com/security/updates/backporting backporting policy upstream.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

kaizerking
Posts: 5
Joined: 2017/04/12 07:33:34

Re: Upgrading to PHP 5.6.9

Postby kaizerking » 2017/04/23 07:58:32

packages from IUS creates conflict with IPA client and php-common

User avatar
TrevorH
Forum Moderator
Posts: 20569
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Upgrading to PHP 5.6.9

Postby TrevorH » 2017/04/23 11:44:56

Could you show the output from yum for that? The ipa packages currently conflict with themselves so I doubt if that's IUS's fault. The conflict for php would be a known one - you have to pick either the distro 'php' packages or the IUS php56u ones, not both.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke