Page 1 of 1

SSSD with AD - No such user

Posted: 2015/11/30 21:44:29
by cqc0988
Dear all,

I am new with SSSD and like to use it to authenticate Windows AD users on our Linux (CentOS 7) machine. After joining the Linux to the Windows Active Directory by using "realm join mydomain -U domainadminuser" successfully, I am able to see the computer account built in AD.

Difficulties:
Experiencing some difficulties with the user identification. After joining the domain successfully, on Linux machine, I was trying to use the command “id” to identify the domain users but failed. And of course, it won’t let me to “ssh” into the system against the AD accounts. Please help

BTW, from Linux, it can ping / find DC and I have tried to disable the firewalld on the linux to ensure there is no blocking issue from the linux end, but no luck.

# id domainuser@mydomain
id: domainuser@mydomain: no such user

Here this the output from "realm list"

[tigeruser@linux etc]# sudo realm list
mydomain
type: kerberos
realm-name: MYDOMAIN
domain-name: mydomain
configured: kerberos-member
server-software: active-directory
client-software: sssd
required-package: oddjob
required-package: oddjob-mkhomedir
required-package: sssd
required-package: adcli
required-package: samba-common
login-formats: %U@mydomain
login-policy: allow-realm-logins

Re: SSSD with AD - No such user

Posted: 2016/05/19 12:39:29
by t3kg33k
I'm having the same issue.
Anyone know how to fix this?

Re: SSSD with AD - No such user

Posted: 2016/05/23 14:47:26
by ephos
I am also having this issue.

Re: SSSD with AD - No such user

Posted: 2016/05/27 11:24:38
by saerom
Also having this problem. When setting ldap_id_mapping = True, no problem to lookup users with "id" or "getent". But we need to use the POSIX attributes in AD...