Can't make hba connection work on centos 7

Issues related to applications and software problems
maniat1k
Posts: 3
Joined: 2016/09/04 18:21:42

Can't make hba connection work on centos 7

Postby maniat1k » 2016/11/24 19:02:31

Hello everyone, I am currently using an old server with an old storage connected by fiberchannel.
On the storage side I left everything configured but on the server side I do not see the disk that was created for it.
Here is what I have so far:

The cards:

Code: Select all

[root@vmprod01 ~]# lspci | grep Fibre
10:00.0 Fibre Channel: Emulex Corporation Zephyr-X LightPulse Fibre Channel Host Adapter (rev 02)
10:00.1 Fibre Channel: Emulex Corporation Zephyr-X LightPulse Fibre Channel Host Adapter (rev 02)

info:

Code: Select all

[root@vmprod01 ~]# lspci -v -s 10:00.0
10:00.0 Fibre Channel: Emulex Corporation Zephyr-X LightPulse Fibre Channel Host Adapter (rev 02)
        Subsystem: Emulex Corporation Zephyr-X LightPulse Fibre Channel Host Adapter
        Physical Slot: 2
        Flags: bus master, fast devsel, latency 0, IRQ 26
        Memory at c7eff000 (64-bit, non-prefetchable) [size=4K]
        Memory at c7efec00 (64-bit, non-prefetchable) [size=256]
        I/O ports at 6000 [size=256]
        [virtual] Expansion ROM at c6000000 [disabled] [size=256K]
        Capabilities: [58] Power Management version 2
        Capabilities: [60] MSI: Enable+ Count=1/16 Maskable- 64bit+
        Capabilities: [44] Express Endpoint, MSI 00
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [12c] Power Budgeting <?>
        Kernel driver in use: lpfc


so then i need to know if the kernel driver is loaded right?

Code: Select all

root@vmprod01 ~]# lsmod | grep lpfc
lpfc                  702870  0
crc_t10dif             12714  3 lpfc,target_core_mod,sd_mod
scsi_transport_fc      64056  1 lpfc
[root@vmprod01 ~]# modinfo lpfc
filename:       /lib/modules/3.10.0-327.36.3.el7.x86_64/kernel/drivers/scsi/lpfc/lpfc.ko
version:        0:10.7.0.1
author:         Emulex Corporation - tech.support@emulex.com
description:    Emulex LightPulse Fibre Channel SCSI driver 10.7.0.1
license:        GPL
rhelversion:    7.2
srcversion:     053424650970DDDDCE74F8C
-
-
-


OK looks like it's loadead right?
What else I have to check/do to have it working?
Remember I'm totally new at this.

Regards,
Maniat1k.-

aks
Posts: 2498
Joined: 2014/09/20 11:22:14

Re: Can't make hba connection work on centos 7

Postby aks » 2016/11/28 17:38:54

You may have SSP (selective storage presentation aka proprietary zones) and/or zones. Do you have FC switches or is this a point-to-point link?
Don't forget that (depending on your FC config) the HBA(s) may have authenticate the the fabric.
Also you can scan for targets at the BIOS level (just to simplify things).

maniat1k
Posts: 3
Joined: 2016/09/04 18:21:42

Re: Can't make hba connection work on centos 7

Postby maniat1k » 2016/11/28 17:52:26

Thanks for the answer!
- Its point to point.
- If the hba has to authenticate: Should not I be the one who sets that up when I create the virtual disk?

can't see anything from the centos.

Code: Select all

[root@vmprod01 ~]# ls -ls /proc/scsi/
total 0
0 -r--r--r--. 1 root root 0 nov 28 15:34 device_info
0 -r--r--r--. 1 root root 0 nov 28 15:34 scsi
0 dr-xr-xr-x. 2 root root 0 nov 28 15:34 sg


ok I will a little more about the SSP.
Thanks!