Can't start DevedeNG due to missing Python3 module

Issues related to applications and software problems
odysseus
Posts: 34
Joined: 2014/09/14 16:55:22

Can't start DevedeNG due to missing Python3 module

Postby odysseus » 2017/06/30 12:24:34

I'm trying the DVD-program DevedeNG and I get this error:

# python3 /usr/bin/devede_ng.py
Traceback (most recent call last):
File "/usr/bin/devede_ng.py", line 20, in <module>
import gi
ModuleNotFoundError: No module named 'gi'

I don't know what module it wants, I have looked around and installed package "gobject-introspection-1.42.0-1.el7.x86_64" but maybe I need a newer version? I don't know how to update to a newer version. Please help me find the right module.

I have installed the IUS repository and installed Python3 from there.

mghe
Posts: 633
Joined: 2015/11/24 12:04:43
Location: Katowice, Poland

Re: Can't start DevedeNG due to missing Python3 module

Postby mghe » 2017/06/30 15:45:16

Did You installed gtk3-devel.x86_64 ?

odysseus
Posts: 34
Joined: 2014/09/14 16:55:22

Re: Can't start DevedeNG due to missing Python3 module

Postby odysseus » 2017/06/30 15:49:15

Thank you for your support, but it is installed:

[root@macbook-air ~]# rpm -q gtk3-devel.x86_64
gtk3-devel-3.14.13-20.el7_3.1.x86_64
[root@macbook-air ~]#

odysseus
Posts: 34
Joined: 2014/09/14 16:55:22

Re: Can't start DevedeNG due to missing Python3 module

Postby odysseus » 2017/12/04 04:09:27

I reinstalled the whole Python 3, and I installed the module "gi" (gobject introspection) via the "pip" application.

Well, I filed a message to the maintainer of Devede, and he says there is a bug with the "gi" module. That's why the application will not start.

The maintainer of Devede said I should file a bug report with the maintainer of the "gobject introspection" module, but I have not done this yet.

https://github.com/rastersoft/devedeng/issues/64

odysseus
Posts: 34
Joined: 2014/09/14 16:55:22

Re: Can't start DevedeNG due to missing Python3 module

Postby odysseus » 2017/12/04 05:10:57

I found a package for CentOS 7 here, that works: https://centos.pkgs.org/7/nux-dextop-x8 ... h.rpm.html

But it is version 3.23, and the latest version out is 4.8.11.

But I can use it, so I will wait for CentOS 8 to come with the updates. I tried with compiling the newest version of Glib and gobject-introspection, but there was too many dependencies.