Yum update Error

Issues related to applications and software problems
patrickhgh
Posts: 12
Joined: 2017/03/10 18:49:35

Yum update Error

Postby patrickhgh » 2017/07/27 04:29:28

When I run yum update I get this.

Code: Select all

yum update
Loaded plugins: fastestmirror, langpacks
http://negativo17.org/repos/HandBrake/epel-7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/

Loading mirror speeds from cached hostfile
 * base: centos-distro.cavecreek.net
 * elrepo: repos.lax-noc.com
 * elrepo-extras: repos.lax-noc.com
 * epel: pubmirror2.math.uh.edu
 * extras: centos-distro.cavecreek.net
 * updates: repos.lax.quadranet.com
 * webtatic: us-east.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package GraphicsMagick.x86_64 0:1.3.25-7.el7 will be updated
---> Package GraphicsMagick.x86_64 0:1.3.26-1.el7 will be an update
--> Processing Dependency: libwebp.so.4()(64bit) for package: GraphicsMagick-1.3.26-1.el7.x86_64
---> Package cuda-npp.x86_64 1:8.0.61-4.el7 will be updated
---> Package cuda-npp.x86_64 1:8.0.61-5.el7 will be an update
---> Package nvidia-driver-cuda-libs.x86_64 2:375.66-1.el7 will be updated
---> Package nvidia-driver-cuda-libs.x86_64 2:384.59-1.el7 will be an update
--> Finished Dependency Resolution
Error: Package: GraphicsMagick-1.3.26-1.el7.x86_64 (epel)
           Requires: libwebp.so.4()(64bit)
           Available: libwebp-0.3.0-3.el7.x86_64 (base)
               libwebp.so.4()(64bit)
           Installed: libwebp-0.5.1-2.el7.x86_64 (@epel-multimedia)
              ~libwebp.so.6()(64bit)
 You could try using --skip-broken to work around the problem
** Found 5 pre-existing rpmdb problem(s), 'yum check' output follows:
mochapro-5.5.1-13127.x86_64 has missing requires of libcrypto.so.6()(64bit)
mochapro-5.5.1-13127.x86_64 has missing requires of libdb-4.3.so()(64bit)
mochapro-5.5.1-13127.x86_64 has missing requires of libgdbm.so.2()(64bit)
mochapro-5.5.1-13127.x86_64 has missing requires of libreadline.so.5()(64bit)
mochapro-5.5.1-13127.x86_64 has missing requires of libssl.so.6()(64bit)
[root@pcentos pwoodard]#

User avatar
TrevorH
Forum Moderator
Posts: 21211
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum update Error

Postby TrevorH » 2017/07/27 08:19:27

Your "epel-multimedia" yum repo is offline. Either disable it using --disablerepo= or edit the file in /etc/yum.repos.d and set it disabled there.

We do not recommend use of the webtatic repo.

For the missing requires messages, two of those are because openssl098e is not installed - yum install openssl098e will fix those but I do not know wher you would get libdb-4.3.so()(64bit) libgdbm.so.2()(64bit) libreadline.so.5()(64bit) as those are not things that we provide.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

patrickhgh
Posts: 12
Joined: 2017/03/10 18:49:35

Re: Yum update Error

Postby patrickhgh » 2017/07/27 08:52:46

Thank you. I disabled the webtatic repo and enabled "epel-multimedia" - this fixed errors.

I'm still getting this.

Code: Select all

http://negativo17.org/repos/HandBrake/epel-7/x86_64/repodata/repomd.xml: [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn't help to resolve this issue please create a bug on https://bugs.centos.org/

patrickhgh
Posts: 12
Joined: 2017/03/10 18:49:35

Re: Yum update Error

Postby patrickhgh » 2017/08/16 03:29:21

I've got another error

Code: Select all

================================================================================
 Package                  Arch    Version                Repository        Size
================================================================================
Updating:
 compat-ffmpeg-libs       x86_64  1:2.8.12-2.el7         epel-multimedia  5.6 M
 ffmpeg                   x86_64  1:3.3.3-2.el7          epel-multimedia  1.5 M
 ffmpeg-devel             x86_64  1:3.3.3-2.el7          epel-multimedia  788 k
 ffmpeg-libs              x86_64  1:3.3.3-2.el7          epel-multimedia  6.3 M
 google-chrome-stable     x86_64  60.0.3112.101-1        google-chrome     59 M
 gstreamer1-plugins-bad   x86_64  1:1.4.5-5.el7          epel-multimedia  1.8 M
 libavdevice              x86_64  1:3.3.3-2.el7          epel-multimedia   63 k
 live555-libs             x86_64  1:2017.07.18-1.el7     epel-multimedia  449 k
 nvidia-driver-cuda-libs  x86_64  2:384.59-2.el7         epel-multimedia   23 M
 vlc                      x86_64  1:2.2.6-2.el7          epel-multimedia  1.5 M
 vlc-core                 x86_64  1:2.2.6-2.el7          epel-multimedia  9.0 M
Installing for dependencies:
 libwebp0.6               x86_64  0.6.0-1.el7            epel-multimedia  250 k

Transaction Summary
================================================================================
Install              ( 1 Dependent package)
Upgrade  11 Packages

Total size: 109 M
Downloading packages:
Running transaction check
Running transaction test


Transaction check error:
  file /usr/lib64/libwebpdemux.so.2 from install of libwebp0.6-0.6.0-1.el7.x86_64 conflicts with file from package libwebp-0.5.1-2.el7.x86_64

User avatar
TrevorH
Forum Moderator
Posts: 21211
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Yum update Error

Postby TrevorH » 2017/08/16 08:27:36

Complain to the person/people who run the epel-multimedia repo. They are replaced the distro version of the libwebp package with their own "libwebp0.6" copy.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

shdd-cjharries
Posts: 1
Joined: 2017/09/18 20:20:20

Re: Yum update Error

Postby shdd-cjharries » 2017/09/18 20:30:25

Did this get any resolution? I'm still getting a similar error. Is there any chance it breaks the EPEL Updates Policy and could be reported?

I didn't resurrect a possibly dead thread for nothing; this should provide a workaround until it is fixed for anyone hitting this thread later like I did:

Code: Select all

sudo yum -x 'libwebp*' update --skip-broken

Code: Select all

$ yum -h
    ...
    -x [package], --exclude=[package]
                         exclude package(s) by name or glob
    ...
    --skip-broken        skip packages with depsolving problems
    ...

User avatar
avij
Forum Moderator
Posts: 2180
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Yum update Error

Postby avij » 2017/09/20 07:08:31

Despite the name, epel-multimedia is not a repository provided by EPEL, so the EPEL Updates Policy is not applicable here. Looks like it should be interpreted as "Multimedia packages using EPEL packages as a base".