autofs appears to be broken in CentOS 7.4 [SOLVED]

Issues related to applications and software problems
r_hartman
Posts: 706
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

autofs appears to be broken in CentOS 7.4 [SOLVED]

Postby r_hartman » 2017/09/22 20:17:58

Tonight I updated my CentOS 7.3 laptop to CentOS 7.4, and now the automounter no longer works.

My config is according to the Tips&Tricks one, and has been unchanged for a long time:
/etc/auto.master:

Code: Select all

/misc   /etc/auto.misc
/net   -hosts
+dir:/etc/auto.master.d
/home/rh.hartman/smb auto.smb.top

/etc/auto.smb.top:

Code: Select all

* -fstype=autofs,-Dhost=& file:/etc/auto.smb.sub

/etc/auto.smb.sub:

Code: Select all

* -fstype=cifs,uid=${UID},gid=${GID},credentials=${HOME}/.cred ://${host}/&


Using the debug logging option, I found that the ${host} parameter from /etc/auto.smb.sub is now populated with the laptop;'s host name (hacnb11), rather than the hostname of my NAS (hacnas02), as it did in 7.3 (and still does in 6.9):

Code: Select all

Sep 22 20:52:06 hacnb11 automount[5624]: parse_mount: parse(sun): dequote("://hacnb11/Videos") -> ://hacnb11/Videos

When I replace ${host} with the name of my NAS it works again:

Code: Select all

Sep 22 21:03:54 hacnb11 automount[6070]: parse_mount: parse(sun): dequote("://hacnas02/Videos") -> ://hacnas02/Videos

I can't find anything in the documentation that would indicate the substitution has changed (which would have been illogical anyway), so I have to assume this is a bug. Has anyone else come across this?
Thanks.
Last edited by r_hartman on 2017/10/06 17:02:29, edited 1 time in total.

r_hartman
Posts: 706
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

Re: autofs appears to be broken in CentOS 7.4

Postby r_hartman » 2017/09/29 15:27:46

Gentle bump...

Using Google, I found only one other reference to autofs invalid parameter substitution here:
https://www.centos.org/forums/viewtopic.php?f=48&t=64309

Conclusion would be I'm doing something wrong, but I haven't changed anything, and it still works with the original ${host} parameter in my 7.3 desktop and my 6.9 laptop/desktop (even my obsolete 5.11 laptop), with identical configurations.
So something must be broken in RHEL / CentOS 7.4.

I don't dare upgrade my desktop to 7.4 now, even while I can exclude autofs from upgrading, as I need autofs to work properly (I have another NAS). As 7.4 is a point upgrade, I cannot downgrade autofs to the previous version...

Would be nice if anyone would at least be able to confirm this behaviour; (suggestion for) fix would be better. :|

Thanks.

User avatar
TrevorH
Forum Moderator
Posts: 20652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: autofs appears to be broken in CentOS 7.4

Postby TrevorH » 2017/09/29 16:28:06

As 7.4 is a point upgrade, I cannot downgrade autofs to the previous version...


yum --enablerepo=C7.3.1611-base,C7.3.1611-updates downgrade autofs perhaps?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

r_hartman
Posts: 706
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

Re: autofs appears to be broken in CentOS 7.4

Postby r_hartman » 2017/10/03 19:10:40

yum --enablerepo=C7.3.1611-base,C7.3.1611-updates downgrade autofs perhaps?

Hi Trevor,

Thanks, you're the man. This indeed fixes it, so there's definitely something wrong with the latest version's parameter substitution.

I'd mark this thread solved, but I presume I'll need to file a bug report somewhere?

User avatar
TrevorH
Forum Moderator
Posts: 20652
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: autofs appears to be broken in CentOS 7.4

Postby TrevorH » 2017/10/03 20:46:56

bugzilla.redhat.com :(
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

r_hartman
Posts: 706
Joined: 2009/03/23 15:08:11
Location: Netherlands
Contact:

Re: autofs appears to be broken in CentOS 7.4 [SOLVED]

Postby r_hartman » 2017/10/05 18:02:25

Bug appears to have already been reported: https://bugzilla.redhat.com/show_bug.cgi?id=1498443
Marking SOLVED