CentOS 7 VM fails to load - postfix mail error

Issues related to applications and software problems
hereat12
Posts: 1
Joined: 2017/11/13 06:50:35

CentOS 7 VM fails to load - postfix mail error

Postby hereat12 » 2017/11/13 06:55:06

My CentOS 7 VM will not load and says, "Failed to start Postfix Mail Transport Agent." It is unresponsive to keystrokes and I am unable to obtain any diagnostic information. Is there a course of action to take?

centos error.JPG
centos error.JPG (76.53 KiB) Viewed 94 times

User avatar
TrevorH
Forum Moderator
Posts: 21170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7 VM fails to load - postfix mail error

Postby TrevorH » 2017/11/13 07:16:56

That looks like it's up and running but no GUI. Did you install any guest additions on the VM and then install/update to a newer kernel? You'll need to reinstall the guest additions each time if so.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

tunk
Posts: 207
Joined: 2017/02/22 15:08:17

Re: CentOS 7 VM fails to load - postfix mail error

Postby tunk » 2017/11/13 10:59:02

If it's a new install then you may try to boot with the rescue kernel.
If it worked before, try to boot with an older kernel.

User avatar
TrevorH
Forum Moderator
Posts: 21170
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: CentOS 7 VM fails to load - postfix mail error

Postby TrevorH » 2017/11/13 11:58:10

It's almost certainly booted up an available via ssh or using Ctrl-Alt-Fx to switch to an alternate console in cli mode.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke