Issue while install IBM notes client in centos 7

Issues related to applications and software problems
Post Reply
User avatar
sharadchandranpt
Posts: 10
Joined: 2014/11/25 15:19:52

Issue while install IBM notes client in centos 7

Post by sharadchandranpt » 2017/12/01 14:33:36

I am trying to install IBM notes client 9 in centos 7 and getting the following error.
[root@localhost ~]# rpm -i ibm_notes-9.0.1.i586.rpm
warning: ibm_notes-9.0.1.i586.rpm: Header V3 DSA/SHA1 Signature, key ID 34f9ae75: NOKEY
error: Failed dependencies:
libpangox-1.0.so.0 is needed by ibm_notes-9.0.1-20131022.1138.i586
libpng12.so.0 is needed by ibm_notes-9.0.1-20131022.1138.i586
gnome-desktop is needed by ibm_notes-9.0.1-20131022.1138.i586
[root@localhost ~]#

Gnome version is already installed.

[root@localhost ~]# cat /usr/share/gnome/gnome-version.xml
<?xml version="1.0" encoding="UTF-8"?>
<gnome-version>
<platform>3</platform>
<minor>22</minor>
<micro>2</micro>
<distributor>GNOME.Org</distributor>
<date>2017-08-06</date>

User avatar
TrevorH
Forum Moderator
Posts: 22983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Issue while install IBM notes client in centos 7

Post by TrevorH » 2017/12/01 14:40:30

If you use rpm to do installs then you need to specify all of the packages that are required on the same command at the same time. Use yum install instead - that does automatic dependency resolution and will expand the package selection to include the other things it needs. You'll need the EPEL repo installed to complete this as one of the requirements you listed is in there. You can find the epel-release package in the CentOS extras repo so yum install epel-release should work.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
sharadchandranpt
Posts: 10
Joined: 2014/11/25 15:19:52

Re: Issue while install IBM notes client in centos 7

Post by sharadchandranpt » 2017/12/02 08:43:45

after installation epel repo one dependency (gnome-desktop) is resolved. But still we have 2 more dependency.

Error
[root@localhost ~]# rpm -i ibm_notes-9.0.1.i586.rpm
warning: ibm_notes-9.0.1.i586.rpm: Header V3 DSA/SHA1 Signature, key ID 34f9ae75: NOKEY
error: Failed dependencies:
libpangox-1.0.so.0 is needed by ibm_notes-9.0.1-20131022.1138.i586
libpng12.so.0 is needed by ibm_notes-9.0.1-20131022.1138.i586

for yum install

[root@localhost ~]# yum localinstall ibm_notes-9.0.1.i586.rpm
Loaded plugins: fastestmirror, langpacks
Examining ibm_notes-9.0.1.i586.rpm: ibm_notes-9.0.1-20131022.1138.i586
Marking ibm_notes-9.0.1.i586.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package ibm_notes.i586 0:9.0.1-20131022.1138 will be installed
--> Processing Dependency: libpangox-1.0.so.0 for package: ibm_notes-9.0.1-20131022.1138.i586
Loading mirror speeds from cached hostfile
* base: centos-hn.viettelidc.com.vn
* epel: epel.mirror.net.in
* extras: centos.excellmedia.net
* updates: centos.excellmedia.net
--> Processing Dependency: libpng12.so.0 for package: ibm_notes-9.0.1-20131022.1138.i586
--> Running transaction check
---> Package ibm_notes.i586 0:9.0.1-20131022.1138 will be installed
--> Processing Dependency: libpangox-1.0.so.0 for package: ibm_notes-9.0.1-20131022.1138.i586
---> Package libpng12.i686 0:1.2.50-10.el7 will be installed
--> Finished Dependency Resolution
Error: Package: ibm_notes-9.0.1-20131022.1138.i586 (/ibm_notes-9.0.1.i586)
Requires: libpangox-1.0.so.0
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

User avatar
TrevorH
Forum Moderator
Posts: 22983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Issue while install IBM notes client in centos 7

Post by TrevorH » 2017/12/02 11:41:12

Unfortunately the packages from EPEL are 64 bit only and you are attempting to install the 32 bit client package which requires libpangox-1.0.so.0 which is provided by a package from EPEL but only in its 64 bit edition. You need to either get a 64 bit notes client package to install or... well not sure whjat else to do other than download the EPEL compat-pangox SRPM and rebuild it for 32 bit which may not be easy as it might have lots of prereqs.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
sharadchandranpt
Posts: 10
Joined: 2014/11/25 15:19:52

Re: Issue while install IBM notes client in centos 7

Post by sharadchandranpt » 2017/12/05 11:03:45

The issue got resolved after installing to package.
pangox-compat-0.0.2-2.el7.i686.rpm
libpng12-1.2.50-10.el7.i686.rpm

The installation was successful :) :D

Post Reply