Gnome, prevent the "welcome" stuff on first login.

Issues related to applications and software problems
iwishitwouldwork
Posts: 40
Joined: 2014/02/08 14:56:39

Gnome, prevent the "welcome" stuff on first login.

Postby iwishitwouldwork » 2017/12/07 22:57:57

Centos 7
Gnome GUI

I've been working on my kickstarting. After I test something I have to log in as root
on the freshly installed machine. And it always asks me about the keyboard and such.
(I was able to get the EULA to be quiet, finally.) I'm doing this:

Code: Select all

systemctl stop initial-setup-graphical.service
systemctl stop initial-setup-reconfiguration.service
systemctl stop initial-setup-text.service
systemctl stop initial-setup.service
systemctl disable initial-setup-graphical.service
systemctl disable initial-setup-reconfiguration.service
systemctl disable initial-setup-text.service
systemctl disable initial-setup.service

but it isn't enough.

When root logs in, it always asks, and it always shows the "help" or "welcome"
or whatever it's called.

Can that be prevented?

j.

ItsTheKitch
Posts: 1
Joined: 2017/12/08 01:19:50

Re: Gnome, prevent the "welcome" stuff on first login.

Postby ItsTheKitch » 2017/12/08 01:29:50

I found this: http://grokbase.com/t/centos/centos/1573cgs19s/get-ride-of-initial-screen-on-centos-7
One of the suggestions is to edit your kickstart with:

Code: Select all

firstboot --disable

iwishitwouldwork
Posts: 40
Joined: 2014/02/08 14:56:39

Re: Gnome, prevent the "welcome" stuff on first login.

Postby iwishitwouldwork » 2017/12/08 04:30:01

splutter. i kept looking in /etc and /var for the answer, nope.
here is the right answer:
https://seven.centos.org/2013/12/preven ... ial-setup/

briefly:
~/.config/gnome-initial-setup-done

j.