Additional Applications for CentOS AltArch 7(1708) on i386

Issues related to applications and software problems
Post Reply
Len E.
Posts: 15
Joined: 2014/10/11 00:04:37

Additional Applications for CentOS AltArch 7(1708) on i386

Post by Len E. » 2017/12/27 22:52:30

I've continued to convert additional applications to CentOS 7 32-bit using the standard
2-step approach (rpm -ivh, rpmbuild -bb) with SRPMS from either the EPEL or
nux-dextop EL7 repositories. I describe the conversion process for 3 of them,
because of the unusual aspects encountered.

OPERA - no conversion required at all

An older version of Opera, opera_12.16.1860.i386.rpm, is still available and
has been described as a universal version, because it local-installs readily with
no dependency requirements.

I found it to be a reasonably-well-featured browser that is very light weight,
and works well for limited-resource 32-bit PC's.

XFBURN - not available in either EPEL or nux-dextop

I was surprised that a current xfburn SRPM was not readily available given that
XFCE is an optional desktop available in EPEL.

xfburn can be a useful light alternative for an XFCE-desktop installation
because it utilizes 4 of the 5 lowest-level packages inherent in XFCE,
libxfce4util, xfconf, libxfce4ui, and exo.

I found that the fc24 version was the newest that avoided a large number
of dependency problems. Accordingly, 2-step builds were used on
xfburn-0.4.3-4.fc24.src.rpm, libjpeg-turbo-1.4.2-3.fc24.src.rpm and
thunar-vfs-1.2.0-17.fc24.src.rpm, with installation being completed
with the 4 XFCE-base packages and other standard CentOS7 32-bit
packages.

CLAWS-MAIL

The process initially proceeded in the usual manner with 2-step builds for the
major dependencies, libetpan, libytnef, and pilot-link.

But a brick wall was encountered with webkitgtk. The SRPM is from EPEL.
The 2nd of the two steps, rpmbuild -bb webkitgtk.spec would run for more
than 2 hours, with a steady stream of screen output the whole time, and
then fail.

On one such occasion, the error messages at the end of the run were as follows:

Collect2: error: ld returned 1 exit status
make [1]: ** [libwebkitgtk-1.0.1a] Error 1
make [1]: Leaving directory /root/rpmbuild/BUILD/webkitgtk-2.4.9
make: *** [all] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.PtGEio(%build)

As a work around, I tried to install the fc23 version of webkitgtk, which is almost
the same version as the EPEL package, but it needs libpng.so.16, whereas
CentOS7 uses libpng.so.15.

What worked was dropping back to the fc19 updates version of webkitgtk, which
installed with no problems.

Ideally, in the future, CentOS 7 32-bit will include webkitgtk in the base.

Len E.

Len E.
Posts: 15
Joined: 2014/10/11 00:04:37

Re: Additional Applications for CentOS AltArch 7(1708) on i386

Post by Len E. » 2018/02/13 19:55:56

An update on the OPERA browser:

The latest and last 32-bit version available is opera-stable-45.0.2552.898.

I downloaded the Russian Fedora (fc26.R) 32-bit version onto
CentOS-7.4-Gnome 32-bit. It local-installed requiring only 1
dependency available in the base repos. It works fine.

If Firefox implements their plans to discontinue 32-bit support,
this opera package may be an appropriate way to fill the gap
for CentOS-7 32-bit.

Len E.

Post Reply