<SOLVED> Installing viber; not executing

Issues related to applications and software problems
makhtux
Posts: 11
Joined: 2018/01/04 06:02:30

<SOLVED> Installing viber; not executing

Post by makhtux » 2018/01/04 15:57:47

Hi

Installed viber, but get this result:

Code: Select all

$ /opt/viber/Viber 
/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/Viber)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Location.so.5)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicui18n.so.52)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libicuuc.so.52)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5WebEngineCore.so.5)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /opt/viber/lib/libQt5Qml.so.5)
/opt/viber/Viber: /lib64/libstdc++.so.6: version `CXXABI_1.3.8' not found (required by /opt/viber/lib/libQt5Core.so.5)
A little search shows to install gcc 4.9. Probably it may resolve the issue.

Will it be fine to do this? What can be better source to install gcc 4.9?

Or is there some other possibility?

Thanktyou
Last edited by makhtux on 2018/01/06 18:53:06, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 23676
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Installing viber; not executing

Post by TrevorH » 2018/01/04 16:00:48

No, that's the wrong solution. What that actually tells you is that the app was built to require a newer glibc package than we ship but if you attempt to change that, you will break the rest of your system so do not even try.

You can find a viber package that's built for CentOS 7 in the nux-dextop third party yum repo. Additional packages are often in 3rd party repos. Information on additional CentOS repos is available at http://wiki.centos.org/AdditionalResources/Repositories Pay attention to the reference on yum-priorities
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

makhtux
Posts: 11
Joined: 2018/01/04 06:02:30

Re: Installing viber; not executing

Post by makhtux » 2018/01/06 08:57:09

Hello Sir

I did got it running via the official repository, and it is starting now.

But now it gives error for my mobile number. (Though the actual site package worked inside Linux Mint.)

The terminal doesnt returns any error, all I get is:

Code: Select all

STATUS_CUSTOM_ERROR
I will need to search on this one.

Thankyou

odysseus
Posts: 47
Joined: 2014/09/14 16:55:22

Re: <SOLVED> Installing viber; not executing

Post by odysseus » 2018/01/07 02:27:06

I get the STATUS_CUSTOM_ERROR too.

makhtux
Posts: 11
Joined: 2018/01/04 06:02:30

Re: <SOLVED> Installing viber; not executing

Post by makhtux » 2018/01/07 16:59:24

odysseus wrote:I get the STATUS_CUSTOM_ERROR too.
So it is buggy.

odysseus
Posts: 47
Joined: 2014/09/14 16:55:22

Re: <SOLVED> Installing viber; not executing

Post by odysseus » 2018/03/14 10:33:36

It's not solved. It's buggy or a fault with Viber. Image

odysseus
Posts: 47
Joined: 2014/09/14 16:55:22

Re: <SOLVED> Installing viber; not executing

Post by odysseus » 2018/07/15 18:29:02

You get the STATUS_CUSTOM_ERROR with the old version of Viber. But the new version of Viber requires a late version of libstdc++ which is not provided by CentOS. Therefore I compiled and installed gcc 8.1.0 and now the latest version of Viber works.

Image

lightman47
Posts: 726
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: <SOLVED> Installing viber; not executing

Post by lightman47 » 2018/07/15 21:20:33

... and was supplying your mobile number mandatory (and not troubling to you)?
"The more I learn, the behinder I get"

User avatar
TrevorH
Forum Moderator
Posts: 23676
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: <SOLVED> Installing viber; not executing

Post by TrevorH » 2018/07/15 21:54:21

Not to mention that you probably just broke your system rather badly...
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

odysseus
Posts: 47
Joined: 2014/09/14 16:55:22

Re: <SOLVED> Installing viber; not executing

Post by odysseus » 2018/07/17 21:17:47

TrevorH wrote:
2018/07/15 21:54:21
Not to mention that you probably just broke your system rather badly...
Things seem to still work.

Post Reply