vsftpd not logging

Issues related to applications and software problems
Post Reply
mojo
Posts: 2
Joined: 2018/01/11 14:37:15

vsftpd not logging

Post by mojo » 2018/01/11 15:30:22

I have a fresh CentOS 7 install with vsftpd running.

vsftpd is setup to allow sftp only and currently functions as expected except it is not logging any transfers.

vsftpd: version 3.0.2

I've tried a number of different combinations in the config file (restarting vsftpd each time) with out any luck. My current config options for logging are:

# Activate logging of uploads/downloads.
xferlog_enable=YES
# You may override where the log file goes if you like. The default is shown
xferlog_file=/var/log/xferlog
# If you want, you can have your log file in standard ftpd xferlog format.
# Note that the default log file location is /var/log/xferlog in this case.
xferlog_std_format=NO

I've tried xferlog_std_format with both Yes and No.

User avatar
TrevorH
Forum Moderator
Posts: 23496
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: vsftpd not logging

Post by TrevorH » 2018/01/11 16:25:40

vsftpd doesn't do sftp, it does ftps. If you're using sftp to connect to the server then it's not talking to vsftpd, it's talking to the open ssh daemon.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mojo
Posts: 2
Joined: 2018/01/11 14:37:15

Re: vsftpd not logging

Post by mojo » 2018/01/12 02:53:42

That explains it. I thought vsftpd used sshd for part of the process but that vsftpd handled most of the work.

Thank you.

Post Reply