Cockpit.service can't be enabled

Issues related to applications and software problems
Post Reply
BeanAE86
Posts: 3
Joined: 2017/12/29 21:12:01

Cockpit.service can't be enabled

Post by BeanAE86 » 2018/01/15 18:10:27

Hi everyone,

new to the linuxworld (sort off as I haven't dealt with a linux system in over 20 years) - so please go gentle.

I'm running the lates CentOS as a hypervisor with ovirt (getting close to getting ovirt running at least) but right now one thing that's bugging me is the cockpit.service (version 155).

I can start it manually and it runs fine but when I check the status it's: static. If I try to enable it nothing happens. I think once it's said something about missing an install file or something. cockpit 155 was installed along ovirt.
Any ideas how I turn a static service into an enabled one as it's annoying to ssh into the server just to start it all the time.
Also when I haven't touched the server for a while it seems that cockpit stopped by itself. Hae to look for the logfile.

If there are any logs etc I can supply please let me know.

dcrdev
Posts: 68
Joined: 2015/10/25 23:42:17

Re: Cockpit.service can't be enabled

Post by dcrdev » 2018/01/16 09:51:15

Cockpit uses socket activation...

Code: Select all

sudo systemctl enable --now cockpit.socket

BeanAE86
Posts: 3
Joined: 2017/12/29 21:12:01

Re: Cockpit.service can't be enabled

Post by BeanAE86 » 2018/01/16 11:36:37

dcrdev wrote:Cockpit uses socket activation...

Code: Select all

sudo systemctl enable --now cockpit.socket
that much I know unfortunately it won't activate like that as it's static.

dcrdev
Posts: 68
Joined: 2015/10/25 23:42:17

Re: Cockpit.service can't be enabled

Post by dcrdev » 2018/01/16 11:47:14

Yes it will!

Note that you need to enable cockpit.socket - not .service.

Post Reply