What's wrong with my system?

Issues related to applications and software problems
Post Reply
eric2kwok
Posts: 11
Joined: 2015/10/23 16:16:04

What's wrong with my system?

Post by eric2kwok » 2018/02/02 00:45:32

libquicktime.x86_64 1.2.4-19.el7.nux nux-dextop
[eric@localhost ~]$ su -c 'yum -y update'
Password:
Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
* base: centos.01link.hk
* epel: mirror.rise.ph
* extras: centos.01link.hk
* nux-dextop: li.nux.ro
* updates: mirror.sunnyvision.com
Resolving Dependencies
--> Running transaction check
---> Package libquicktime.x86_64 0:1.2.4-13.el7 will be updated
---> Package libquicktime.x86_64 0:1.2.4-19.el7.nux will be an update
--> Processing Dependency: libx264.so.142()(64bit) for package: libquicktime-1.2.4-19.el7.nux.x86_64
--> Finished Dependency Resolution
Error: Package: libquicktime-1.2.4-19.el7.nux.x86_64 (nux-dextop)
Requires: libx264.so.142()(64bit)
Available: x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Available: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Available: x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Installed: x264-libs-0.148-11.20160614gita5e06b9.el7.x86_64 (@rpmfusion-free-updates)
~libx264.so.148()(64bit)
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
fahcontrol-7.4.4-1.noarch has missing requires of python(abi) = ('0', '2.6', None)

Anyone knows how to solve this issue? Please help. Thanks in advance.

desertcat
Posts: 440
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: What's wrong with my system?

Post by desertcat » 2018/02/02 02:25:10

eric2kwok wrote:libquicktime.x86_64 1.2.4-19.el7.nux nux-dextop
[eric@localhost ~]$ su -c 'yum -y update'
Password:
Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
* base: centos.01link.hk
* epel: mirror.rise.ph
* extras: centos.01link.hk
* nux-dextop: li.nux.ro
* updates: mirror.sunnyvision.com
Resolving Dependencies
--> Running transaction check
---> Package libquicktime.x86_64 0:1.2.4-13.el7 will be updated
---> Package libquicktime.x86_64 0:1.2.4-19.el7.nux will be an update
--> Processing Dependency: libx264.so.142()(64bit) for package: libquicktime-1.2.4-19.el7.nux.x86_64
--> Finished Dependency Resolution
Error: Package: libquicktime-1.2.4-19.el7.nux.x86_64 (nux-dextop)
Requires: libx264.so.142()(64bit)
Available: x264-libs-0.142-4.20140423gite260ea5.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Available: x264-libs-0.142-7.20140728gitaf8e768.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Available: x264-libs-0.142-11.20141221git6a301b6.el7.nux.x86_64 (nux-dextop)
libx264.so.142()(64bit)
Installed: x264-libs-0.148-11.20160614gita5e06b9.el7.x86_64 (@rpmfusion-free-updates)
~libx264.so.148()(64bit)
You could try using --skip-broken to work around the problem
** Found 1 pre-existing rpmdb problem(s), 'yum check' output follows:
fahcontrol-7.4.4-1.noarch has missing requires of python(abi) = ('0', '2.6', None)

Anyone knows how to solve this issue? Please help. Thanks in advance.
"What's wrong with my system" is a pretty generic question, that is along the same lines of "What's wrong with me?" Without knowing what *you* think is wrong, or stating a specific problem no one is likely to spend any time trying to answer your question.

Enough for for my rant... Since I have no idea what is "wrong" you can help yourself narrow down the problem by running yum update --skip-broken as was suggested. This may or may not solve your problem. Based upon your results try posting a specific problem rather than an open ended "What's wrong with my system".

User avatar
TrevorH
Forum Moderator
Posts: 23653
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: What's wrong with my system?

Post by TrevorH » 2018/02/02 07:22:27

You cannot mix and match the nux-dextop repo with rpmfusion. Both supply an x264-libs package and the packages from nux that depend on it will not work with the copy from rpmfusion (and vice versa).
Installed: x264-libs-0.148-11.20160614gita5e06b9.el7.x86_64 (@rpmfusion-free-updates)
~libx264.so.148()(64bit)
Pick one of rpmfusion OR nux and stick with it. It _may_ be possible to install individual packages from rpmfusion at the same time as using nux but you'll probably need to add an includepkgs= line to the rpmfusion repo file so that it pulls only packages from there that you explicitly tell it to.

You also appear to have done something nasty with the fahcontrol package that you have installed. The "missing requires" for python 2.6 shows that it's not intended for use on CentOS 6 which uses python 2.7.5 so that looks like you had to use rpm --install --force to get that onto your system. It's not safe to install packages intended for other versions of CentOS (or other distros).
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply