im-chooser

Issues related to applications and software problems
Post Reply
LTLE
Posts: 1
Joined: 2018/02/09 04:50:53

im-chooser

Post by LTLE » 2018/02/10 10:39:32

Hello,
I could not open ibus even I already added 3 lines in $HOME/.bashrc file:
export GTK_IM_MODULE=ibus
export XMODIFIERS=@im=ibus
export QT_IM_MODULE=ibus
Please see the attached file also. Thank you very much for your helps.

Best regards,
L.T.LE
Attachments
Screenshot from 2018-02-10 02-36-06.png
Screenshot from 2018-02-10 02-36-06.png (48.49 KiB) Viewed 371 times

scottro
Forum Moderator
Posts: 2383
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: im-chooser

Post by scottro » 2018/02/10 13:02:34

Depending upon what language you're using, you may wish to try fcitx instead. I have a page about using it with Japanese at http://srobb.net/jpninpt.html#CentOS6 that talks about it, (and has a few tips for ibus as well).
New users should check the FAQ and Read Me First pages

pjsr2
Posts: 343
Joined: 2014/03/27 20:11:07

Re: im-chooser

Post by pjsr2 » 2018/02/10 18:58:20

I have the following notes that I took when installing Japanese language and input support:

Erase the anthy ibus input method.

Code: Select all

sudo yum erase ibus-anthy
Install group "input-methods".

Code: Select all

sudo yum group install "input-methods"
Install Japanese fonts.

Code: Select all

sudo yum install ipa-mincho-fonts ipa-pmincho-fonts vlgothic-fonts vlgothic-p-fonts
Install im-chooser.

Code: Select all

sudo yum install im-chooser
The following lines need to be added to the $HOME/.bashrc file:

Code: Select all

#
# For Japanese language input.
#
export XMODIFIERS=@im=ibus
export GTK_IM_MODULE=ibus
export QT_IM_MODULE=ibus

Gnome desktop
On first time login using a GNOME desktop, the initial login procedure will bring up a dialog for
configuration of user language, keyboard and integration of web accounts. If you have logged in before
and you want to run this again, execute the following command from a terminal:

Code: Select all

/usr/libexec/gnome-initial-setup --existing-user
Select the language and keyboard layout.


XFCe desktop
When logging in using a XFCE desktop session, open a terminal window and enter the command:

Code: Select all

im-chooser
In the im-chooser dialog (the on that you have shown) select "Use Ibus (recommended)", then "Close" button.
Log out and log in again.

Open a terminal window and start ibus-setup:

Code: Select all

ibus-setup
This will show a dialog telling that the iBus daemon is not running. Select "Yes" to start the iBus daemon.
Next, the iBus preferences dialog is opend. Go to the "Input Method" tab. Check the "Customize active input methods" box and then use the "Select an input method" button. This will bring a limited list of input languages for mostly western languages. Therefor select "Show all input methods" near the bottom. This brings you back to the same dialog, but when you use the "Select an input method" button again, you will see a much longer list of input methods. Pick the language you need (in my case: Japanese and "Kana Kanji") and then the "+Add" button.

Close the dialog and log out and log in again.

You can now select the input method/keyboard in the top right of the menu bar. To switch keyboard/language, use <Windows>+<space> key or <Alt>+<@> key combination.

Post Reply