VLC Player can't play DVD Movie

Issues related to applications and software problems
Post Reply
eric2kwok
Posts: 10
Joined: 2015/10/23 16:16:04

VLC Player can't play DVD Movie

Post by eric2kwok » 2018/02/23 06:22:13

I have one 32bit system installed CentOS 6.9 i386, I can smoothly to play the DVD Movies, but another system can not, the second one computer was a 64bit system x86_64, i7-5500U cpu, I used the virtualbox to run the CentOS 7.4.1708, but I can't play the DVD on this guest system, the host is Windows 10 Home Edition, am I missing something I haven't installed the codec packages? Why I can play dvd movie in 32bit system smoother but the 64bit system cannot? Why? Both system I already installed the libdvdcss rpm package, but seems doesn't work, is it because I'm using Virtuallbox so I can not play dvd? Isn't it?
What is the reason why I can not play a dvd movie on my linux guest system?

Any solution would be helpful, Thanks in advance.

scottro
Forum Moderator
Posts: 2377
Joined: 2007/09/03 21:18:09
Location: NYC
Contact:

Re: VLC Player can't play DVD Movie

Post by scottro » 2018/02/23 11:21:36

I don't use VLC, but have you tried one of the other players, such as mpv or mplayer? I believe both are available from the nux repo.

https://wiki.centos.org/AdditionalResou ... positories (search for nux on the page). Although if you have VLC, you may already be using the nux repo.

This may also be useful.
https://wiki.centos.org/TipsAndTricks/M ... aOnCentOS7
New users should check the FAQ and Read Me First pages

lightman47
Posts: 641
Joined: 2014/05/21 20:16:00
Location: Central New York, USA

Re: VLC Player can't play DVD Movie

Post by lightman47 » 2018/02/24 13:09:22

I use vlc because it'll play most anything, but I'd not tried it in a VM. Can you "see" the DVD in VirtualBox but it won't play, or can't you even see it? I ask because I had to enable 'passthru' in the virtualbox disk settings for the machine to see disks on mine. If you can see but it won't play then ignore this.
"Please solve your problems in advance so we can help you more"
- unknown

Post Reply