Moneydance on Centos 7 ?

Issues related to applications and software problems
SirLurkalot
Posts: 117
Joined: 2013/02/28 07:57:46

Moneydance on Centos 7 ?

Post by SirLurkalot » 2018/04/01 06:33:33

Hi. I have run Moneydance on Centos for ages. Since the last major Centos update, some of the text has become cropped. It's not a big issue but it would be good to sort it or at least see if it's just me !

The main example is on the Summary page, the Expenses Graph, where all the labels and associated amounts only have the top half of the type showing. Similarly on some dialogues, like the initial password screen, where it asks 'Please enter your password' that is equally cropped off at the bottom.

I have raised it with the Infinitekind support board and they suggested it was probably because Linus uses an old java but I'm not convinced because I think java comes in their package, i.e. in the jre directory, contained within Moneydance. Is that right? I don't really know what I'm doing but I did try removing their jre and inserting a softlink to my install of jre1.8.0_161 but that made no difference.

It's not a big deal but i do wonder if it's a general issue or simply something wrong with my install?

Cheers

jimj
Posts: 72
Joined: 2014/10/01 05:34:57

Re: Moneydance on Centos 7 ?

Post by jimj » 2018/05/12 20:01:50

SirLurkalot wrote: I have run Moneydance on Centos for ages. Since the last major Centos update, some of the text has become cropped. It's not a big issue but it would be good to sort it or at least see if it's just me !
I thought I was the only CentOS Monedydance user! I have the exact same problem as you, I reported my problem to Infinite Kind, but their support never responded to my post here:
http://help.infinitekind.com/discussion ... -correctly
An Ubuntu user reported he had the same problem that was resolved when he updated his Ubuntu from 17.04 to 17.10. I was really hoping that CentOS 7.5 would resolve this issue, but no such luck. I tried using different themes which didn't help. You are correct that Moneydance uses its own JRE, but changing the JRE was certainly worth a shot. If you ever find a fix to this issue please share.

SirLurkalot
Posts: 117
Joined: 2013/02/28 07:57:46

Re: Moneydance on Centos 7 ?

Post by SirLurkalot » 2018/05/12 20:14:37

Thanks for at least confirming i'm not the only one ! I too hoped something might change with the shift to 7.5 but no such luck. That it was sorted on the Ubunto upgrade makes you wonder what was updated at that time, though I don't really know enough to spot the culprit ! If I should come across a cure, I'll certainly post it here.

jimj
Posts: 72
Joined: 2014/10/01 05:34:57

Re: Moneydance on Centos 7 ?

Post by jimj » 2018/05/12 20:25:36

This HiDPI issue sounds kind of similar. Maybe the fix for this issue will resolve our problem as well?
http://help.infinitekind.com/discussion ... unreadable

SirLurkalot
Posts: 117
Joined: 2013/02/28 07:57:46

Re: Moneydance on Centos 7 ?

Post by SirLurkalot » 2018/05/13 05:13:09

It certainly sounds very similar, though the effects I see are pretty limited. I'm currently using version 2017.6 1656 and updated hoping for an improvement but to no avail. We'll have to pin our hopes on Java 9 for now. The guy's right though, it should have been sorted if they want to continue to be a commercial offering. I really like it.

Edit: I saw after posting this, that there was a later version, 2017.7.1 1671. I've updated to that but it made no difference to the cropped text. :-(

jimj
Posts: 72
Joined: 2014/10/01 05:34:57

Re: Moneydance on Centos 7 ?

Post by jimj » 2018/05/28 15:33:32

SirLurkalot wrote:I did try removing their jre and inserting a softlink to my install of jre1.8.0_161 but that made no difference.
I'm not sure why your method wouldn't work, but maybe this method will work better for you? It turns out another Fedora used posted the workaround to this back in Dec of 2016 here. Basically the problem is caused by Moneydance's included Java (a Java version or setting issue). Below is a copy of the solution I posted to the Moneydance support forum here.

Here are some details on this workaround. Prior to the change "Help->Console Window" showed:

Code: Select all

Starting Moneydance 2017.7.2 (1672) at Mon May 28 09:25:29 CDT 2018
OS: Linux 3.10.0-862.3.2.el7.x86_64 amd64
Java: 1.8.0_144 (Oracle Corporation)
I then closed Moneydance and from the terminal I ran:

Code: Select all

export INSTALL4J_JAVA_HOME_OVERRIDE=/etc/alternatives/jre
And now when I start Moneydance by running /opt/Moneydance/Moneydance from the same terminal everything works correctly. "Help->Console Window" shows:

Code: Select all

Starting Moneydance 2017.7.2 (1672) at Mon May 28 09:28:45 CDT 2018
OS: Linux 3.10.0-862.3.2.el7.x86_64 amd64
Java: 1.8.0_171 (Oracle Corporation)
I'm using OpenJDK 1.8.0.171-8.b10 on CentOS 7.5:

Code: Select all

$ yum list installed '*openjdk*'
java-1.8.0-openjdk.x86_64                1:1.8.0.171-8.b10.el7_5        @updates
java-1.8.0-openjdk-headless.x86_64       1:1.8.0.171-8.b10.el7_5        @updates
Of course as soon as I close that terminal window my INSTALL4J_JAVA_HOME_OVERRIDE environment variable goes away. To make this Java override permanent (until the next time you update Moneydance) you must (as root) edit /opt/Moneydance/Moneydance and change this line (fourth from the top for me) from:

Code: Select all

# INSTALL4J_JAVA_HOME_OVERRIDE=
to:

Code: Select all

INSTALL4J_JAVA_HOME_OVERRIDE=/etc/alternatives/jre
Last edited by jimj on 2018/05/29 02:39:52, edited 1 time in total.

SirLurkalot
Posts: 117
Joined: 2013/02/28 07:57:46

Re: Moneydance on Centos 7 ?

Post by SirLurkalot » 2018/05/28 17:21:39

Thanks for the pointer, I've had no luck so far and to be honest I'm really wary of screwing it all up!
For some reason I had two jre versions installed 1.7.0 & 1.8.0 . I've now removed 1.7.0
As you say Moneydance is using 1.8.0_144

This command appears to have no effect export INSTALL4J_JAVA_HOME_OVERRIDE=/etc/alternatives/jre
Should I remove these existing entries in /etc/alternatives first to make sure it's up to date?
jre_1.8.0
jre_1.8.0_exports
jre_1.8.0_openjdk
jre_1.8.0_openjdk_exports
jre_openjdk
jre_openjdk_exports

The first few lines of my Moneydance file is a follows..
#!/bin/sh

# Uncomment the following line to override the JVM search sequence
# INSTALL4J_JAVA_HOME_OVERRIDE=
# Uncomment the following line to add additional VM parameters
# INSTALL4J_ADD_VM_PARAMS=

INSTALL4J_JAVA_PREFIX=""
GREP_OPTIONS=""

As i said, it's not that big an issue for me and from your experience, it appears it's just a matter of time !
Cheers

jimj
Posts: 72
Joined: 2014/10/01 05:34:57

Re: Moneydance on Centos 7 ?

Post by jimj » 2018/05/28 17:41:02

SirLurkalot wrote:Thanks for the pointer, I've had no luck so far and to be honest I'm really wary of screwing it all up!
For some reason I had two jre versions installed 1.7.0 & 1.8.0 . I've now removed 1.7.0
As you say Moneydance is using 1.8.0_144
So you're having trouble getting Moneydance to use CentOS' OpenJDK? Maybe something is wrong with your /etc/alternatives/jre file? It should look like this:

Code: Select all

$ls -l /etc/alternatives/jre
lrwxrwxrwx 1 root root 64 May 23 07:47 /etc/alternatives/jre -> /usr/lib/jvm/java-1.8.0-openjdk-1.8.0.171-8.b10.el7_5.x86_64/jre
This web page has info on using the "alternative" commands to set your Java version (which will update this file). I'm not sure what else to check (other than doublechecking the info I've already posted).

Since Infinite Kind support is now responding to my ticket I'm hopeful they'll get it fixed eventually.

SirLurkalot
Posts: 117
Joined: 2013/02/28 07:57:46

Re: Moneydance on Centos 7 ?

Post by SirLurkalot » 2018/05/29 05:30:49

That clearly is where the problem lies. In /etc/alternatives I have....

jre_1.8.0
jre_1.8.0_exports
jre_1.8.0_openjdk
jre_1.8.0_openjdk_export
jre_openjdk
jre_openjdk_exports

so $ls -l /etc/alternatives/jre returns No such file or directory/

I think I'll leave it because it's not really causing me a problem but thank you for trying ! :-)
Oh by the way, my swapping the Moneydance jre directory for a softlink to java-1.8.0 does change the entry in the Help/Console list but doesn't change the behaviour.

jimj
Posts: 72
Joined: 2014/10/01 05:34:57

Re: Moneydance on Centos 7 ?

Post by jimj » 2018/05/29 12:18:19

SirLurkalot wrote:That clearly is where the problem lies. In /etc/alternatives I have....
Oh by the way, my swapping the Moneydance jre directory for a softlink to java-1.8.0 does change the entry in the Help/Console list but doesn't change the behaviour.
You're welcome. I still can't explain why your softlink way doesn't fix Moneydance, but my guess is that the "alternatives" command would fix your /etc/alternatives/jre file (which may allow my original fix to work).

Post Reply