VM guest hangs under virt-manager (viewer) with 100% cpu

Issues related to applications and software problems
matt_garman
Posts: 40
Joined: 2006/10/18 14:14:21

VM guest hangs under virt-manager (viewer) with 100% cpu

Postby matt_garman » 2018/05/09 01:55:34

I'm trying to use libvirt/qemu/kvm to use my CentOS 7 installation as a virtualization host.

Under virt-manager, I've tried creating two different guests: one an Ubuntu 16 guest, and another a CentOS 7 guest. I choose all defaults, and use the respective OS's installer ISO to boot from. In both cases, as soon as I start the guest, it goes into the installer program, but I virt-viewer will not accept any keyboard (or in one case, mouse) input. On Ubuntu, it skips the initial menu (install options), and jumps straight into the Language selection screen. From here, neither the mouse nor the keyboard work. Also interesting, the CPU usage (as shown in virt-manager) is pegged at 100%. I left it here for over an hour, thinking maybe it had to "work something out", but it never changed: CPU stayed at 100%, and suck at the Language selection screen, mouse/keyboard still not working. Also interesting, the buttons and menus of the virt-viewer window sometimes work, and sometimes don't. When it does work, even if I use Send Key -> Ctl-Alt-Delete, nothing happens.

In CentOS, it's at the first screen where you can choose "Install CentOS 7", "Test this media...", or "Troubleshooting". It appears the guest isn't hung, because the counter is counting down. Eventually it times out, and goes into the actual installer GUI. From here, the mouse works, but not the keyboard. Also, like with Ubuntu, the viewer GUI menus/buttons sometimes work, sometimes don't. But, Send Key -> Ctl-Alt-Delete doesn't do anything (nor does any of the other Send Key options).

Host has virtualization enabled in the BIOS, both kvm and kvm_intel modules are loaded. Only a couple nights ago I ran "yum update" and rebooted. Host CPU is Xeon D-1541 with 32 GB of RAM.

I've used CentOS 7 as a virtualization host numerous times before, never had any issues. It normally "just works", so I've never had to dig in and troubleshoot issues. So I'm at a loss.

Thanks for any tips, hints or suggestions!