Disable interative startup (in other words disable edit kernel parameters pressing 'e' on Centos) not running

Issues related to applications and software problems
djrafael
Posts: 3
Joined: 2018/01/15 04:20:44

Disable interative startup (in other words disable edit kernel parameters pressing 'e' on Centos) not running

Postby djrafael » 2018/05/14 03:27:40

# This not running on Centos 7, Kernel Version(s): 3.10.0-693.21.1.el7.x86_64 and or 4.14.x
nano /etc/sysconfig/init
PROMPT=no

There is another way to disable edit kernel parameters pressing 'e' at startup on Centos 7 or handle this issue.

As regards
Rafael Peres dos Santos

User avatar
jlehtone
Posts: 1917
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Disable interative startup (in other words disable edit kernel parameters pressing 'e' on Centos) not running

Postby jlehtone » 2018/05/14 06:45:20

Is that a statement or a question?

The

Code: Select all

edit kernel parameters pressing 'e'

message is shown in GRUB menu by GRUB.

In order to disable the edit option one could, for example, update the GRUB2 configuration to require a password.

hunter86_bg
Posts: 1101
Joined: 2015/02/17 15:14:33
Location: Bulgaria
Contact:

Re: Disable interative startup (in other words disable edit kernel parameters pressing 'e' on Centos) not running

Postby hunter86_bg » 2018/05/15 04:50:32

Don't forget to add '--unrestricted' (if not already there) in /etc/grub.d/10_linux -> CLASS section, otherwise you will need the password even for boot.