Kickstart Configurator crashes when selecting Encrypt root password

Issues related to applications and software problems
Post Reply
mgoblue0970
Posts: 25
Joined: 2013/01/02 03:39:20

Kickstart Configurator crashes when selecting Encrypt root password

Post by mgoblue0970 » 2018/06/22 15:25:55

Hello:

I'm running system-config-kickstart and when the Kickstart Configurator appears, I select the following:

Basic Configuration -> type in the textboxes for Root Password and Confirm Password -> check the Encrypt root password checkbox -> and then either select File -> Preview or File -> Save

In the preview/save, it crashes with:

Code: Select all

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 346, in on_activate_preview_options
    if self.getAllData() != None:
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 264, in getAllData
    if self.basic_class.formToKickstart(doInstall) is None:
  File "/usr/share/system-config-kickstart/basic.py", line 176, in formToKickstart
    temp = unicode (self.passwd, 'iso-8859-1')
TypeError: coercing to Unicode: need string or buffer, NoneType found
I've been able to make this repeatable... the trigger is definitely selecting the Encrypt root password checkbox. I've tried every other setting in all the trees on the left and then tried to save/preview without a problem. This just happens with then Encrypt root password checkbox.

Thoughts?

Thanks!

User avatar
TrevorH
Forum Moderator
Posts: 23854
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Kickstart Configurator crashes when selecting Encrypt root password

Post by TrevorH » 2018/06/22 15:42:00

Tried it here. Works for me. What language did you select? And the other settings on that page. Does your password contain any special characters?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mgoblue0970
Posts: 25
Joined: 2013/01/02 03:39:20

Re: Kickstart Configurator crashes when selecting Encrypt root password

Post by mgoblue0970 » 2018/06/22 16:10:55

What language did you select?
Any of them. Doesn't matter.
And the other settings on that page
For every tree nodes on the left side of the UI, I have either changed every single combobox, checkbox, radio button, etc., and typed something in every textbox or memo field (e.g., the pre and post script stuff). ALL of that works until the Encrypt root password checkbox is checked.
Does your password contain any special characters?
Of course the password contains special characters... and numbers and caps too.

For this reply, if I type "password" in the Root Password and Comfirm Password textboxes, and leave the checkbox unchecked, here is a snip of the preview:

Code: Select all

#platform=x86, AMD64, or Intel EM64T
#version=DEVEL
# Install OS instead of upgrade
install
# Keyboard layouts
keyboard 'us'
# Root password
rootpw --plaintext password
# System language
lang en_US
# System authorization information
auth  --useshadow  --passalgo=sha512
now, NOT CHANGING A THING, other than checking the Encrypt root password checkbox, and selecting preview, I get this from the terminal:

Code: Select all

Traceback (most recent call last):
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 346, in on_activate_preview_options
    if self.getAllData() != None:
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 264, in getAllData
    if self.basic_class.formToKickstart(doInstall) is None:
  File "/usr/share/system-config-kickstart/basic.py", line 176, in formToKickstart
    temp = unicode (self.passwd, 'iso-8859-1')
TypeError: coercing to Unicode: need string or buffer, NoneType found

User avatar
TrevorH
Forum Moderator
Posts: 23854
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Kickstart Configurator crashes when selecting Encrypt root password

Post by TrevorH » 2018/06/22 16:51:50

Your 'password' check is pretty much what I ran here and it works perfectly for me. That means the problem is something specific to your machine and the settings on it - mine is a just a throwaway VM which I use for testing stuff and did a yum install system-config-kickstart then logged on, ran it did the same thing as you with a simple password and pressed File->Preview and it works. The encrypt checkbox is already prechecked for me.

system-config-kickstart-2.9.7-1.el7.noarch
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

mgoblue0970
Posts: 25
Joined: 2013/01/02 03:39:20

Re: Kickstart Configurator crashes when selecting Encrypt root password

Post by mgoblue0970 » 2018/06/22 17:10:03

mine is a just a throwaway VM which I use for testing stuff
Ditto... mine is really just a default install of CentOS 7 that I'm running in a VM and trying to do some development on. I really haven't done anything to it more than banging on the Next button while installing.
The encrypt checkbox is already prechecked for me
Not here
system-config-kickstart-2.9.7-1.el7.noarch

Code: Select all

rpm -qa | grep -i kickstart
system-config-kickstart-2.9.7-1.el7.noarch
ditto again. Grrr. :)

Post Reply