libaudio.so.2 required for draftSight ...

Issues related to applications and software problems
Post Reply
ikfredje
Posts: 4
Joined: 2018/07/10 12:41:14

libaudio.so.2 required for draftSight ...

Post by ikfredje » 2018/07/10 13:03:40

Hi,

relatively new to CentOS 7 but not to linux (Ubuntu since 2009 private as well as for work).

I'm trying to install draftSight for Fedora from Dassault Systems (https://www.3ds.com/products-services/d ... -download/) by

Code: Select all

$ sudo yum install ./draftSight.rpm 
Loaded plugins: fastestmirror, langpacks
Examining ./draftSight.rpm: draftsight-2018.2.0.3102-1.x86_64
Marking ./draftSight.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package draftsight.x86_64 0:2018.2.0.3102-1 will be installed
--> Processing Dependency: libaudio.so.2 for package: draftsight-2018.2.0.3102-1.x86_64
Loading mirror speeds from cached hostfile
 * base: mirror.ox.ac.uk
 * epel: mirror.inode.at
 * extras: mirror.clustered.net
 * updates: centos.mirroring.pulsant.co.uk
--> Processing Dependency: libGLU.so.1 for package: draftsight-2018.2.0.3102-1.x86_64
--> Running transaction check
---> Package draftsight.x86_64 0:2018.2.0.3102-1 will be installed
--> Processing Dependency: libaudio.so.2 for package: draftsight-2018.2.0.3102-1.x86_64
---> Package mesa-libGLU.i686 0:9.0.0-4.el7 will be installed
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4) for package: mesa-libGLU-9.0.0-4.el7.i686
--> Processing Dependency: libstdc++.so.6(CXXABI_1.3) for package: mesa-libGLU-9.0.0-4.el7.i686
--> Processing Dependency: libstdc++.so.6 for package: mesa-libGLU-9.0.0-4.el7.i686
--> Processing Dependency: libGL.so.1 for package: mesa-libGLU-9.0.0-4.el7.i686
--> Running transaction check
---> Package draftsight.x86_64 0:2018.2.0.3102-1 will be installed
--> Processing Dependency: libaudio.so.2 for package: draftsight-2018.2.0.3102-1.x86_64
---> Package libstdc++.i686 0:4.8.5-28.el7_5.1 will be installed
---> Package mesa-libGL.i686 0:17.2.3-8.20171019.el7 will be installed
--> Processing Dependency: libxshmfence.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb-xfixes.so.0 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb-sync.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb-present.so.0 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb-glx.so.0 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb-dri3.so.0 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libxcb-dri2.so.0 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libselinux.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libglapi.so.0 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libexpat.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libdrm.so.2 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libXxf86vm.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libXfixes.so.3 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libXext.so.6 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libXdamage.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libX11.so.6 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Processing Dependency: libX11-xcb.so.1 for package: mesa-libGL-17.2.3-8.20171019.el7.i686
--> Running transaction check
---> Package draftsight.x86_64 0:2018.2.0.3102-1 will be installed
--> Processing Dependency: libaudio.so.2 for package: draftsight-2018.2.0.3102-1.x86_64
---> Package expat.i686 0:2.1.0-10.el7_3 will be installed
---> Package libX11.i686 0:1.6.5-1.el7 will be installed
---> Package libXdamage.i686 0:1.1.4-4.1.el7 will be installed
---> Package libXext.i686 0:1.3.3-3.el7 will be installed
---> Package libXfixes.i686 0:5.0.3-1.el7 will be installed
---> Package libXxf86vm.i686 0:1.1.4-1.el7 will be installed
---> Package libdrm.i686 0:2.4.83-2.el7 will be installed
--> Processing Dependency: libpciaccess.so.0 for package: libdrm-2.4.83-2.el7.i686
---> Package libselinux.i686 0:2.5-12.el7 will be installed
--> Processing Dependency: libsepol(x86-32) >= 2.5-6 for package: libselinux-2.5-12.el7.i686
--> Processing Dependency: libsepol.so.1(LIBSEPOL_1.0) for package: libselinux-2.5-12.el7.i686
--> Processing Dependency: libsepol.so.1 for package: libselinux-2.5-12.el7.i686
--> Processing Dependency: libpcre.so.1 for package: libselinux-2.5-12.el7.i686
---> Package libxcb.i686 0:1.12-1.el7 will be installed
--> Processing Dependency: libXau.so.6 for package: libxcb-1.12-1.el7.i686
---> Package libxshmfence.i686 0:1.2-1.el7 will be installed
---> Package mesa-libglapi.i686 0:17.2.3-8.20171019.el7 will be installed
--> Running transaction check
---> Package draftsight.x86_64 0:2018.2.0.3102-1 will be installed
--> Processing Dependency: libaudio.so.2 for package: draftsight-2018.2.0.3102-1.x86_64
---> Package libXau.i686 0:1.0.8-2.1.el7 will be installed
---> Package libpciaccess.i686 0:0.14-1.el7 will be installed
---> Package libsepol.i686 0:2.5-8.1.el7 will be installed
---> Package pcre.i686 0:8.32-17.el7 will be installed
--> Finished Dependency Resolution
Error: Package: draftsight-2018.2.0.3102-1.x86_64 (/draftSight)
           Requires: libaudio.so.2
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
I found that libaudio.so.2 is part of nas-libs which I did install :

Code: Select all

$ sudo yum install ./nas-libs-1.9.4-1.el7.nux.x86_64.rpm
$ sudo find /usr -iname *libaudio.so*
/usr/lib64/libaudio.so.2
/usr/lib64/libaudio.so.2.4
I also made a soft link /usr/lib/libaudio.so.2 -> /usr/lib64/libaudio.so.2.4 (similar to /usr/lib64/libaudio.so.2)

But despite this the draftSight.rpm won't install as shown above.

What am I overlooking ?

Thanks upfront for any help you can provide.

User avatar
TrevorH
Forum Moderator
Posts: 23196
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: libaudio.so.2 required for draftSight ...

Post by TrevorH » 2018/07/10 13:45:30

I also made a soft link /usr/lib/libaudio.so.2 -> /usr/lib64/libaudio.so.2.4 (similar to /usr/lib64/libaudio.so.2)
That's not the right thing to do. This is a packaging problem and will never look at the files that exist on disk. It's checking the rpm/yum databases to find out if they say the things it needs are installed not looking at the contents of your filesystem.

Judging by the rest of the packages it's pulling in all being .i686 and the path involved being /usr/lib not /usr/lib64, I'd say it's loking for the i686 version of nas-libs and you've installed the x86_64 version. Not quite sure why your package says it's x86_64 when it appears to be a 32 bit thing.

You're picking up your existing nas-libs package from the nux-dextop repo but I checked and he only has 64 bit packages available. Unless you can find a place to get a 32 bit version of that package you will need to download his SRPM and rebuild it. I'd suggest using mock to do that as it will allow you to build 32 bit packages on a 64 bit system easily. But who knows what other pre-reqs it will have so you might be in for a long rebuild chain.

BTW, if you aim to install packages from a repo, it is far better to install the -release package for that repo - e.g. nux-dextop-release.rpm - so that yum has it available and will update those packages for you in the future. That will also help if the package you downloaded manually has prereqs from the same repo as yum will then be able to pull those in automatically.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

ikfredje
Posts: 4
Joined: 2018/07/10 12:41:14

Re: libaudio.so.2 required for draftSight ...

Post by ikfredje » 2018/07/10 14:48:45

Hi TrevorH,

Thanks for the prompt reply ...

yes, you are fully right of course that it is a packaging issue (install time) and not a run time issue: silly me !

so do you think it is because the rpm does not properly define which libaudio.so.2 it wants (x86_64 vs i686) and that Fedora (vs CentOS) somehow finds the proper libs to install anyway OR that it really needs the i686 version ?

Is it possible to find out from the .rpm (and tweak it to test) ?

pjsr2
Posts: 338
Joined: 2014/03/27 20:11:07

Re: libaudio.so.2 required for draftSight ...

Post by pjsr2 » 2018/07/10 16:04:10

As the dependencies that are pulled in are all .i686, you have to install the i686 version of libaudio.so.2

It looks like there is a packaging error in ./draftSight.rpm. The install messages mention draftsight-2018.2.0.3102-1.x86_64, but it is not x86_64 but i686 instead. ( https://www.3ds.com/products-services/d ... -download/ links to a beta version, so you may expect some errors. Maybe this packaging error is one of those ...)

An i686 executable needs i686 shared libraries and never can load x86_64 shared libs. And the other way round: an x86_64 executable can only load x86_64 shared libs.
Don't create links from something in /usr/lib to something in /usr/lib64 or the other way round. /usr/lib is for i686 libraries and /usr/lib64 for x86_64 libs.

ikfredje
Posts: 4
Joined: 2018/07/10 12:41:14

Re: libaudio.so.2 required for draftSight ...

Post by ikfredje » 2018/07/10 17:00:28

ok I'm not experienced enough probably, but going through the output of the yum install it looks that the .i686 are pulled in through libaudio.so.2 or do I read too much in this output ?

User avatar
TrevorH
Forum Moderator
Posts: 23196
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: libaudio.so.2 required for draftSight ...

Post by TrevorH » 2018/07/10 17:04:13

No because there is no package that supplies a 32 bit copy of that file.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

ikfredje
Posts: 4
Joined: 2018/07/10 12:41:14

Re: libaudio.so.2 required for draftSight ...

Post by ikfredje » 2018/07/12 10:11:55

Finally I found on the draftsight user forum that this is a well known issue on CentOS and that one should install the package without checking the dependencies:

Code: Select all

sudo rpm -Uvh --nodeps draftSight.rpm
which appeared to do the trick ... (although the 1st run activation failed ... <sigh>)

User avatar
TrevorH
Forum Moderator
Posts: 23196
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: libaudio.so.2 required for draftSight ...

Post by TrevorH » 2018/07/12 11:08:49

That will also give nastygrams every time you run yum from now on, complaining about the missing dep.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply