GDM Bottoming out on Lock/Login Screen

Issues related to applications and software problems
Post Reply
Mike_Rochefort
Posts: 81
Joined: 2016/03/16 02:34:19

GDM Bottoming out on Lock/Login Screen

Post by Mike_Rochefort » 2018/08/16 14:17:42

For some reason over the past week I've been having some issues with GDM on both my desktop at work (RHEL 7.5) and my workstation at home (CentOS 7). They are both two very different hardware configurations but are demonstrating identical symptoms and issues. For some reason after locking the desktop (Super + L or Lock button) trying to unlock will cause the password submit button to flicker at a very high frequency and the password field will clear itself while typing. This requires a power reset or dropping into a TTY shell and rebooting to solve.

The other issue is that the login screen doesn't seem to be resuming from sleep properly. This is the second day in the row where I came in to the office and I'm met by a black screen with a flashing cursor. I dropped into a TTY shell and ran systemctl status gdm. The following image is the result:

Image

I checked the Xorg log in /var/log/Xorg.0.log but there wasn't anything that stuck out besides hundreds of AUDIT messages mentioning MIT_MAGIC_COOKIE connecting/disconnecting a lot. I've attached the log file just in case anyone can pick something up. This also required a reboot to resolve as restarting gdm would just break things further.

Any pointers on this would be helpful!

Cheers,
Mike
Attachments
Xorg.0.log.xz.tar
This is an XZ compressed log file, not just tar. Tar was added to allow uploading to the forum.
(25.73 KiB) Downloaded 9 times

desertcat
Posts: 433
Joined: 2014/08/07 02:17:29
Location: Tucson, AZ

Re: GDM Bottoming out on Lock/Login Screen

Post by desertcat » 2018/08/17 22:35:00

GDM is a problem. I would suggest you switch your Display Manager to LightDM. LightDM gets around all the wonky AUDIT stuff. GDM is a runaway locomotive constantly filling up /var/log/Xorg.0.log file with repetitive AUDIT lines.

To install LightDM try this:

GoTo a konsole => type su => Enter Secret Sauce Password and become root!

As root enter the following two commands:

systemctl disable gdm.service
systemctl enable lightdm.service

Reboot the Machine and it should come up in lightdm

With LightDM installed hopefully that will solve your problem.

Post Reply