Apache Server not starting centos 7

Issues related to applications and software problems
Post Reply
sicario
Posts: 1
Joined: 2018/08/17 20:50:09

Apache Server not starting centos 7

Post by sicario » 2018/08/17 21:09:10

My server was all good, until I decided to update Php6 for php7.0 in the Tutorial everything went perfect when updating everything. but the page Jamas came back inside.
The Apache never went back to Restart, the Apache does not work and I have several websites off the air. Please help me.

[root~]# systemctl restart httpd
Job for httpd.service failed because the control process exited with error code. See "systemctl status httpd.service" and "journalctl -xe" for details.


When I go to systemctl status httpd.service

[root@vmi106435 ~]# systemctl status httpd.service
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Fri 2018-08-17 22:53:45 CEST; 52s ago
Docs: man:httpd(8)
man:apachectl(8)
Process: 29474 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
Process: 29472 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILURE)
Main PID: 29472 (code=exited, status=1/FAILURE)

Aug 17 22:53:45 systemd[1]: Starting The Apache HTTP S...
Aug 17 22:53:45 httpd[29472]: AH00534: httpd: Configur...
Aug 17 22:53:45 systemd[1]: httpd.service: main proces...
Aug 17 22:53:45 kill[29474]: kill: cannot find process ""
Aug 17 22:53:45 systemd[1]: httpd.service: control pro...
Aug 17 22:53:45 systemd[1]: Failed to start The Apache...
Aug 17 22:53:45 systemd[1]: Unit httpd.service entered...
Aug 17 22:53:45 systemd[1]: httpd.service failed.
Hint: Some lines were ellipsized, use -l to show in full.
[root@vmi106435 ~]#

When I go to journalctl -xe

[root@vmi106435 ~]# journalctl -xe
Aug 17 22:45:41 [31177]: Unregistered Authenticati
Aug 17 22:53:45 [31177]: Registered Authentication
Aug 17 22:53:45 systemd[1]: Starting The Apache HTTP Serv
-- Subject: Unit httpd.service has begun start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li ... temd-devel
--
-- Unit httpd.service has begun starting up.
Aug 17 22:53:45 httpd[29472]: AH00534: httpd: Configurati
Aug 17 22:53:45 systemd[1]: httpd.service: main process e
Aug 17 22:53:45 kill[29474]: kill: cannot find process ""
Aug 17 22:53:45 systemd[1]: httpd.service: control proces
Aug 17 22:53:45 systemd[1]: Failed to start The Apache HT
-- Subject: Unit httpd.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li ... temd-devel
--
-- Unit httpd.service has failed.
--
-- The result is failed.
Aug 17 22:53:45 systemd[1]: Unit httpd.service entered fa
Aug 17 22:53:45 systemd[1]: httpd.service failed.
Aug 17 22:53:45 polkitd[31177]: Unregistered Authenticati
lines 1429-1451/1451 (END)

Inside the Log_error file the last error is this
/var/log/httpd
[Fri Aug 17 06:53:19.664430 2018] [suexec:notice] [pid 21096] AH01232: suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

User avatar
avij
Forum Moderator
Posts: 2722
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Apache Server not starting centos 7

Post by avij » 2018/08/18 04:12:48

AH00534 is "httpd: Configuration error: No MPM loaded". See that you have some module loaded in /etc/httpd/conf.modules.d/00-mpm.conf

Post Reply