PC restarting when connecting to M&S

Issues related to applications and software problems
Post Reply
SirLurkalot
Posts: 127
Joined: 2013/02/28 07:57:46

PC restarting when connecting to M&S

Post by SirLurkalot » 2019/02/04 09:27:22

As per title... Following the latest update my PC restarts when connecting to https://www.marksandspencer.com/
I then have to log in again! Firefox is now at 60.5.0esr
So far it appears to be the only site and I have apparently solved it by selecting
Preferences/Privacy & Security/Tracking Protection > Always
Is there something wrong with the site that I can raise or is it just what they've chosen to do?
Cheers

User avatar
TrevorH
Forum Moderator
Posts: 25576
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PC restarting when connecting to M&S

Post by TrevorH » 2019/02/04 09:46:47

Your PC restarts? As in reboots?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

SirLurkalot
Posts: 127
Joined: 2013/02/28 07:57:46

Re: PC restarting when connecting to M&S

Post by SirLurkalot » 2019/02/04 09:50:43

Yes, I have to log in again.

User avatar
TrevorH
Forum Moderator
Posts: 25576
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PC restarting when connecting to M&S

Post by TrevorH » 2019/02/04 11:00:36

It doesn't just log you out? It actually reboots the machine and makes it go through POST and all the BIOS messages etc?
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

SirLurkalot
Posts: 127
Joined: 2013/02/28 07:57:46

Re: PC restarting when connecting to M&S

Post by SirLurkalot » 2019/02/04 12:13:37

Oh no, sorry, just makes me log in again.

Just for the record, reverting FF to earlier version 60.4.0esr makes no difference.

User avatar
TrevorH
Forum Moderator
Posts: 25576
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: PC restarting when connecting to M&S

Post by TrevorH » 2019/02/04 17:05:07

Right, so most likely it's crashing gnome-session or something. There is probably a line in /var/log/messages telling you what crashed and the eip it crashed at. If you have abrt installed then it's probably stashed a bunch of debug info away somewhere (I purge it with fire so don't know where).

I did just fire up my firefox on a CentOS 7 VM and tried the site and it's fine for me. My settings are for Tracking Protection "Only in Private Windows" (and this one was not).

What's the rest of your system? Up to date with all updates offered by yum update ? Running gnome3 or some alternative desktop? What sort of hardware - specifically processor but other details like graphics card might be useful too.
CentOS 5 died in March 2017 - migrate NOW!
Full time Geek, part time moderator. Use the FAQ Luke

SirLurkalot
Posts: 127
Joined: 2013/02/28 07:57:46

Re: PC restarting when connecting to M&S

Post by SirLurkalot » 2019/02/04 19:24:34

Yes the SW is up to date and running Gnome 3.28.2

Architecture: x86_64
Vendor ID: GenuineIntel
Model name: Intel(R) Core(TM) i3-2120 CPU @ 3.30GHz

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Cedar [Radeon HD 5000/6000/7350/8350 Series] (prog-if 00 [VGA controller])
Subsystem: Dell Radeon HD 6350
Kernel driver in use: radeon
Kernel modules: radeon

This is the first few lines of Messages...

Feb 4 19:07:01 localhost abrt-hook-ccpp: Process 28396 (Xorg) of user 0 killed by SIGABRT - dumping core
Feb 4 19:07:01 localhost abrtd: Size of '/var/spool/abrt' >= 1000 MB (MaxCrashReportsSize), deleting old directory 'ccpp-2019-02-04-18:38:33-29366'
Feb 4 19:07:01 localhost journal: gnome-shell: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:01 localhost org.a11y.atspi.Registry: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Feb 4 19:07:01 localhost org.a11y.atspi.Registry: after 1541 requests (1541 known processed) with 0 events remaining.
Feb 4 19:07:01 localhost gnome-session-binary[28791]: WARNING: Lost name on bus: org.gnome.SessionManager
Feb 4 19:07:01 localhost org.gtk.vfs.Daemon: A connection to the bus can't be made
Feb 4 19:07:01 localhost gnome-session: gnome-session-binary[28791]: WARNING: Lost name on bus: org.gnome.SessionManager
Feb 4 19:07:02 localhost journal: gsd-power: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-xsettings: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-wacom: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-clipboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-color: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-keyboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-media-keys: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: nautilus-desktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost bluetoothd[3708]: Endpoint unregistered: sender=:1.630 path=/MediaEndpoint/A2DPSource
Feb 4 19:07:02 localhost bluetoothd[3708]: Endpoint unregistered: sender=:1.630 path=/MediaEndpoint/A2DPSink
Feb 4 19:07:02 localhost journal: gnome-terminal-server: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost firefox.desktop: Gdk-Message: 19:07:02.027: /usr/lib64/firefox/firefox: Fatal IO error 13 (Permission denied) on X server :0.
Feb 4 19:07:02 localhost journal: firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost gdm: Child process 28396 was already dead.
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Power.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Power.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gFeb 4 19:07:01 localhost abrt-hook-ccpp: Process 28396 (Xorg) of user 0 killed by SIGABRT - dumping core
Feb 4 19:07:01 localhost abrtd: Size of '/var/spool/abrt' >= 1000 MB (MaxCrashReportsSize), deleting old directory 'ccpp-2019-02-04-18:38:33-29366'
Feb 4 19:07:01 localhost journal: gnome-shell: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:01 localhost org.a11y.atspi.Registry: XIO: fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
Feb 4 19:07:01 localhost org.a11y.atspi.Registry: after 1541 requests (1541 known processed) with 0 events remaining.
Feb 4 19:07:01 localhost gnome-session-binary[28791]: WARNING: Lost name on bus: org.gnome.SessionManager
Feb 4 19:07:01 localhost org.gtk.vfs.Daemon: A connection to the bus can't be made
Feb 4 19:07:01 localhost gnome-session: gnome-session-binary[28791]: WARNING: Lost name on bus: org.gnome.SessionManager
Feb 4 19:07:02 localhost journal: gsd-power: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-xsettings: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-wacom: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-clipboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-color: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-keyboard: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: gsd-media-keys: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost journal: nautilus-desktop: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost bluetoothd[3708]: Endpoint unregistered: sender=:1.630 path=/MediaEndpoint/A2DPSource
Feb 4 19:07:02 localhost bluetoothd[3708]: Endpoint unregistered: sender=:1.630 path=/MediaEndpoint/A2DPSink
Feb 4 19:07:02 localhost journal: gnome-terminal-server: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost firefox.desktop: Gdk-Message: 19:07:02.027: /usr/lib64/firefox/firefox: Fatal IO error 13 (Permission denied) on X server :0.
Feb 4 19:07:02 localhost journal: firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
Feb 4 19:07:02 localhost gdm: Child process 28396 was already dead.
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Power.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Power.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.XSettings.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Wacom.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Clipboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Color.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'nautilus-classic.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.XSettings.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Wacom.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Clipboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Color.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'nautilus-classic.desktop' exited with code 1
Feb 4 19:07:02 localhost journal: Error releasing name org.freedesktop.portal.IBus: The connection is closed
Feb 4 19:07:02 localhost org.gnome.Shell.CalendarServer: gnome-shell-calendar-server[29087]: Lost (or failed to acquire) the name org.gnome.Shell.CalendarServer - exiting
Feb 4 19:07:02 localhost journal: Cannot open display:
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.UDisks2VolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.UDisks2VolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.MTPVolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost firefox.desktop: Sandbox: Unexpected EOF, op 2 flags 00 path /etc/localtime
Feb 4 19:07:02 localhost kernel: Chrome_~dThread[31522]: segfault at 0 ip 00007f6a80ae9dad sp 00007f6a7e042b00 error 6 in libxul.so[7f6a805db000+5802000]
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.GoaVolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost org.gtk.vfs.Daemon: A connection to the bus can't be made
Feb 4 19:07:02 localhost org.gtk.vfs.Daemon: A connection to the bus can't be made

nome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.XSettings.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Wacom.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Clipboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Color.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session: gnome-session-binary[28791]: WARNING: App 'nautilus-classic.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.XSettings.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Wacom.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Clipboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Color.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.Keyboard.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'org.gnome.SettingsDaemon.MediaKeys.desktop' exited with code 1
Feb 4 19:07:02 localhost gnome-session-binary[28791]: WARNING: App 'nautilus-classic.desktop' exited with code 1
Feb 4 19:07:02 localhost journal: Error releasing name org.freedesktop.portal.IBus: The connection is closed
Feb 4 19:07:02 localhost org.gnome.Shell.CalendarServer: gnome-shell-calendar-server[29087]: Lost (or failed to acquire) the name org.gnome.Shell.CalendarServer - exiting
Feb 4 19:07:02 localhost journal: Cannot open display:
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.UDisks2VolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.UDisks2VolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.MTPVolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost firefox.desktop: Sandbox: Unexpected EOF, op 2 flags 00 path /etc/localtime
Feb 4 19:07:02 localhost kernel: Chrome_~dThread[31522]: segfault at 0 ip 00007f6a80ae9dad sp 00007f6a7e042b00 error 6 in libxul.so[7f6a805db000+5802000]
Feb 4 19:07:02 localhost journal: Owner of volume monitor org.gtk.vfs.GoaVolumeMonitor disconnected from the bus; removing drives/volumes/mounts
Feb 4 19:07:02 localhost org.gtk.vfs.Daemon: A connection to the bus can't be made
Feb 4 19:07:02 localhost org.gtk.vfs.Daemon: A connection to the bus can't be made

I admit that it's all ***** to me and am tempted to simply leave it set to 'Tracking protection/Always' and hope a future update straightens it out again.

Thanks

SirLurkalot
Posts: 127
Joined: 2013/02/28 07:57:46

Re: PC restarting when connecting to M&S

Post by SirLurkalot » 2019/02/07 13:06:35

I have persevered with this and the issue appears to be with xorg-x11-*
I've completed the latest update but excluding xorg-x11-drv-ati, xorg-x11-server-Xorg, xorg-x11-server-common and the problem of Gnome re-starting when attempting to log into the M&S site has gone. I was also having the same issue with Amazon.
I've added an exclude line with those files to /etc/yum.conf and all appears well.

I've just found this on a Redhat list https://access.redhat.com/discussions/3677071 which describes the bug.

SirLurkalot
Posts: 127
Joined: 2013/02/28 07:57:46

Re: PC restarting when connecting to M&S

Post by SirLurkalot » 2019/05/17 15:54:58

SirLurkalot wrote:
2019/02/07 13:06:35
I've just found this on a Redhat list https://access.redhat.com/discussions/3677071 which describes the bug.
Why is it, that this can apparently be resolved for Fedora but doesn't get fed through to Redhat/Centos? I don't like the idea of preventing updates and getting behind although by preventing the update, all's working OK.

Cheers

Post Reply