Thunderbird/Firebird failure

Issues related to applications and software problems
Post Reply
MartinR
Posts: 423
Joined: 2015/05/11 07:53:27
Location: UK

Thunderbird/Firebird failure

Post by MartinR » 2019/05/09 19:04:03

I have a user who is experiencing problems starting a Firebird browser from a link in Thunderbird. The syptoms are that she clicks on the link and Firebird attempts to start with a URL like:
Removing the file and $HOME works perfectly.

I examined the running system and the command line (from ps -ef | grep fire was:
From a terminal both the command firefox 'https... and /usr/lib64/firefox/firefox 'https... both worked perfectly. Going into /proc shows that the commandline is just as ps displayed.

I'm a little stumped. It appears the Thunderbird is sending the right string, and yet Firefox consistently applies a default "file://$HOME" to the start of the string when invoked this way.

Any pointer please!

MartinR
Posts: 423
Joined: 2015/05/11 07:53:27
Location: UK

Re: Thunderbird/Firebird failure

Post by MartinR » 2019/05/14 12:48:14

Bump?

aks
Posts: 2720
Joined: 2014/09/20 11:22:14

Re: Thunderbird/Firebird failure

Post by aks » 2019/05/14 15:56:50

At a guess, create a new firefox profile for the user (and hence reset firefox to defaults) - at least that'll eliminate anything that the user has done?

MartinR
Posts: 423
Joined: 2015/05/11 07:53:27
Location: UK

Re: Thunderbird/Firebird failure

Post by MartinR » 2019/05/14 20:52:51

If I don't find out why it's behaving in this way that's what I was thinking of as a next step. I still don't understand why though it works from the command line but not from Thunderbird.

aks
Posts: 2720
Joined: 2014/09/20 11:22:14

Re: Thunderbird/Firebird failure

Post by aks » 2019/05/15 17:48:53

Something is injecting a 'file://' in the MIME type of URL????

Post Reply