snapd error - cannot mount squashfs image

Issues related to applications and software problems
Post Reply
wylandadm
Posts: 4
Joined: 2019/08/26 20:10:07

snapd error - cannot mount squashfs image

Post by wylandadm » 2019/08/26 20:15:14

Code: Select all

[root@xx ~]# snap install filebot
error: system does not fully support snapd: cannot mount squashfs image using
       "squashfs": mount: unknown filesystem type 'squashfs'

System info
centos-release-7-6.1810.2.el7.centos.x86_64

Package squashfs-tools-4.3-0.21.gitaae0aff4.el7.x86_64 already installed and latest version
Last edited by wylandadm on 2019/09/01 18:26:33, edited 1 time in total.

wylandadm
Posts: 4
Joined: 2019/08/26 20:10:07

Re: snapd error - cannot mount squashfs image

Post by wylandadm » 2019/09/01 13:37:12

Code: Select all

Sep 01 15:31:24 as01.wyland systemd[1]: Starting Snappy daemon...
Sep 01 15:31:24 as01.wyland snapd[1432]: AppArmor status: apparmor not enabled
Sep 01 15:31:24 as01.wyland snapd[1432]: daemon.go:379: started snapd/2.39.2-1.el7 (series 16; classic; devmode) centos/7 (amd64) linux/3.10.0-957.27.2.el7.x86_6.
Sep 01 15:31:24 as01.wyland snapd[1432]: main.go:123: system does not fully support snapd: cannot mount squashfs image using "squashfs": mount: unknown filesystem type 'squashfs'
Sep 01 15:31:24 as01.wyland systemd[1]: Started Snappy daemon.
Sep 01 15:31:29 as01.wyland snapd[1432]: daemon.go:611: gracefully waiting for running hooks
Sep 01 15:31:29 as01.wyland snapd[1432]: daemon.go:613: done waiting for running hooks
Sep 01 15:31:29 as01.wyland snapd[1432]: daemon stop requested to wait for socket activation
Sep 01 15:35:31 as01.wyland systemd[1]: Starting Snappy daemon...
Sep 01 15:35:31 as01.wyland snapd[2496]: AppArmor status: apparmor not enabled
Sep 01 15:35:31 as01.wyland snapd[2496]: daemon.go:379: started snapd/2.39.2-1.el7 (series 16; classic; devmode) centos/7 (amd64) linux/3.10.0-957.27.2.el7.x86_6.
Sep 01 15:35:31 as01.wyland snapd[2496]: main.go:123: system does not fully support snapd: cannot mount squashfs image using "squashfs": mount: unknown filesystem type 'squashfs'
Sep 01 15:35:31 as01.wyland systemd[1]: Started Snappy daemon.
Sep 01 15:35:36 as01.wyland snapd[2496]: daemon.go:611: gracefully waiting for running hooks
Sep 01 15:35:36 as01.wyland snapd[2496]: daemon.go:613: done waiting for running hooks
Sep 01 15:35:36 as01.wyland snapd[2496]: daemon stop requested to wait for socket activation
Last edited by wylandadm on 2019/09/01 18:26:19, edited 1 time in total.

User avatar
TrevorH
Forum Moderator
Posts: 26940
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: snapd error - cannot mount squashfs image

Post by TrevorH » 2019/09/01 15:21:57

What happens if you run modprobe squashfs as root first?
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

wylandadm
Posts: 4
Joined: 2019/08/26 20:10:07

Re: snapd error - cannot mount squashfs image

Post by wylandadm » 2019/09/01 18:26:03

TrevorH wrote:
2019/09/01 15:21:57
What happens if you run modprobe squashfs as root first?

Executed:

Code: Select all

sudo modprobe squashfs -v
install /bin/true
Still the same. I did run

Code: Select all

lsmod|grep squash
but it shows nothing.

User avatar
TrevorH
Forum Moderator
Posts: 26940
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: snapd error - cannot mount squashfs image

Post by TrevorH » 2019/09/01 19:57:15

sudo modprobe squashfs -v
install /bin/true
Someone has disabled the squashfs module by setting up an "install squashfs /bin/true" in a file in /etc/modprobe.d.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

wylandadm
Posts: 4
Joined: 2019/08/26 20:10:07

Re: snapd error - cannot mount squashfs image

Post by wylandadm » 2019/09/01 20:06:41

TrevorH wrote:
2019/09/01 19:57:15
sudo modprobe squashfs -v
install /bin/true
Someone has disabled the squashfs module by setting up an "install squashfs /bin/true" in a file in /etc/modprobe.d.
Thank you so much. Was an entry by Security Requirement from the setup I think.

Post Reply

Return to “CentOS 7 - Software Support”