Issue when installing Package

Issues related to applications and software problems
Post Reply
akshay
Posts: 2
Joined: 2019/08/31 08:00:31

Issue when installing Package

Post by akshay » 2019/08/31 08:03:15

NOT able to solve this issue.

when i try this :

#yum install R -y

i get this error:

Error: Package: R-core-3.6.0-1.el7.x86_64 (epel)
Requires: tex(dvips)
Error: Package: R-core-devel-3.6.0-1.el7.x86_64 (epel)
Requires: tk-devel
Error: Package: R-core-devel-3.6.0-1.el7.x86_64 (epel)
Requires: texinfo-tex
Error: Package: R-core-devel-3.6.0-1.el7.x86_64 (epel)
Requires: tex(latex)
Error: Package: R-core-devel-3.6.0-1.el7.x86_64 (epel)
Requires: tcl-devel
Error: Package: R-core-3.6.0-1.el7.x86_64 (epel)
Requires: tex(latex)
Error: Package: R-core-devel-3.6.0-1.el7.x86_64 (epel)
Requires: pcre2-devel
Error: Package: R-java-devel-3.6.0-1.el7.x86_64 (epel)
Requires: java-devel
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
intel-conda-ipp-devel-linux-64-shadow-package-2019.3-199-2019.3-199.x86_64 has missing requires of intel-conda-ipp-linux-32-shadow-package-2019.3-199
iwpmd-17.2-3.el7.x86_64 has missing requires of rdma-core(x86-64) = ('0', '17.2', '3.el7')
You have new mail in /var/spool/mail/root

User avatar
TrevorH
Forum Moderator
Posts: 26942
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Issue when installing Package

Post by TrevorH » 2019/08/31 12:50:27

I'd say you have disabled the base and updates repos that contain all the missing prereqs it's complaining about...
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”