Dependency error with qt5-qtquick1-devel

Issues related to applications and software problems
gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 11:37:33

Hello. I seem to be having the same issue.

[ Topic split away from original 7.4 thread viewtopic.php?f=48&t=63992 ]

For those of us less savvy, would you please expand on the how to "CR repo" to address this problem.

Thank you.

Gary

User avatar
TrevorH
Forum Moderator
Posts: 26983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/01 11:48:39

yum --enablerepo=cr ... or edit the file in /etc/yum.repos.d and set it to permanently enabbled there. Probably better to do it on each command you run.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 11:55:24

Thank you! I appreciate your help and quick reply.

Gary

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 13:47:53

TrevorH,

Still learning CentOS...

I don't know what within CentOS even needs "qt5-qtquick1-devel". Is it an app or the CentOS itself? How do I find out?

Thank you again.

Gary

User avatar
jlehtone
Posts: 2389
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Dependency error with qt5-qtquick1-devel

Post by jlehtone » 2019/09/01 15:01:20

gsownsby wrote:
2019/09/01 13:47:53
I don't know what within CentOS even needs "qt5-qtquick1-devel".
Nothing does.

You did hop on two years old thread. Incidentally, at that time CR repo was active just like now.
However, right now:

Code: Select all

Error: Package: qt5-qtquick1-5.7.1-1.2bc722agit.el7.x86_64 (epel)
           Requires: qt5-qtbase(x86-64) = 5.9.2
           Installed: qt5-qtbase-5.9.7-2.el7.x86_64 (@cr)
Without CR's updates:

Code: Select all

Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtbase(x86-64) = 5.9.7
           Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@anaconda)
In other words, the qt5-qtquick1 in EPEL demands qt5-qtbase-5.9.2 (available in CentOS 7.6 base), but pulls in qt5-qtwebkit from EPEL that requires qt5-qtbase-5.9.7 (available in CentOS 7.6 CR).
That is a (temporary) no-win situation.


The qt5-qtquick1-devel is a "devel" package for qt5-qtquick1. The devel packages have header files, etc so that one can compile applications that use libraries. In this case the library is in qt5-qtquick1. The compiled applications can be run without the devel packages.

Code: Select all

yum --enablerepo=epel info qt5-qtquick1
That "library" adds some tools for creating Qt5-based applications.

Nothing "within CentOS" needs it. EPEL might have packages that depend on the qt5-qtquick1 package. Only a human would need the devel. Only you know why you did want to install it.

User avatar
TrevorH
Forum Moderator
Posts: 26983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/01 15:21:03

You're going to need to raise a bugzilla entry in the Fedora EPEL section of bugzilla.redhat.com to get this addressed. There is no newer version of qt5-qtquick1 even in the epel-testing repo. That means it needs the maintainer to rebuild it and push it and the only way that happens is if someone asks them to do so.

qt5-qtquick1 needs rebuilding against the newer qt5-* 5.9.7 packages which will be in 7.7 (7.6 has 5.9.2).
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 15:23:13

TrevorH,

Thank you for your reply.

Well, actually I don't have a clue as to what or why it is installed. I assume that some app I installed put it into play. I did not intentionally install it specifically.

I suspect there is a lot going on behind the scenes of which the casual users has no direct knowledge. From my view, it seems there has been a lot of late that has popped up during a simple "yum update". This is the third or fourth in the last couple of months that there was an issue...requiring more than simple sleuthing. My CentOS install is fairly straightforward and I do yum updates when I see notices that something has been updated.

When an update fails or has other issues, it is often a high hurdle for a casual CentOS user. :D

Thank you again. I really appreciate your help.

Gary

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 15:25:40

Thank you again.

I'd even be happy to know what app on my system even requires it as I might be able to live without it. ;)

Gary

User avatar
TrevorH
Forum Moderator
Posts: 26983
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/01 15:28:43

You trimmed the rest of the yum output which would have told you.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

User avatar
jlehtone
Posts: 2389
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Dependency error with qt5-qtquick1-devel

Post by jlehtone » 2019/09/01 16:53:04

gsownsby wrote:
2019/09/01 15:23:13
Well, actually I don't have a clue as to what or why it is installed. I assume that some app I installed put it into play. I did not intentionally install it specifically.
In other words, you did install something with yum and got qt5-quick1-devel as dependency?

One method is to:

Code: Select all

yum remove qt5-quick1-devel
If the list of packages that the command would uninstall is expendable, then accept.

Method two:

Code: Select all

yum history list qt5-quick1-devel
You should get at least one yum transaction that did install/update the package.
Then you can:

Code: Select all

yum history info NNN
to see what the transaction NNN did do.

Post Reply

Return to “CentOS 7 - Software Support”