Dependency error with qt5-qtquick1-devel

Issues related to applications and software problems
User avatar
jlehtone
Posts: 2379
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Dependency error with qt5-qtquick1-devel

Post by jlehtone » 2019/09/02 08:43:41

Ziris85 wrote:
2019/09/01 23:50:15
I submitted a bug about this so hopefully they'll repackage this and fix the dependency issues:
Did I not already show that the qt5-qtwebkit-5.9.1-2.el7.x86_64 currently in EPEL is satisfied by the qt5-qtbase-5.9.7 that is in RHEL-7.7 and in CentOS 7 CR?
I see no bug nor anything to "fix" with the qt5-qtwebkit.

Within CentOS 7 you either exclude qt5-qtwebkit until 7.7 is released or enable cr repo.


The qt5-quick1 is an another story.

Adonist
Posts: 4
Joined: 2019/09/02 15:19:29

Re: Dependency error with qt5-qtquick1-devel

Post by Adonist » 2019/09/02 15:21:18

Having the same issue here.
The support page in Red Hat has a "fix" for that that also doesn't work: https://access.redhat.com/solutions/4385521

I think we have to wait for them to fix the repo for the mean time.
There's a bug report created if anyone wants to comment: https://bugzilla.redhat.com/show_bug.cgi?id=1747823

Thanks

User avatar
TrevorH
Forum Moderator
Posts: 26915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/02 15:26:29

Did you try with yum --enablerepo=cr as part of your command?
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Ziris85
Posts: 5
Joined: 2014/11/19 08:19:15

Re: Dependency error with qt5-qtquick1-devel

Post by Ziris85 » 2019/09/03 01:34:44

jlehtone wrote:
2019/09/01 15:01:20
In other words, the qt5-qtquick1 in EPEL demands qt5-qtbase-5.9.2 (available in CentOS 7.6 base), but pulls in qt5-qtwebkit from EPEL that requires qt5-qtbase-5.9.7 (available in CentOS 7.6 CR).
That is a (temporary) no-win situation.
Yes, I suppose you did, though in my humble opinion wasn't stated very clearly. Apologies for missing it all the same.

In any case, this does appear to be an issue related to the inevitable wait for updates from RHEL to make it to CentOS, as that package is built for RHEL 7.7 but CentOS 7.7 is not out yet. Enabling the CR repo does fix this for me, so we can either wait for cent7.7 to make its way out, or go with the temp fix of enabling the CR repo for now (or just skip the updates for now or something).

User avatar
TrevorH
Forum Moderator
Posts: 26915
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/03 01:38:21

Since what is in CR is what will be 7.7, you're just getting advance access to it.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Ziris85
Posts: 5
Joined: 2014/11/19 08:19:15

Re: Dependency error with qt5-qtquick1-devel

Post by Ziris85 » 2019/09/03 01:42:53

Well then there ya go - problem solved :D

Thanks all!

Post Reply

Return to “CentOS 7 - Software Support”