Dependency error with qt5-qtquick1-devel

Issues related to applications and software problems
User avatar
TrevorH
Forum Moderator
Posts: 26864
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/01 17:23:32

The only thing that repoquery --whatrequires qt5-qtquick1 (not -devel) tells me that looks like it might be the thing that required it is viber-0:4.2.2.6-8.el7.nux.x86_64
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 17:27:00

I reran "yum update" and here is the full output:

[root@zeus ~]# yum clean all
Loaded plugins: fastestmirror, langpacks
Existing lock /var/run/yum.pid: another copy is running as pid 8961.
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: PackageKit
Memory : 263 M RSS (581 MB VSZ)
Started: Sun Sep 1 13:22:35 2019 - 00:11 ago
State : Sleeping, pid: 8961
Another app is currently holding the yum lock; waiting for it to exit...
The other application is: PackageKit
Memory : 263 M RSS (581 MB VSZ)
Started: Sun Sep 1 13:22:35 2019 - 00:13 ago
State : Sleeping, pid: 8961
Cleaning repos: base epel extras mariadb nux-dextop remi-php70 remi-php71 remi-php73 remi-safe teamviewer updates virtualbox
Cleaning up list of fastest mirrors
Other repos take up 2.1 M of disk space (use --verbose for details)
[root@zeus ~]# yum update
Loaded plugins: fastestmirror, langpacks
Determining fastest mirrors
epel/x86_64/metalink | 19 kB 00:00:00
* base: ftpmirror.your.org
* epel: mirror.team-cymru.com
* extras: ftp.osuosl.org
* nux-dextop: li.nux.ro
* remi-php70: mirror.team-cymru.com
* remi-php71: mirror.team-cymru.com
* remi-php73: mirror.team-cymru.com
* remi-safe: mirror.team-cymru.com
* updates: mirror.cs.uwp.edu
base | 3.6 kB 00:00:00
epel | 5.4 kB 00:00:00
extras | 3.4 kB 00:00:00
mariadb | 2.9 kB 00:00:00
nux-dextop | 2.9 kB 00:00:00
remi-php70 | 3.0 kB 00:00:00
remi-php71 | 3.0 kB 00:00:00
remi-php73 | 3.0 kB 00:00:00
remi-safe | 3.0 kB 00:00:00
teamviewer | 2.5 kB 00:00:00
updates | 3.4 kB 00:00:00
virtualbox/7/x86_64/signature | 181 B 00:00:00
virtualbox/7/x86_64/signature | 2.9 kB 00:00:00 !!!
(1/15): base/7/x86_64/group_gz | 166 kB 00:00:00
(2/15): epel/x86_64/group_gz | 88 kB 00:00:00
(3/15): epel/x86_64/updateinfo | 1.0 MB 00:00:00
(4/15): extras/7/x86_64/primary_db | 215 kB 00:00:00
(5/15): mariadb/primary_db | 72 kB 00:00:00
(6/15): remi-php70/primary_db | 229 kB 00:00:00
(7/15): remi-php73/primary_db | 201 kB 00:00:00
(8/15): base/7/x86_64/primary_db | 6.0 MB 00:00:00
(9/15): remi-php71/primary_db | 239 kB 00:00:00
(10/15): remi-safe/primary_db | 1.6 MB 00:00:00
(11/15): epel/x86_64/primary_db | 6.8 MB 00:00:00
(12/15): virtualbox/7/x86_64/primary_db | 134 kB 00:00:00
(13/15): teamviewer/x86_64/primary_db | 33 kB 00:00:00
(14/15): updates/7/x86_64/primary_db | 7.4 MB 00:00:00
(15/15): nux-dextop/x86_64/primary_db | 1.8 MB 00:00:01
Resolving Dependencies
--> Running transaction check
---> Package qt5-qtwebkit.x86_64 0:5.9.1-1.el7 will be updated
---> Package qt5-qtwebkit.x86_64 0:5.9.1-2.el7 will be an update
--> Processing Dependency: qt5-qtbase(x86-64) = 5.9.7 for package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Processing Dependency: qt5-qtdeclarative(x86-64) = 5.9.7 for package: qt5-qtwebkit-5.9.1-2.el7.x86_64
--> Finished Dependency Resolution
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
Requires: qt5-qtbase(x86-64) = 5.9.7
Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@anaconda)
qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
Requires: qt5-qtdeclarative(x86-64) = 5.9.7
Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va -

User avatar
TrevorH
Forum Moderator
Posts: 26864
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/01 17:41:11

So qt5-webkit is from EPEL and requires the older packages from 7.6. That needs to be rebuilt by EPEL to allow it to work. I looked in epel-testing and it's not already there.

As for what pulled it in in the first place, jlehtone has already told you the easiest way to find out: yum remove it and study the list of packages that it wants to take out with it carefully and see if it includes anything you want.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 18:08:01

Thank you both for your help.

We'll give it a shot.

Gary

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/01 18:13:55

Well tried those commands. Here is the result:

[root@zeus ~]# yum remove qt5-quick1-devel
Loaded plugins: fastestmirror, langpacks
No Match for argument: qt5-quick1-devel
No Packages marked for removal

[root@zeus ~]# yum history list qt5-quick1-devel
Loaded plugins: fastestmirror, langpacks
Bad transaction IDs, or package(s), given
Error: Failed history list

[root@zeus ~]#

User avatar
jlehtone
Posts: 2369
Joined: 2007/12/11 08:17:33
Location: Finland

Re: Dependency error with qt5-qtquick1-devel

Post by jlehtone » 2019/09/01 18:37:16

Your "yum update" does not mention qt quick.

What Qt-packages do you actually have?

Code: Select all

rpm -qa qt5\*
# or
yum list installed qt5\*
The latter command is better in this case.

scaprile
Posts: 2
Joined: 2016/06/27 18:08:26

Re: Dependency error with qt5-qtquick1-devel

Post by scaprile » 2019/09/01 19:23:48

Hi, I can contribute that qt-creator had asked for qt-webkit as a dependency and today's yum update failed. As I'm not currently using qt-creator, I just removed both qt-creator and qt-webkit, but... I might need them in the future.
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
Requires: qt5-qtbase(x86-64) = 5.9.7
Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@base)
qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
Requires: qt5-qtdeclarative(x86-64) = 5.9.7
Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
qt5-qtdeclarative(x86-64) = 5.9.2-1.el7

User avatar
TrevorH
Forum Moderator
Posts: 26864
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Dependency error with qt5-qtquick1-devel

Post by TrevorH » 2019/09/01 19:53:06

I don't know where qt5-quick1-devel comes from, your original yum was asking for qt5-quick1 not -devel. In your latest yum output it isn't complaining about htat package any more anyway, it's now qt5-qtwebkit.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Ziris85
Posts: 5
Joined: 2014/11/19 08:19:15

Re: Dependency error with qt5-qtquick1-devel

Post by Ziris85 » 2019/09/01 23:50:15

Hey there, just thought I'd chime in that I'm having the same trouble here. Looks like the package I installed that needed this was Teamviewer, as that was wanting to go upon attempting to remove:

Code: Select all

==========================================================================================================
 Package                    Arch                 Version                    Repository               Size
==========================================================================================================
Removing:
 qt5-qtwebkit               x86_64               5.9.1-1.el7                @epel                    38 M
Removing for dependencies:
 teamviewer                 x86_64               14.1.9025-0                installed                61 M
Since I use teamviewer, obviously can't do that. I submitted a bug about this so hopefully they'll repackage this and fix the dependency issues:

gsownsby
Posts: 17
Joined: 2014/10/12 16:49:19

Re: Dependency error with qt5-qtquick1-devel

Post by gsownsby » 2019/09/02 00:57:37

Ziris85,

I agree with you. After more research on my own system, it appears this problem is related to Teamviewer.

Thanks to everyone who helped.

Gary

Post Reply

Return to “CentOS 7 - Software Support”