Issue with yum update

Issues related to applications and software problems
Post Reply
akshay
Posts: 2
Joined: 2019/08/31 08:00:31

Issue with yum update

Post by akshay » 2019/09/03 05:16:23

when I tried to update yum package I got this issue
# yum update

...
......
Finished Dependency Resolution
Error: Package: ganglia-gmetad-3.7.2-2.el7.x86_64 (epel)
Requires: libmemcachedutil.so.2()(64bit)
Error: Package: ucx-cuda-1.6.0-1.46101.x86_64 (local)
Requires: libcuda.so.1()(64bit)
Error: Package: ucx-gdrcopy-1.6.0-1.46101.x86_64 (local)
Requires: libgdrapi.so.1()(64bit)
Error: Package: ucx-gdrcopy-1.6.0-1.46101.x86_64 (local)
Requires: libcudart.so.9.2(libcudart.so.9.2)(64bit)
Error: Package: perl-MIME-tools-5.505-1.el7.noarch (epel)
Requires: perl(Mail::Field)
Error: Package: ucx-gdrcopy-1.6.0-1.46101.x86_64 (local)
Requires: libcuda.so.1()(64bit)
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
Requires: qt5-qtbase(x86-64) = 5.9.7
Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@anaconda)
qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: perl-MIME-tools-5.505-1.el7.noarch (epel)
Requires: perl(Mail::Field) >= 1.05
Error: Package: php-ZendFramework-1.12.20-1.el7.noarch (epel)
Requires: php-process
Error: Package: ganglia-gmetad-3.7.2-2.el7.x86_64 (epel)
Requires: libmemcached.so.11()(64bit)
Error: Package: perl-MIME-tools-5.505-1.el7.noarch (epel)
Requires: perl(Mail::Internet) >= 1.28
Error: Package: php-ZendFramework-1.12.20-1.el7.noarch (epel)
Requires: php-xml
Error: Package: ucx-cuda-1.6.0-1.46101.x86_64 (local)
Requires: libcudart.so.9.2()(64bit)
Error: Package: ucx-cuda-1.6.0-1.46101.x86_64 (local)
Requires: libcudart.so.9.2(libcudart.so.9.2)(64bit)
Error: Package: perl-MIME-tools-5.505-1.el7.noarch (epel)
Requires: perl(Mail::Header) >= 1.09
Error: Package: perl-SOAP-Lite-1.10-1.el7.noarch (epel)
Requires: perl(Class::Inspector)
Error: Package: php-ZendFramework-1.12.20-1.el7.noarch (epel)
Requires: php-bcmath
Error: Package: perl-MIME-tools-5.505-1.el7.noarch (epel)
Requires: perl(Mail::Send)
Error: Package: ucx-gdrcopy-1.6.0-1.46101.x86_64 (local)
Requires: libcudart.so.9.2()(64bit)
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
Requires: qt5-qtdeclarative(x86-64) = 5.9.7
Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@local)
qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
intel-conda-ipp-devel-linux-64-shadow-package-2019.3-199-2019.3-199.x86_64 has missing requires of intel-conda-i
iwpmd-17.2-3.el7.x86_64 has missing requires of rdma-core(x86-64) = ('0', '17.2', '3.el7')

User avatar
TrevorH
Forum Moderator
Posts: 26970
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Issue with yum update

Post by TrevorH » 2019/09/03 13:09:35

For some of those errors you are picking up packages from EPEL that have been rebuilt for RHEL 7.7 and the errors are because you are on CentOS 7.6 not 7.7. CentOS 7.7 is not GA yet but you can access the packages that will be released as 7.7 already by enabling the "CR" repo (yum --enablerepo=cr .. on each yum command). Try that and see what errors go away. You might also want to temporarily enable the epel-testing repo at the same time as some of the EPEL packages have been rebuilt but are still waiting to be promoted to the main repo.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”