Newer version of Postfix

Issues related to applications and software problems
Post Reply
Pramodius
Posts: 1
Joined: 2019/09/03 11:51:15

Newer version of Postfix

Post by Pramodius » 2019/09/03 12:05:03

I"m being pressured to install a newer version of postfix (V 2.3 +) that is currently installed in Centos 7 (V 2.1), to enable custom error messages. I'm loath to install an RPM that is newer than the version supplied from the standard Centos Distribution, as I'm not sure what that would break. Am I being paranoid, or is this a reasonable thing to do ?

Thanks !

User avatar
TrevorH
Forum Moderator
Posts: 26933
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: Newer version of Postfix

Post by TrevorH » 2019/09/03 13:07:10

No you're not being paranoid and the "best" version is the one that we ship as it gets regular security updates from Redhat.

However, if you actually require functionality that's in newer versions and has not been backported by Redhat then you either need to find a different way to accomplish the same thing or you need to update. The Ghettoforge third party yum repo has newer copies of postfix in their "extras" repo which is disabled by default when you install their ghettoforge-release package (since it replaces the distro copy).
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”