Need 32-bit packages

Issues related to applications and software problems
Post Reply
JJ Smith
Posts: 3
Joined: 2019/09/04 14:14:59

Need 32-bit packages

Post by JJ Smith » 2019/09/04 14:31:16

I can't figure out how to get .i686 packages installed on the server, nor why sometimes they conflict out with yum and sometimes they don't.

For example, I need yum to install libgcc.i686 on a server, but when I try to install it, yum has it conflict out with the 64-bit and won't install it.

Protected multilib versions: libgcc-4.8.5-36.el7_6.2.i686 != libgcc-4.8.5-11.el7.x86_64

And sure enough if I do a rpm -qa libgcc it lists the 64-bit package:
libgcc-4.8.5-11.el7.x86_64

Yet on the same server yum let me install glibc.i686 without a conflict message as can be seen when I do an rpm-qa glibc on the server:
glibc-2.17-260.el7_6.6.x86_64
glibc-2.17-260.el7_6.6.i686


So why can I have both the 64-bit and 32-bit of glibc, but only the 64-bit of libgcc, or libstdc++?

I need those 32-bit packages for a software install. How can I get them installed? I can't remove the 64-bit packages as they want to remove all sorts of dependencies like yum and such, so it fails an uninstall as well. ... Thanks for considering.

User avatar
avij
Retired Moderator
Posts: 3039
Joined: 2010/12/01 19:25:52
Location: Helsinki, Finland
Contact:

Re: Need 32-bit packages

Post by avij » 2019/09/04 14:53:05

The versions differ. Try yum update first.

JJ Smith
Posts: 3
Joined: 2019/09/04 14:14:59

Re: Need 32-bit packages

Post by JJ Smith » 2019/09/04 15:24:05

Thank you for clarifying the problem.

I always thought it was getting upset about the 64-bit vs the 32-bit, but it's actually the version number difference between the packages that's the problem.

Sure enough, simply updated the 64-bit package first, then could install the 32-bit package.

Thanks again.

Post Reply

Return to “CentOS 7 - Software Support”