python-rope help, for spyder

Issues related to applications and software problems
Post Reply
ron7000
Posts: 120
Joined: 2019/01/15 20:00:28

python-rope help, for spyder

Post by ron7000 » 2019/09/12 13:17:13

I want to install spyder
that requires python-rope

I cannot seem to find python-rope in any repo. In scouring the web I came across python-rope-0.10.2-6.el7.noarch.rpm and python2-rope-0.11.0-1.fc29.noarch.rpm. I installed both of those in centos 7.6 (although I think only "python-rope" was needed) and that then let me yum install spyder

What is the status with spyder, and specifically its dependency python-rope?

I can see python-rope here https://github.com/python-rope/rope
however there is no rpm there and I have no idea how to make use of what is listed at there at github... it seems the current version is 0.14 and I installed 0.10 is there a way to get an rpm of python-rope 0.14 ?

User avatar
TrevorH
Forum Moderator
Posts: 26936
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: python-rope help, for spyder

Post by TrevorH » 2019/09/12 13:20:34

You need to report this to EPEL via bugzilla.redhat.com in the Fedora EPEL section. It gets further if you --enablerepo=cr,epel-testing but still fails. It's an EPEL bug.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

ron7000
Posts: 120
Joined: 2019/01/15 20:00:28

Re: python-rope help, for spyder

Post by ron7000 » 2019/09/12 16:04:16

will do. thanks

Post Reply

Return to “CentOS 7 - Software Support”