requires qt5-qtbase-5.9.7, installed=5.9.2

Issues related to applications and software problems
Post Reply
ron7000
Posts: 120
Joined: 2019/01/15 20:00:28

requires qt5-qtbase-5.9.7, installed=5.9.2

Post by ron7000 » 2019/09/12 17:17:31

I was hoping to install openshot 2.2.4-2.el7 from rpm-fusion.
In trying to I got this

Code: Select all

Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtbase(x86-64) = 5.9.7
           Installed: qt5-qtbase-5.9.2-3.el7.x86_64 (@anaconda)
               qt5-qtbase(x86-64) = 5.9.2-3.el7
Error: Package: qt5-qtwebkit-5.9.1-2.el7.x86_64 (epel)
           Requires: qt5-qtdeclarative(x86-64) = 5.9.7
           Installed: qt5-qtdeclarative-5.9.2-1.el7.x86_64 (@base)
               qt5-qtdeclarative(x86-64) = 5.9.2-1.el7
In a scenario like this, what is going on and what are my options or what should i do?

I tried updating qt5 but there is nothing newer available, so it seems the latest available for centos-7.6 right now is qt5-qtbase-5.9.2.
But the current version of openshot (correct me if i'm wrong) was built with a newer version of qt5? How did they get that?
It's unclear to me why this is happening... did this openshot-2.2.4 just get released before a newer version of qt is available?
It was months ago and on rhel-7.6 a different system I briefly messed with some version of openshot when I learned of openshot, now i have some time and have a different system with centos-7.6 I want to play with openshot some more.
The repo's I'm using (listed on the centos wiki) are base + extras + epel + scl + rpmfusion.

User avatar
TrevorH
Forum Moderator
Posts: 26971
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: requires qt5-qtbase-5.9.7, installed=5.9.2

Post by TrevorH » 2019/09/12 17:22:22

It's due to 7.6->7.7.

You can yum --enablerepo=cr,epel-testing update to get up to date on CR's version of 7.7 and then retry the install with those 2 repos enabled as well.
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

ron7000
Posts: 120
Joined: 2019/01/15 20:00:28

Re: requires qt5-qtbase-5.9.7, installed=5.9.2

Post by ron7000 » 2019/09/12 17:37:44

sorry but what is "CR's" ?

User avatar
TrevorH
Forum Moderator
Posts: 26971
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: requires qt5-qtbase-5.9.7, installed=5.9.2

Post by TrevorH » 2019/09/12 17:44:28

For information on the Continuous Release repository please see https://wiki.centos.org/AdditionalResou ... itories/CR
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

Post Reply

Return to “CentOS 7 - Software Support”