CentOS 7.7 breaks Dovecot, Pure-FTPd, Fail2Ban, Amavisd-new, and postgrey

Issues related to applications and software problems
Post Reply
Pascal666
Posts: 15
Joined: 2013/08/29 15:41:00
Location: Chicagoland

CentOS 7.7 breaks Dovecot, Pure-FTPd, Fail2Ban, Amavisd-new, and postgrey

Post by Pascal666 » 2019/09/19 20:38:56

Just rebooted one of my servers after it updated from 7.6 to 7.7. Dovecot, Pure-FTPd, Fail2Ban, Amavisd-new, and postgrey all failed to start.

If I run 'systemctl start dovecot' then Dovecot actually starts and works perfectly. I can access my email just fine, but 90 seconds later the start command returns "Job for dovecot.service failed because a timeout was exceeded. See "systemctl status dovecot.service" and "journalctl -xe" for details." and "systemctl status dovecot.service" shows:
Sep 19 15:35:11 cvps3820821902 systemd[1]: dovecot.service start operation timed out. Terminating.
Sep 19 15:35:11 cvps3820821902 dovecot[3659]: master: Warning: Killed with signal 15 (by pid=1 uid=0 code=kill)
Sep 19 15:35:11 cvps3820821902 systemd[1]: Failed to start Dovecot IMAP/POP3 email server.
Sep 19 15:35:11 cvps3820821902 systemd[1]: Unit dovecot.service entered failed state.
Sep 19 15:35:11 cvps3820821902 systemd[1]: dovecot.service failed.

It looks like Dovecot actually starts & works fine, but systemd doesn't see that so it kills it.

Logs for the others look similar. Is there a quick way to tell systemd to stop killing things after 90 seconds while I try to figure out what the real problem is?

Pascal666
Posts: 15
Joined: 2013/08/29 15:41:00
Location: Chicagoland

Re: CentOS 7.7 breaks Dovecot, Pure-FTPd, Fail2Ban, Amavisd-new, and postgrey

Post by Pascal666 » 2019/09/19 21:24:15

I tried putting "DefaultTimeoutStartSec=infinity" in both "/etc/systemd/system.conf" and "/etc/systemd/user.conf" and using the "--no-block" command line option with "systemctl start", but that did not work.


tiangou
Posts: 1
Joined: 2019/09/23 20:36:50

Re: CentOS 7.7 breaks Dovecot, Pure-FTPd, Fail2Ban, Amavisd-new, and postgrey

Post by tiangou » 2019/09/23 20:40:31

Thank you @Pascal666.

I spent a few unwanted hours trying to get to the bottom of this and not finding any easy answers online. Figured out what was going on, then came here to post and found your posts.

I'm running CentOS 7.7 on a VPS and this got my Dovecot torqued. It also broke SpamAssassin in a similar way.

Post Reply

Return to “CentOS 7 - Software Support”