Starting samba fails to start on centos 7, despite testparm finding no errors in smb.conf

Issues related to applications and software problems
Post Reply
jringoot
Posts: 3
Joined: 2010/03/01 09:24:41

Starting samba fails to start on centos 7, despite testparm finding no errors in smb.conf

Post by jringoot » 2019/10/07 09:54:52

Running
CentOS Linux release 7.7.1908 (Core)
* updates: ftp.belnet.be
Installed Packages
Name : samba
Arch : x86_64
Version : 4.9.1
Release : 6.el7
Size : 1.9 M
Repo : installed
From repo : base
Summary : Server and Client software to interoperate with Windows machines
URL : http://www.samba.org/
Licence : GPLv3+ and LGPLv3+
Description : Samba is the standard Windows interoperability suite of programs for Linux and
: Unix.




This is the result of journalctl -xe
--
-- Unit smb.service has begun starting up.
Oct 07 11:39:35 myserver.mydomain smbd[13796]: [2019/10/07 11:39:35.318978, 0] ../source3/auth/auth_util.c:1382(make_new_session_info_guest)
Oct 07 11:39:35 myserver.mydomain smbd[13796]: create_local_token failed: NT_STATUS_NO_MEMORY
Oct 07 11:39:35 myserver.mydomain smbd[13796]: [2019/10/07 11:39:35.319381, 0] ../source3/smbd/server.c:2000(main)
Oct 07 11:39:35 myserver.mydomain smbd[13796]: ERROR: failed to setup guest info.
Oct 07 11:39:35 myserver.mydomain systemd[1]: smb.service: main process exited, code=exited, status=255/n/a
Oct 07 11:39:35 myserver.mydomain systemd[1]: Failed to start Samba SMB Daemon.
-- Subject: Unit smb.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/li ... temd-devel
--
-- Unit smb.service has failed.
--
-- The result is failed.
Oct 07 11:39:35 myserver.mydomain systemd[1]: Unit smb.service entered failed state.
Oct 07 11:39:35 myserver.mydomain systemd[1]: smb.service failed.
Oct 07 11:39:35 myserver.mydomain polkitd[27695]: Unregistered Authentication Agent for unix-process:13790:51755362 (system bus name :1.3142, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, local
And this is the output of tesparm:

testparm /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Processing section "[Anonymous]"
Loaded services file OK.
Server role: ROLE_DOMAIN_MEMBER

Press enter to see a dump of your service definitions

# Global parameters
And the globals parameters but those have no errors either,

Any tips on how to troubleshoot this are welcome

Post Reply

Return to “CentOS 7 - Software Support”