centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Issues related to applications and software problems
Post Reply
ralf
Posts: 107
Joined: 2005/11/25 20:10:20

centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Post by ralf » 2019/10/27 15:30:06

Hi
I have new centos8 server with gutenprint-cups 5.2.14 and an centos7 client machine running gutenprint-cups 5.2.9.
The centos7 client cannot print to the shared printer on the centos8 printer:
The error is "The PPD version (5.2.14 Simplified) is not compatible with Gutenprint 5.2.9."
Other machines, like Mac, can print on the printer on centos8 without any problems.
I tried to install the gutenprint 5.2.14 on the centos7 machine (from source through configure; make; make install) and that installs nicely, but the new 5.2.14 PPD files do not show up in the list of driver to chose from. I still only see the 5.2.9 drivers.
What am I missing here? How do I solve this?

Thanks for any help!
/Ralf

ralf
Posts: 107
Joined: 2005/11/25 20:10:20

Re: centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Post by ralf » 2019/10/29 18:27:38

As I have not received any suggestions regarding how to solve the incompatibility issue of gutenprint and gutenprint-cups between Centos7 client and Centos8 server, I wonder if I could downgrade gutenprint/gutenprint-cup on Centos8 from version 5.2.14 to 5.2.9 (used in Centos7).
That would most likely solve my problems. Can I just remove the 5.2.14 packages and force-install the centos7 version 5.2.9?
Is a "force-install" possible?

Any comments or suggestions?
Many thanks in advance.

/Ralf

User avatar
TrevorH
Forum Moderator
Posts: 26942
Joined: 2009/09/24 10:40:56
Location: Brighton, UK

Re: centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Post by TrevorH » 2019/10/29 18:36:26

No, don't do that. It's the wrong solution.

Did you see things like https://forum.manjaro.org/t/solved-cups ... 2-13/30502
CentOS 5 died in March 2017 - migrate NOW!
CentOS 6 goes EOL sooner rather than later, get upgrading!
Full time Geek, part time moderator. Use the FAQ Luke

ralf
Posts: 107
Joined: 2005/11/25 20:10:20

Re: centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Post by ralf » 2019/10/31 13:47:20

Trevor, thanks for replying!

My problem has similarities with the post above you refer to, but it is not the same.
Let me report what I have tried so far.

In short, when installing printer EPSON Stylus Photo R285 on the server, either through Cups webinterface or using Centos8 own printer interface (devices -> printer), the printer is found and installed. I then Go to my Mac and the epson is "bonjour shared" on the network, it finds it and installs it perfectly and it works. No problem. I even can print from my android 9 phone using ipp://192.168.1.94:631/printers/Stylus-Photo-R285. It prints nicely from the android. So far so good.

Now, when installing this centos8 server printer on centos7 client, this is were it becomes weird.
I can install it on the centos7 client, as in centos8, using the centos interface (devices--> printers) or via Cups web interface. It finds the printer on the server, installs it, but cannot print.
I can send file to printer, gives message on client "printing started" (or similar) then message appears: "printing is stopped".
When looking via cups web interface into the printer on the centos7 client:
Stylus-Photo-R285-54 Unknown Withheld 11k Unknown stopped
"The PPD version (5.2.14 Simplified) is not compatible with Gutenprint 5.2.9."
The PPD file seems to get installed from the server when installing the printer on the client centos7.

So, I modify the printer on the centos7 client (as in the referred post), to use gutenprint 5.2.9 Simplified (instead of 5.2.14 on the centos8 server) and cancel the old stopped job.
I print test page from CUPS system on centos7 client. Checking job-id:
Stylus-Photo-R285-55 Unknown Withheld 1k Unknown completed at ons 30 okt 2019 22:14:31; but nothing is printed.
Client seems to think job is done. Nothing is printed though! NO error messages on centos8 server either. /var/log/cups/error-log is empty.

As soon as I try to print from the centos7 client or locally on the centos8 server, after printing from the Mac, cups on centos client and server says the job is "completed", but nothing is printed. No error messages on centos7 client or centos8 server. At this stage, the Mac cannot print anymore to the server either, though it says: job completed and no error messages.

No matter what I do, use Cups web interface or the built in centos interface, I cannot get the centos7 client nor the Mac printing anymore to the centos8 server... Only way out is to delete all printers on the server and on the mac (and also on centos7 client) and then reinstall on server and mac.
Again, as soon as I try to print from the centos7 client (re-installed printer with gutenrprint 5.2.9), cups says the job is completed, but nothing is printed. No error messages on centos7 client or centos8 server. I did this several times and always the same result.
Changing printer USB port on the server did not make any difference.

After reinstalling printer on server and Mac, I can print once from the Mac, but then after printing, the mMac says: Printer is Offline.
but on server:
[root@server1-hartings-se cups]# lpstat -t
scheduler is running
no system default destination
device for Stylus-Photo-R285: usb://EPSON/Stylus%20Photo%20R285?serial=573134503147B36895
Stylus-Photo-R285 accepting requests since Thu 31 Oct 2019 05:03:40 PM CET
printer Stylus-Photo-R285 is idle. enabled since Thu 31 Oct 2019 05:03:40 PM CET
[root@server1-hartings-se cups]#
When trying to print again from the Mac, the Mac tells me it's looking for the printer. After every time I print, I need to delete and reinstall all printers and I have one chance to print....

So I am really stuck; it looks like the centos8 printer setting is getting corrupt, when getting jobs from the centos7 client, and disconnected ("offline") after one single print from the Mac. Something is really wrong, most likely on the centos8 server, as I had no problems when my main server was running centos7.

For now, I have given up my attempts, as I ran out of ideas. Any suggestions from your side?

Thanks
Ralf

ralf
Posts: 107
Joined: 2005/11/25 20:10:20

Re: centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Post by ralf » 2019/11/01 16:33:25

Today's update and summary of situation:

On server (192.168.1.94) , printing on locally installed printer Stylus-Photo-R285, works fine:
more /var/log/messages | grep print ->
Nov 1 14:16:36 server1-hartings-se cupsd[1617]: Started filter /usr/lib/cups/filter/rastertogutenprint.5.2 (PID 23344)
Nov 1 14:16:36 server1-hartings-se cupsd[1617]: REQUEST localhost - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 11552 Print-Job successful-ok

[root@server1-hartings-se ~]# systemctl status *print*
● system-configurex2dprinter.slice
Loaded: loaded
Active: active since Fri 2019-11-01 14:22:46 CET; 4s ago
Tasks: 0
Memory: 0B
CGroup: /system.slice/system-configurex2dprinter.slice

Nov 01 14:22:46 server1-hartings-se systemd[1]: Created slice system-configurex2dprinter.slice.

● printer.target - Printer
Loaded: loaded (/usr/lib/systemd/system/printer.target; static; vendor preset: disabled)
Active: active since Fri 2019-11-01 14:22:13 CET; 37s ago
Docs: man:systemd.special(7)

Nov 01 14:22:13 server1-hartings-se systemd[1]: Stopping Printer.
Nov 01 14:22:13 server1-hartings-se systemd[1]: Reached target Printer.

● system-configure\x2dprinter.slice
Loaded: loaded
Active: active since Fri 2019-11-01 13:46:57 CET; 35min ago
Tasks: 0
Memory: 3.6M
CGroup: /system.slice/system-configure\x2dprinter.slice

Nov 01 13:46:57 server1-hartings-se systemd[1]: Created slice system-configure\x2dprinter.slice.
Nov 01 13:47:01 server1-hartings-se udev-configure-printer[1450]: add usb-001-002
Nov 01 13:47:01 server1-hartings-se udev-configure-printer[1450]: device devpath is /devices/pci0000:00/0000:00:12.2/usb1/1-4
Nov 01 13:47:01 server1-hartings-se udev-configure-printer[1450]: MFG:EPSON MDL:Stylus Photo R285 SERN:- serial:573134503147B36895

On iMac client (192.168.1.109):
- when using local epson driver on Mac for printer on server via ipp://192.168.1.94:631/printers/Stylus-Photo-R285, doesn't print, but no errors reported
- when choosing "generic postscript driver" on mac prints, but only grayscale and only letter size (which I can't change).

On server:
more /var/log/messages | grep print ->
Nov 1 14:27:16 server1-hartings-se cupsd[1617]: REQUEST 192.168.1.109 - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 243 Validate-Job successful-ok
Nov 1 14:27:16 server1-hartings-se cupsd[1617]: REQUEST 192.168.1.109 - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 192 Create-Job successful-ok
Nov 1 14:27:16 server1-hartings-se cupsd[1617]: Started filter /usr/lib/cups/filter/rastertogutenprint.5.2 (PID 26046)
Nov 1 14:27:16 server1-hartings-se cupsd[1617]: REQUEST 192.168.1.109 - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 40172 Send-Document successful-ok
[root@server1-hartings-se ~]#

On centos7 (192.168.1.95) client, using server printer as ipp://192.168.1.94:631/printers/Stylus-Photo-R285, nothing is printed, but no errors reported ...:
more /var/log/messages | grep print ->
Nov 1 14:36:07 elly dbus[1087]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service'
Nov 1 14:36:07 elly systemd: Starting Fingerprint Authentication Daemon...
Nov 1 14:36:07 elly dbus[1087]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 1 14:36:07 elly systemd: Started Fingerprint Authentication Daemon.
Nov 1 14:40:31 elly dbus[1087]: [system] Activating via systemd: service name='net.reactivated.Fprint' unit='fprintd.service'
Nov 1 14:40:31 elly systemd: Starting Fingerprint Authentication Daemon...
Nov 1 14:40:31 elly dbus[1087]: [system] Successfully activated service 'net.reactivated.Fprint'
Nov 1 14:40:31 elly systemd: Started Fingerprint Authentication Daemon.


On server, get's request from centos7 client, but doesn't print:
more /var/log/messages | grep print ->
Nov 1 14:37:17 server1-hartings-se cupsd[1617]: REQUEST 192.168.1.95 - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 248 Validate-Job successful-ok
Nov 1 14:37:17 server1-hartings-se cupsd[1617]: REQUEST 192.168.1.95 - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 201 Create-Job successful-ok
Nov 1 14:37:17 server1-hartings-se cupsd[1617]: Started filter /usr/lib/cups/filter/rastertogutenprint.5.2 (PID 28342)
Nov 1 14:37:17 server1-hartings-se cupsd[1617]: REQUEST 192.168.1.95 - - "POST /printers/Stylus-Photo-R285 HTTP/1.1" 200 30439 Send-Document successful-ok
[root@server1-hartings-se cups]#

So I can only print locally on server now; centos clients, nor Mac client can print, though clients and server say that printing is done, but nothing is printed.....

I hope somebody has a good advice here, as I have no ideas left and think about changing the motherboard (due to other sata disk problems, see posting.php?mode=reply&f=54&t=72341).

Anyone?

Can it be a hardware issue?

ralf
Posts: 107
Joined: 2005/11/25 20:10:20

Re: centos7 Gutenprint not compatible with centos8 Gutenprint -> cups not working

Post by ralf » 2019/11/01 18:55:04

I have now installed the same epson printer on my backup server running centos7. And it prints locally and from the others centos7 clients and the Mac !
So it is a centos8 problem related to cups or a hardware problem on my main server.

Post Reply

Return to “CentOS 7 - Software Support”